aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/etherape
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:32:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:32:10 +0000
commit6e692f8c612db84d451a5aa01226ef9ba1b7504b (patch)
tree5f614ca9ad470a3fcda656eef2eaa9405dd219bd /net-mgmt/etherape
parent5686389b98212013d2237391a648219657c62e33 (diff)
downloadports-6e692f8c612db84d451a5aa01226ef9ba1b7504b.tar.gz
ports-6e692f8c612db84d451a5aa01226ef9ba1b7504b.zip
- Update to 0.9.13
PR: 188862 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=352214
Diffstat (limited to 'net-mgmt/etherape')
-rw-r--r--net-mgmt/etherape/Makefile28
-rw-r--r--net-mgmt/etherape/distinfo4
-rw-r--r--net-mgmt/etherape/files/patch-src__decocde_proto.c18
-rw-r--r--net-mgmt/etherape/files/patch-src__names.c21
-rw-r--r--net-mgmt/etherape/files/patch-src_decode_proto.c11
-rw-r--r--net-mgmt/etherape/pkg-plist28
6 files changed, 63 insertions, 47 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index d5b0ce961169..67a90783417c 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -2,35 +2,21 @@
# $FreeBSD$
PORTNAME= etherape
-PORTVERSION= 0.9.9
-PORTREVISION= 2
+PORTVERSION= 0.9.13
CATEGORIES= net-mgmt gnome
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical network traffic visualization tool for gnome
-USE_GNOME= libglade2 libgnomeui gnomehack gnomeprefix gnomedocutils
-USES= gmake pkgconfig
-INSTALLS_OMF= yes
+LICENSE= GPLv2
+
+USES= gettext gmake iconv pathfix pkgconfig
+USE_GNOME= gnomedocutils gnomehier libglade2 libgnomeui
GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= etherape.1
-
-NO_STAGE= yes
-
-OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
.include <bsd.port.mk>
diff --git a/net-mgmt/etherape/distinfo b/net-mgmt/etherape/distinfo
index 7909685ae75f..3b4f6aaa72ef 100644
--- a/net-mgmt/etherape/distinfo
+++ b/net-mgmt/etherape/distinfo
@@ -1,2 +1,2 @@
-SHA256 (etherape-0.9.9.tar.gz) = 2f9b5a2fdfd62940fd20cb2d2536255337eb9b0cfd210457844cc8ac5117feec
-SIZE (etherape-0.9.9.tar.gz) = 1301421
+SHA256 (etherape-0.9.13.tar.gz) = 2a3d2a28b824ce4797529bb90d19a213d80e70f5b3f0cc5f455379aac31c09f7
+SIZE (etherape-0.9.13.tar.gz) = 1399211
diff --git a/net-mgmt/etherape/files/patch-src__decocde_proto.c b/net-mgmt/etherape/files/patch-src__decocde_proto.c
new file mode 100644
index 000000000000..e1bc96de9f01
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src__decocde_proto.c
@@ -0,0 +1,18 @@
+--- src/decode_proto.c.orig
++++ src/decode_proto.c
+@@ -27,6 +27,15 @@
+ #include "appdata.h"
+ #include <ctype.h>
+ #include <string.h>
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_SOCKET_H
++#include <sys/socket.h>
++#endif
++#ifdef HAVE_NETINET_IN_H
++#include <netinet/in.h>
++#endif
+ #ifdef HAVE_ARPA_INET_H
+ #include <arpa/inet.h>
+ #endif
diff --git a/net-mgmt/etherape/files/patch-src__names.c b/net-mgmt/etherape/files/patch-src__names.c
new file mode 100644
index 000000000000..d005e2025ec3
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src__names.c
@@ -0,0 +1,21 @@
+--- src/names.c.orig
++++ src/names.c
+@@ -21,7 +21,18 @@
+ #include <config.h>
+ #endif
+
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_SOCKET_H
++#include <sys/socket.h>
++#endif
++#ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
++#endif
++#ifdef HAVE_ARPA_INET_H
++#include <arpa/inet.h>
++#endif
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
diff --git a/net-mgmt/etherape/files/patch-src_decode_proto.c b/net-mgmt/etherape/files/patch-src_decode_proto.c
deleted file mode 100644
index 118528986c22..000000000000
--- a/net-mgmt/etherape/files/patch-src_decode_proto.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/decode_proto.c.orig 2010-04-14 16:16:43.000000000 -0300
-+++ src/decode_proto.c 2010-04-14 16:17:57.000000000 -0300
-@@ -165,7 +165,7 @@
- {"WLAN", DLT_IEEE802_11, LINK6, get_wlan },
- /* Wireless with radiotap header */
- {"WLAN+RTAP", DLT_IEEE802_11_RADIO, LINK6, get_radiotap },
-- {"PPI", DLT_PPI, LINK6, get_ppi }, /* PPI encapsulation */
-+ /* {"PPI", DLT_PPI, LINK6, get_ppi }, PPI encapsulation */
- {NULL, 0, 0 } /* terminating entry, must be last */
- };
-
diff --git a/net-mgmt/etherape/pkg-plist b/net-mgmt/etherape/pkg-plist
index e6ac4a3cd75d..8e885c54bdef 100644
--- a/net-mgmt/etherape/pkg-plist
+++ b/net-mgmt/etherape/pkg-plist
@@ -1,6 +1,10 @@
bin/etherape
-etc/etherape/services
+%%ETCDIR%%/services
+man/man1/etherape.1.gz
share/applications/etherape.desktop
+%%DATADIR%%/glade/etherape.glade
+%%DATADIR%%/glade/etherape.png
+%%DATADIR%%/glade/nodes.xpm
share/gnome/help/etherape/C/etherape.xml
share/gnome/help/etherape/C/figures/all_nodes.eps
share/gnome/help/etherape/C/figures/all_nodes.png
@@ -22,25 +26,23 @@ share/gnome/help/etherape/C/figures/pref_diagram_dlg.eps
share/gnome/help/etherape/C/figures/pref_diagram_dlg.png
share/gnome/help/etherape/C/figures/pref_timings_dlg.eps
share/gnome/help/etherape/C/figures/pref_timings_dlg.png
-share/gnome/help/etherape/C/figures/protocol_edit_dlg.eps
-share/gnome/help/etherape/C/figures/protocol_edit_dlg.png
share/gnome/help/etherape/C/figures/proto_info.eps
share/gnome/help/etherape/C/figures/proto_info.png
+share/gnome/help/etherape/C/figures/protocol_edit_dlg.eps
+share/gnome/help/etherape/C/figures/protocol_edit_dlg.png
+share/locale/de/LC_MESSAGES/etherape.mo
+share/locale/es/LC_MESSAGES/etherape.mo
+share/locale/fr/LC_MESSAGES/etherape.mo
+share/locale/it/LC_MESSAGES/etherape.mo
+share/locale/nl/LC_MESSAGES/etherape.mo
+share/locale/sv/LC_MESSAGES/etherape.mo
+share/locale/tr/LC_MESSAGES/etherape.mo
share/omf/etherape/etherape-C.omf
share/pixmaps/etherape.png
-%%DATADIR%%/glade/etherape.glade
-%%DATADIR%%/glade/etherape.png
-%%DATADIR%%/glade/pause.xpm
-%%DATADIR%%/glade/play.xpm
-%%DATADIR%%/glade/stop.xpm
-%%NLS%%share/locale/es/LC_MESSAGES/etherape.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/etherape.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/etherape.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/etherape.mo
@dirrm share/omf/etherape
@dirrm share/gnome/help/etherape/C/figures
@dirrm share/gnome/help/etherape/C
@dirrm share/gnome/help/etherape
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
-@dirrm etc/etherape
+@dirrm %%ETCDIR%%