aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/etherape
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-10 17:17:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-04-10 17:17:25 +0000
commit9e0b4328d2bb0a6d44a5610b08650a8a317b2645 (patch)
tree2064cd2ab3545ea889c4bbd1749935076fea5398 /net-mgmt/etherape
parent9c189ac118175e5f035a0e74b0db880287934e29 (diff)
downloadports-9e0b4328d2bb0a6d44a5610b08650a8a317b2645.tar.gz
ports-9e0b4328d2bb0a6d44a5610b08650a8a317b2645.zip
Fix broken GUI due to infamous "libglade-WARNING **: could not find signal
handler" errors. This usually happens when signal handlers are not being exported correctly (via G_MODULE_EXPORT), but I'd leave it for upstream to decide how to come up with a proper fix. For now, adding `-export-dynamic' to LDFLAGS is probably OK for a quick'n'dirty remedy. While here: rephrase COMMENT text, install a few documentation files, and reformat and amend port description text. PR: 199139
Notes
Notes: svn path=/head/; revision=383745
Diffstat (limited to 'net-mgmt/etherape')
-rw-r--r--net-mgmt/etherape/Makefile18
-rw-r--r--net-mgmt/etherape/pkg-descr13
2 files changed, 22 insertions, 9 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index 0cb380f26679..b8e6db67d2a0 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -3,12 +3,12 @@
PORTNAME= etherape
PORTVERSION= 0.9.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt gnome
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= Graphical network traffic visualization tool for gnome
+COMMENT= Graphical network traffic monitor tool modeled after Etherman
LICENSE= GPLv2
@@ -18,6 +18,18 @@ GNU_CONFIGURE= yes
INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -export-dynamic # XXX: G_MODULE_EXPORT?
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} FAQ README* TODO ${STAGEDIR}${DOCSDIR}
+.for f in AUTHORS ChangeLog NEWS
+ ${ICONV_CMD} -f latin1 -t utf-8 ${WRKSRC}/${f} > \
+ ${STAGEDIR}${DOCSDIR}/${f}
+.endfor
.include <bsd.port.mk>
diff --git a/net-mgmt/etherape/pkg-descr b/net-mgmt/etherape/pkg-descr
index f26741ea2b51..53b3915fbb71 100644
--- a/net-mgmt/etherape/pkg-descr
+++ b/net-mgmt/etherape/pkg-descr
@@ -1,8 +1,9 @@
-EtherApe is a graphical network monitor for Unix modeled after etherman.
-Featuring ether, ip and tcp modes, it displays network activity
-graphically. Hosts and links change in size with traffic. Color coded
-protocols display. It supports ethernet, fddi, ppp and slip devices.
-It can filter traffic to be shown, and can read traffic from a
-file as well as live from the network.
+EtherApe is a graphical network monitor for Unix modeled after Etherman.
+Featuring link layer, IP and TCP modes, it displays network activity
+graphically. Hosts and links change in size with traffic. Color coded
+protocols display. It supports Ethernet, FDDI, Token Ring, ISDN, PPP,
+SLIP, and WLAN devices, plus several encapsulation formats. It can
+filter traffic to be shown, and can read packets from a file as well as
+live from the network. Node statistics can be exported.
WWW: http://etherape.sourceforge.net/