aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ettercap
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-14 17:47:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-14 17:47:55 +0000
commita437f26f3e51fa81b9bac27266d889a60e942237 (patch)
tree6c085a3ecb74cbb29b6a135d88fe3c335bcb1aad /net-mgmt/ettercap
parent5fcde2efe3a88fbe1208af3f1a230b33d411b56f (diff)
downloadports-a437f26f3e51fa81b9bac27266d889a60e942237.tar.gz
ports-a437f26f3e51fa81b9bac27266d889a60e942237.zip
- Fix PLIST
- Use @sample - Convert to new options helper - Simplify Makefile - Bump PORTREVISION for package change
Notes
Notes: svn path=/head/; revision=361804
Diffstat (limited to 'net-mgmt/ettercap')
-rw-r--r--net-mgmt/ettercap/Makefile13
-rw-r--r--net-mgmt/ettercap/pkg-plist9
2 files changed, 10 insertions, 12 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index a2f3a2d8f3cd..b26cab9d3870 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ettercap
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net-mgmt security
@@ -26,6 +26,7 @@ CMAKE_ARGS= -DBUNDLED_LIBS=OFF \
-DHAVE_LIBNET=${LOCALBASE}/lib/libnet11 \
-DHAVE_PCAP=${LIBDIR} \
-DHAVE_RESOLV=${LIBDIR} \
+ -DINSTALL_SYSCONFDIR=${PREFIX}/etc \
-DLIBNET_INCLUDE_DIR=${LOCALBASE}/include/libnet11 \
-DLIBNET_LIB_DIR=${LOCALBASE}/lib/libnet11 \
-DLIBNET_LIBRARY=${LOCALBASE}/lib/libnet11 \
@@ -61,9 +62,10 @@ PCRE_CMAKE_OFF= -DHAVE_PCRE=OFF
PCRE_CMAKE_ON= -DHAVE_PCRE=ON
PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PLUGINS_BUILD_DEPENDS= curl>=7.26.0:${PORTSDIR}/ftp/curl
-PLUGINS_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
PLUGINS_CMAKE_OFF= -DENABLE_PLUGINS=OFF
PLUGINS_CMAKE_ON= -DENABLE_PLUGINS=ON
+PLUGINS_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+PLUGINS_USE_OFF= LDCONFIG=yes
SSL_CMAKE_OFF= -DENABLE_SSL=OFF
SSL_CMAKE_ON= -DENABLE_SSL=ON
SSL_USE= OPENSSL=yes
@@ -77,18 +79,11 @@ UTF8_USES= iconv
.if ${PORT_OPTIONS:MPLUGINS}
USE_LDCONFIG= ${PREFIX}/lib/ettercap
DOCS+= doc/plugins
-.else
-USE_LDCONFIG= yes
.endif
post-install:
${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${STAGEDIR}${PREFIX}/etc/etter.conf.sample
-.if !exists(${PREFIX}/etc/etter.conf)
- ${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${STAGEDIR}${PREFIX}/etc/etter.conf
-.endif
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/ettercap/pkg-plist b/net-mgmt/ettercap/pkg-plist
index ec3cf61840f4..a9c21d15d178 100644
--- a/net-mgmt/ettercap/pkg-plist
+++ b/net-mgmt/ettercap/pkg-plist
@@ -2,9 +2,11 @@ bin/ettercap
%%DESKTOP%%bin/ettercap-pkexec
bin/etterfilter
bin/etterlog
-@unexec if cmp -s %D/etc/etter.conf.sample %D/etc/etter.conf; then rm -f %D/etc/etter.conf; else echo "If permanently deleting this package, %D/etc/etter.conf must be removed manually."; fi
-etc/etter.conf.sample
-@exec [ -f %B/etter.conf ] || cp %B/%f %B/etter.conf
+@sample etc/etter.conf.sample
+%%ETCDIR%%/etter.conf
+%%ETCDIR%%/etter.dns
+%%ETCDIR%%/etter.mdns
+%%ETCDIR%%/etter.nbns
%%PLUGINS%%lib/ettercap/ec_arp_cop.so
%%PLUGINS%%lib/ettercap/ec_autoadd.so
%%PLUGINS%%lib/ettercap/ec_chk_poison.so
@@ -84,3 +86,4 @@ man/man8/etterlog.8.gz
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PLUGINS%%@dirrm lib/ettercap
+@dirrm %%ETCDIR%%