aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fastnetmon
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2017-05-22 13:35:00 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2017-05-22 13:35:00 +0000
commit2c20262b31d7c9a2dd9ec11639e9e1695fb1325a (patch)
treebd4584ad4b295a2626fd94fff9c5b918a081f535 /net-mgmt/fastnetmon
parentcbfa306f08f1ad226d893241aed90775beea3465 (diff)
downloadports-2c20262b31d7c9a2dd9ec11639e9e1695fb1325a.tar.gz
ports-2c20262b31d7c9a2dd9ec11639e9e1695fb1325a.zip
net-mgmt/fastnetmon: add dependency for libbison and remove ndpi support (broken)
Reported by: Mihai <mihaigabriel@gmail.com> Reviewed by: mat Approved by: mat Differential Revision: https://reviews.freebsd.org/D10644
Notes
Notes: svn path=/head/; revision=441457
Diffstat (limited to 'net-mgmt/fastnetmon')
-rw-r--r--net-mgmt/fastnetmon/Makefile6
-rw-r--r--net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt9
2 files changed, 11 insertions, 4 deletions
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index 5d853a84e9b9..5db2ed3c9453 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fastnetmon
PORTVERSION= 1.1.3
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt security
MAINTAINER= farrokhi@FreeBSD.org
@@ -15,10 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp \
- libndpi.so:net/ndpi \
libluajit-5.1.so:lang/luajit \
libmongoc-1.0.so:devel/mongo-c-driver \
- libjson-c.so:devel/json-c
+ libjson-c.so:devel/json-c \
+ libbson-1.0.so:devel/libbson
USE_GITHUB= yes
GH_ACCOUNT= pavel-odintsov
diff --git a/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt b/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt
index 0fe64953a76f..592aac6fe0fe 100644
--- a/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt
+++ b/net-mgmt/fastnetmon/files/patch-src_CMakeLists.txt
@@ -35,7 +35,14 @@
set(FASTNETMON_PROFILER OFF)
-@@ -190,15 +199,15 @@ if (ENABLE_DPI_SUPPORT)
+@@ -184,21 +193,21 @@ add_library(sflow_plugin STATIC sflow_pl
+ add_library(netflow_plugin STATIC netflow_plugin/netflow_collector.cpp)
+ target_link_libraries(netflow_plugin ipfix_rfc)
+
+-set(ENABLE_DPI_SUPPORT YES)
++#set(ENABLE_DPI_SUPPORT YES)
+ if (ENABLE_DPI_SUPPORT)
+ message(STATUS "We will enable nDPI support")
add_library(fast_dpi STATIC fast_dpi.cpp)