aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-11-08 23:09:46 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-11-08 23:09:46 +0000
commit72d55b0a509fea38ebfac5c6ab7c02daa1b80874 (patch)
treef1047d65febb148fc88c260c8058a26956bf8559 /net-mgmt/flow-tools
parent4d49570e6fbc5fa7a8c2a4da5374c0e6af6debbd (diff)
downloadports-72d55b0a509fea38ebfac5c6ab7c02daa1b80874.tar.gz
ports-72d55b0a509fea38ebfac5c6ab7c02daa1b80874.zip
- Fix flow-capture on amd64
- Bump portrevision. PR: ports/116677 Submitted by: Michael W Lucas <mwlucas@blackhelicopters.org> Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=202599
Diffstat (limited to 'net-mgmt/flow-tools')
-rw-r--r--net-mgmt/flow-tools/Makefile2
-rw-r--r--net-mgmt/flow-tools/files/patch-lib-ftfile.c13
-rw-r--r--net-mgmt/flow-tools/files/patch-lib_ftlib.h24
3 files changed, 36 insertions, 3 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 7b3b49618d02..a1ed32e0426d 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
diff --git a/net-mgmt/flow-tools/files/patch-lib-ftfile.c b/net-mgmt/flow-tools/files/patch-lib-ftfile.c
index 0418caa8ac0a..dae753aec696 100644
--- a/net-mgmt/flow-tools/files/patch-lib-ftfile.c
+++ b/net-mgmt/flow-tools/files/patch-lib-ftfile.c
@@ -1,5 +1,5 @@
---- lib/ftfile.c.orig Thu Feb 13 05:38:42 2003
-+++ lib/ftfile.c Fri Feb 10 10:39:40 2006
+--- lib/ftfile.c.orig 2003-02-13 05:38:42.000000000 +0300
++++ lib/ftfile.c 2007-11-09 01:07:46.000000000 +0300
@@ -311,7 +311,7 @@
int ftfile_expire (struct ftfile_entries *fte, int doit, int curbytes)
{
@@ -75,6 +75,15 @@
} /* if */
if (debug)
+@@ -499,7 +517,7 @@
+ * returns -1 on error
+ *
+ */
+-int ftfile_mkpath(u_int32 ftime, int nest)
++int ftfile_mkpath(time_t ftime, int nest)
+ {
+ struct tm *tm;
+ char buf[32];
@@ -762,13 +780,19 @@
{
struct ftfile_entry *n1, *n2;
diff --git a/net-mgmt/flow-tools/files/patch-lib_ftlib.h b/net-mgmt/flow-tools/files/patch-lib_ftlib.h
new file mode 100644
index 000000000000..297f70eca48c
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-lib_ftlib.h
@@ -0,0 +1,24 @@
+--- lib/ftlib.h.orig Wed Sep 26 16:21:50 2007
++++ lib/ftlib.h Wed Sep 26 16:21:23 2007
+@@ -416,8 +416,8 @@
+ };
+
+ struct fttime {
+- u_int32 secs;
+- u_int32 msecs;
++ time_t secs;
++ time_t msecs;
+ };
+
+ struct ftver {
+@@ -2710,7 +2710,7 @@
+ int ftfile_dump(struct ftfile_entries *fte);
+ struct ftfile_entry *ftfile_entry_new(int len);
+ void ftfile_entry_free(struct ftfile_entry *entry);
+-int ftfile_mkpath(u_int32 ftime, int nest);
++int ftfile_mkpath(time_t ftime, int nest);
+ void ftfile_pathname(char *buf, int bsize, int nest, struct ftver ftv,
+ int done, u_int32 ftime);
+
+
+--XsQoSWH+UP9D9v3l--