aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-tools
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-07-22 06:09:52 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-07-22 06:09:52 +0000
commitf7f2a8eab8e27a3a6373e8b175a5b8594242f8f1 (patch)
tree189c8ffb298c99ac3820615ea31d18016f89a2f2 /net-mgmt/flow-tools
parent9ef88c205bd3d56990f11cdfb4b66b6f6314e9da (diff)
downloadports-f7f2a8eab8e27a3a6373e8b175a5b8594242f8f1.tar.gz
ports-f7f2a8eab8e27a3a6373e8b175a5b8594242f8f1.zip
net-mgmt/flow-tools: Fix run with python3
- Pet portlint PR: 247437 Submitted by: andrew.hotlab@hotmail.com
Notes
Notes: svn path=/head/; revision=542834
Diffstat (limited to 'net-mgmt/flow-tools')
-rw-r--r--net-mgmt/flow-tools/Makefile41
1 files changed, 23 insertions, 18 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index fa8ca03d309c..5dbcfd7ff280 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= flow-tools
PORTVERSION= 0.68.6
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MAINTAINER= bofh@FreeBSD.org
@@ -15,32 +15,37 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man
-USES= autoreconf libtool:keepla python:run shebangfix
+USES= autoreconf libtool:keepla python:2.7 shebangfix
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= flow_capture flow_fanout
-OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
-PGSQL_CONFIGURE_ON= --with-postgresql
-PGSQL_USES= pgsql
-MYSQL_CONFIGURE_ON= --with-mysql="${LOCALBASE}"
-MYSQL_USES= mysql
-OPENSSL_CONFIGURE_ON= --with-openssl="${OPENSSLBASE}"
-OPENSSL_USES= ssl
+GH_ACCOUNT= 5u623l20
+GH_TAGNAME= 6e7c849
SHEBANG_FILES= bin/flow-*
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_GITHUB= yes
-GH_ACCOUNT= 5u623l20
-GH_TAGNAME= 6e7c849
-SUB_LIST= FLOW_CAPTURE_SPOOL="${FLOW_CAPTURE_SPOOL}" \
- FLOW_CAPTURE_PIDDIR="${FLOW_CAPTURE_PIDDIR}"
-USE_RC_SUBR= flow_capture flow_fanout
+SUB_LIST= FLOW_CAPTURE_PIDDIR="${FLOW_CAPTURE_PIDDIR}" \
+ FLOW_CAPTURE_SPOOL="${FLOW_CAPTURE_SPOOL}"
+
+USERS= flowtools
+GROUPS= flowtools
VARDIR?= /var
FLOW_CAPTURE_SPOOL= ${VARDIR}/db/flows
FLOW_CAPTURE_PIDDIR= ${VARDIR}/run/flow-capture
-USERS= flowtools
-GROUPS= flowtools
+OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
+
+MYSQL_USES= mysql
+MYSQL_CONFIGURE_ON= --with-mysql="${LOCALBASE}"
+OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_ON= --with-openssl="${OPENSSLBASE}"
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ON= --with-postgresql
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libft.so.0.0.0
.include <bsd.port.mk>