aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/grepip
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-11-07 07:40:11 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-11-07 07:40:11 +0000
commit7ee5c2644afa66a60e3bc2e08be4274c62df86fb (patch)
tree606ad06c540cb357b1acd2de7eab5aea597435d7 /net-mgmt/grepip
parentb9e4075e4eebebc1efffe3f94fdf7d8671ee390b (diff)
downloadports-7ee5c2644afa66a60e3bc2e08be4274c62df86fb.tar.gz
ports-7ee5c2644afa66a60e3bc2e08be4274c62df86fb.zip
Notes
Diffstat (limited to 'net-mgmt/grepip')
-rw-r--r--net-mgmt/grepip/Makefile34
-rw-r--r--net-mgmt/grepip/distinfo2
-rw-r--r--net-mgmt/grepip/pkg-descr7
3 files changed, 43 insertions, 0 deletions
diff --git a/net-mgmt/grepip/Makefile b/net-mgmt/grepip/Makefile
new file mode 100644
index 000000000000..3bc2b8deafc0
--- /dev/null
+++ b/net-mgmt/grepip/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: grepip
+# Date created: 2 Nov 2005
+# Whom: Serge Maslov <serge@maslov.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grepip
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt
+MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/lexa/ \
+ ftp://ftp.des.tstu.ru/pub/mirror/Unix/apache/apache.lexa.ru/pub/domestic/lexa/
+
+MAINTAINER= Serge@Maslov.biz
+COMMENT= Print lines contans IP matching a pattern in CIDR format
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+PLIST_FILES= bin/grepip %%PORTDOCS%%%%DOCSDIR%%/README.txt
+PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
+
+do-build:
+ cd ${WRKSRC}; \
+ ${CC} ${CFLAGS} -c patricia.c; \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o -L${LOCALBASE}/lib -lpcre
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/grepip ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/grepip/distinfo b/net-mgmt/grepip/distinfo
new file mode 100644
index 000000000000..0722448aedab
--- /dev/null
+++ b/net-mgmt/grepip/distinfo
@@ -0,0 +1,2 @@
+MD5 (grepip-1.0.tar.gz) = 5f4528775f196a59f646195629dede4c
+SIZE (grepip-1.0.tar.gz) = 15490
diff --git a/net-mgmt/grepip/pkg-descr b/net-mgmt/grepip/pkg-descr
new file mode 100644
index 000000000000..fb7fafc09710
--- /dev/null
+++ b/net-mgmt/grepip/pkg-descr
@@ -0,0 +1,7 @@
+grepip searches the named input FILE (or standard input if no files are named),
+for lines containing an IP address matched to the given CIDR.
+grepip finds IP in any context of a line, while grepcidr only if all line is IP.
+
+WWW: http://www.lexa.ru/lexa/
+
+- Serge Maslov <serge@maslov.biz>