aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2018-08-10 08:45:06 +0000
committerLars Engels <lme@FreeBSD.org>2018-08-10 08:45:06 +0000
commit06441bc2f97f29152ca5619404ccd989004bd484 (patch)
tree47f6fe4f81bfc91a9b49dda10023b8714881973f /net-mgmt/icinga2
parent7cb8ef83c8915f707f1f66b583a5d4b69a23c2c7 (diff)
downloadports-06441bc2f97f29152ca5619404ccd989004bd484.tar.gz
ports-06441bc2f97f29152ca5619404ccd989004bd484.zip
net-mgmt/icinga2:
Update to 2.9.1
Notes
Notes: svn path=/head/; revision=476812
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile5
-rw-r--r--net-mgmt/icinga2/distinfo6
-rw-r--r--net-mgmt/icinga2/files/patch-CMakeLists.txt19
-rw-r--r--net-mgmt/icinga2/files/patch-itl_command-plugins.conf6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt18
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt18
-rw-r--r--net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/pkg-plist45
12 files changed, 64 insertions, 83 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 722a057c3662..341ee81544a1 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,11 +2,10 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.8.4
-PORTREVISION= 2
+DISTVERSION= 2.9.1
CATEGORIES= net-mgmt
-MAINTAINER= lme@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index c03ffaad1006..8b82948a7a35 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524755477
-SHA256 (icinga-icinga2-v2.8.4_GH0.tar.gz) = 36f6ae3ccd5d93599459ee093011e6b64f0c56cc16bc28d37e2e6acd0c63aae6
-SIZE (icinga-icinga2-v2.8.4_GH0.tar.gz) = 2510333
+TIMESTAMP = 1533888966
+SHA256 (icinga-icinga2-v2.9.1_GH0.tar.gz) = dbc01ee0ac8e981a99b998f17fb87a6c338be7cdbbec7680ad8935c9a638d934
+SIZE (icinga-icinga2-v2.9.1_GH0.tar.gz) = 2193190
diff --git a/net-mgmt/icinga2/files/patch-CMakeLists.txt b/net-mgmt/icinga2/files/patch-CMakeLists.txt
index 7be455b0d398..a9a67a7d609c 100644
--- a/net-mgmt/icinga2/files/patch-CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-CMakeLists.txt
@@ -1,7 +1,7 @@
---- CMakeLists.txt.orig 2018-03-22 10:26:19 UTC
+--- CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+++ CMakeLists.txt
@@ -28,8 +28,8 @@ if(NOT CMAKE_BUILD_TYPE)
- FORCE)
+ FORCE)
endif()
-option(ICINGA2_WITH_MYSQL "Build the MySQL IDO module" ON)
@@ -10,4 +10,17 @@
+option(ICINGA2_WITH_PGSQL "Build the PostgreSQL IDO module" OFF)
option(ICINGA2_WITH_CHECKER "Build the checker module" ON)
option(ICINGA2_WITH_COMPAT "Build the compat module" ON)
- option(ICINGA2_WITH_DEMO "Build the demo module" OFF)
+ option(ICINGA2_WITH_LIVESTATUS "Build the Livestatus module" ON)
+@@ -217,6 +217,12 @@ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+ endif()
+ endif()
+
++if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD.*")
++ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -lexecinfo")
++ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -lexecinfo")
++ set(CMAKE_STATIC_LINKER_FLAGS "${CMAKE_STATIC_LINKER_FLAGS} -lexecinfo")
++endif()
++
+ include(CheckCXXCompilerFlag)
+
+ function(check_cxx_linker_flag flag var)
diff --git a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
index 0e96f99024a7..a9580a342255 100644
--- a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
+++ b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
@@ -1,6 +1,6 @@
---- itl/command-plugins.conf.orig 2017-11-16 10:44:26.000000000 +0100
-+++ itl/command-plugins.conf 2017-11-20 15:01:11.622955000 +0100
-@@ -1638,6 +1638,10 @@ object CheckCommand "procs" {
+--- itl/command-plugins.conf.orig 2018-07-17 12:27:32 UTC
++++ itl/command-plugins.conf
+@@ -1627,6 +1627,10 @@ object CheckCommand "procs" {
set_if = "$procs_nokthreads$"
description = "Only scan for non kernel threads"
}
diff --git a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
index 2f8aa09a5ba8..0ff2715c3718 100644
--- a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/checker/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/checker/CMakeLists.txt 2017-05-30 16:24:26.678934000 +0200
-@@ -38,7 +38,7 @@ set_target_properties (
+--- lib/checker/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/checker/CMakeLists.txt
+@@ -35,7 +35,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
index c5a82b7d4d8a..5d75dd5f9167 100644
--- a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/compat/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/compat/CMakeLists.txt 2017-05-30 16:24:26.681909000 +0200
-@@ -43,17 +43,17 @@ set_target_properties (
+--- lib/compat/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/compat/CMakeLists.txt
+@@ -41,17 +41,17 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
index 64b925fa135e..b151b4ca3406 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
@@ -1,11 +1,11 @@
---- lib/db_ido_mysql/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/db_ido_mysql/CMakeLists.txt 2017-05-30 16:24:26.685470000 +0200
-@@ -42,7 +42,7 @@ if(MYSQL_FOUND)
- )
+--- lib/db_ido_mysql/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/db_ido_mysql/CMakeLists.txt
+@@ -37,7 +37,7 @@ set_target_properties (
+ )
- install_if_not_exists(
-- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf
-+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
- )
+ install_if_not_exists(
+- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf
++ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf.sample
+ ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ )
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
index 1db5be85ef52..45a6067afec6 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
@@ -1,11 +1,11 @@
---- lib/db_ido_pgsql/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/db_ido_pgsql/CMakeLists.txt 2017-05-30 16:24:26.688856000 +0200
-@@ -44,7 +44,7 @@ if(PostgreSQL_FOUND)
- )
+--- lib/db_ido_pgsql/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/db_ido_pgsql/CMakeLists.txt
+@@ -37,7 +37,7 @@ set_target_properties (
+ )
- install_if_not_exists(
-- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf
-+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
- )
+ install_if_not_exists(
+- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf
++ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf.sample
+ ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ )
diff --git a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
index f5e1c65889b8..8193a562a575 100644
--- a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/livestatus/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/livestatus/CMakeLists.txt 2017-05-30 16:24:26.692057000 +0200
-@@ -48,7 +48,7 @@ set_target_properties (
+--- lib/livestatus/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/livestatus/CMakeLists.txt
+@@ -71,7 +71,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
index baebdf015337..d619f480f592 100644
--- a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/notification/CMakeLists.txt.orig 2017-03-29 09:55:49.000000000 +0200
-+++ lib/notification/CMakeLists.txt 2017-05-30 16:24:26.695167000 +0200
-@@ -38,7 +38,7 @@ set_target_properties (
+--- lib/notification/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/notification/CMakeLists.txt
+@@ -35,7 +35,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
index 45cc1c3d398f..a2eb210800e8 100644
--- a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/perfdata/CMakeLists.txt.orig 2017-11-16 10:44:26.000000000 +0100
-+++ lib/perfdata/CMakeLists.txt 2017-11-20 15:02:18.563301000 +0100
-@@ -43,32 +43,32 @@ set_target_properties (
+--- lib/perfdata/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
++++ lib/perfdata/CMakeLists.txt
+@@ -45,32 +45,32 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index 6c86062f49f4..d44ef97dcf4b 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -9,6 +9,7 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/conf.d/templates.conf.sample
@sample %%ETCDIR%%/conf.d/timeperiods.conf.sample
@sample %%ETCDIR%%/conf.d/users.conf.sample
+@sample %%ETCDIR%%/constants.conf.sample
@sample %%ETCDIR%%/features-available/api.conf.sample
@sample %%ETCDIR%%/features-available/checker.conf.sample
@sample %%ETCDIR%%/features-available/command.conf.sample
@@ -30,46 +31,15 @@ etc/bash_completion.d/icinga2
%%ETCDIR%%/features-enabled/checker.conf
%%ETCDIR%%/features-enabled/mainlog.conf
%%ETCDIR%%/features-enabled/notification.conf
-@sample %%ETCDIR%%/constants.conf.sample
@sample %%ETCDIR%%/icinga2.conf.sample
@sample %%ETCDIR%%/scripts/mail-host-notification.sh.sample
@sample %%ETCDIR%%/scripts/mail-service-notification.sh.sample
@sample %%ETCDIR%%/zones.conf.sample
%%ETCDIR%%/zones.d/README
-lib/icinga2/libbase.so
-lib/icinga2/libbase.so.2.8.4
-lib/icinga2/libchecker.so
-lib/icinga2/libchecker.so.2.8.4
-lib/icinga2/libcli.so
-lib/icinga2/libcli.so.2.8.4
-lib/icinga2/libcompat.so
-lib/icinga2/libcompat.so.2.8.4
-lib/icinga2/libconfig.so
-lib/icinga2/libconfig.so.2.8.4
-%%DBBACKEND%%lib/icinga2/libdb_ido.so
-%%DBBACKEND%%lib/icinga2/libdb_ido.so.2.8.4
-%%MYSQL%%lib/icinga2/libdb_ido_mysql.so
-%%MYSQL%%lib/icinga2/libdb_ido_mysql.so.2.8.4
-%%PGSQL%%lib/icinga2/libdb_ido_pgsql.so
-%%PGSQL%%lib/icinga2/libdb_ido_pgsql.so.2.8.4
-lib/icinga2/libexecvpe.so
-lib/icinga2/libexecvpe.so.2.8.4
-lib/icinga2/libicinga.so
-lib/icinga2/libicinga.so.2.8.4
-lib/icinga2/liblivestatus.so
-lib/icinga2/liblivestatus.so.2.8.4
-lib/icinga2/libmethods.so
-lib/icinga2/libmethods.so.2.8.4
-lib/icinga2/libmmatch.so
-lib/icinga2/libmmatch.so.2.8.4
-lib/icinga2/libnotification.so
-lib/icinga2/libnotification.so.2.8.4
-lib/icinga2/libperfdata.so
-lib/icinga2/libperfdata.so.2.8.4
-lib/icinga2/libremote.so
-lib/icinga2/libremote.so.2.8.4
-lib/icinga2/libsocketpair.so
-lib/icinga2/libsocketpair.so.2.8.4
+%%MYSQL%%lib/icinga2/libmysql_shim.so
+%%MYSQL%%lib/icinga2/libmysql_shim.so.2.9.1
+%%PGSQL%%lib/icinga2/libpgsql_shim.so
+lib/icinga2/libpgsql_shim.so.2.9.1
lib/icinga2/sbin/icinga2
libexec/nagios/check_nscp_api
man/man8/icinga2.8.gz
@@ -77,7 +47,6 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.md
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/COPYING.Exceptions
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/01-about.md
@@ -106,6 +75,7 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/markdown/24-appendix.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/advanced-topics/flapping-state-graph.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/advanced-topics/icinga2_external_checks_freshness_icingaweb2.png
+%%PORTDOCS%%%%DOCSDIR%%/markdown/images/advanced-topics/icingaweb2_downtime_handled.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_distributed_endpoints.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_distributed_roles.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_distributed_scenarios_ha_master_clients.png
@@ -127,6 +97,7 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_installer_05.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_01.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_02.png
+%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_02_global_zone.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_03.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_04.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/distributed-monitoring/icinga2_windows_setup_wizard_05_nsclient_01.png
@@ -143,8 +114,6 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/getting-started/nano-syntax.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/getting-started/postgr-import-ido.png
%%PORTDOCS%%%%DOCSDIR%%/markdown/images/getting-started/vim-syntax.png
-%%PORTDOCS%%%%DOCSDIR%%/markdown/images/icinga2-api/icinga2_api_icinga_studio_connect.png
-%%PORTDOCS%%%%DOCSDIR%%/markdown/images/icinga2-api/icinga2_api_icinga_studio_overview.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsyslog/icinga2
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/mysql.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.0.2.sql