aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-08-23 16:52:18 +0000
committerLars Engels <lme@FreeBSD.org>2016-08-23 16:52:18 +0000
commit6c0286442db176bad4d835d3b0a680ce4f305bad (patch)
tree7fe6ca2ac24c5aba58312f72256c6c859b588cb2 /net-mgmt/icinga2
parent6aca1a12ff150be986e9409d6b7d8fcfa205fef8 (diff)
downloadports-6c0286442db176bad4d835d3b0a680ce4f305bad.tar.gz
ports-6c0286442db176bad4d835d3b0a680ce4f305bad.zip
Notes
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile17
-rw-r--r--net-mgmt/icinga2/distinfo6
-rw-r--r--net-mgmt/icinga2/files/icinga2-newsyslog.in3
-rw-r--r--net-mgmt/icinga2/files/patch-CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-etc_CMakeLists.txt8
-rw-r--r--net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt (renamed from net-mgmt/icinga2/files/patch-lib_db_ido_mysql_CMakeLists.txt)6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt (renamed from net-mgmt/icinga2/files/patch-lib_db_ido_pgsql_CMakeLists.txt)6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt6
-rw-r--r--net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt12
-rw-r--r--net-mgmt/icinga2/files/pkg-message.in3
-rw-r--r--net-mgmt/icinga2/pkg-plist46
14 files changed, 78 insertions, 57 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 9067ab38f722..4afae26e80fe 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.10
+DISTVERSION= 2.5.1
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
@@ -10,16 +10,17 @@ COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libyajl.so:devel/yajl
+ libyajl.so:devel/yajl \
+ libconfig.so:devel/libconfig
RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
+BROKEN_powerpc64= Does not build
+
USE_GITHUB= yes
GH_ACCOUNT= icinga
-USES= alias bison cmake execinfo libedit
+USES= alias bison cmake execinfo libedit ssl
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
@@ -65,6 +66,8 @@ PLIST_SUB= ICINGA2USER=${ICINGA2USER} \
ICINGA2GROUP=${ICINGA2GROUP} \
WWWGRP=${WWWGRP}
+SUB_FILES= pkg-message ${PORTNAME}-newsyslog
+
# Config files with references to "Linux"
LINUX_CONFIG= groups.conf services.conf hosts.conf
@@ -100,4 +103,8 @@ pre-install:
${FIND} ${WRKSRC}/etc/icinga2/scripts -type f -name "*.sh" \
-exec ${MV} {} {}.sample \;
+post-install:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/newsyslog/
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-newsyslog ${STAGEDIR}${EXAMPLESDIR}/newsyslog/${PORTNAME}
+
.include <bsd.port.mk>
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index 08dd320ad0e6..4afb0ee42b28 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463677720
-SHA256 (icinga-icinga2-v2.4.10_GH0.tar.gz) = c2963430503c382cc4d5083b05731c0b965b5ffa960e900c0827b83789f0425e
-SIZE (icinga-icinga2-v2.4.10_GH0.tar.gz) = 1768052
+TIMESTAMP = 1471959487
+SHA256 (icinga-icinga2-v2.5.1_GH0.tar.gz) = 6bf606136e5d0304bb422b520f0483a37c514fa09805f6f1abea8ab99b4d121d
+SIZE (icinga-icinga2-v2.5.1_GH0.tar.gz) = 2493564
diff --git a/net-mgmt/icinga2/files/icinga2-newsyslog.in b/net-mgmt/icinga2/files/icinga2-newsyslog.in
new file mode 100644
index 000000000000..f931f79037a8
--- /dev/null
+++ b/net-mgmt/icinga2/files/icinga2-newsyslog.in
@@ -0,0 +1,3 @@
+%%ICINGA2LOGDIR%%/debug.log %%ICINGA2USER%%:%%ICINGA2GROUP%% 644 7 * @T00 X
+%%ICINGA2LOGDIR%%/error.log %%ICINGA2USER%%:%%ICINGA2GROUP%% 644 90 * @T00 X
+%%ICINGA2LOGDIR%%/icinga2.log %%ICINGA2USER%%:%%ICINGA2GROUP%% 644 7 * @T00 X /var/run/icinga2/icinga2.pid SIGUSR1
diff --git a/net-mgmt/icinga2/files/patch-CMakeLists.txt b/net-mgmt/icinga2/files/patch-CMakeLists.txt
index f2f1511c1eb2..7ecd1e745e1f 100644
--- a/net-mgmt/icinga2/files/patch-CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- CMakeLists.txt.orig 2015-03-26 09:50:40.000000000 +0100
-+++ CMakeLists.txt 2015-03-26 20:40:12.055624000 +0100
+--- CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ CMakeLists.txt
@@ -28,8 +28,8 @@ if(NOT CMAKE_BUILD_TYPE)
FORCE)
endif()
diff --git a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
index 780aa6432dc5..b3c629d6d1c8 100644
--- a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
@@ -1,6 +1,6 @@
---- etc/CMakeLists.txt.orig 2015-11-16 10:57:03.000000000 +0100
-+++ etc/CMakeLists.txt 2015-11-16 15:20:49.216643000 +0100
-@@ -26,44 +26,44 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux"
+--- etc/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ etc/CMakeLists.txt
+@@ -26,43 +26,43 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux"
configure_file(logrotate.d/icinga2.cmake ${CMAKE_CURRENT_BINARY_DIR}/logrotate.d/icinga2 @ONLY)
endif()
@@ -45,7 +45,6 @@
-install_if_not_exists(icinga2/conf.d/users.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-install_if_not_exists(icinga2/features-available/api.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-install_if_not_exists(icinga2/features-available/debuglog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
--install_if_not_exists(icinga2/features-available/icingastatus.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-install_if_not_exists(icinga2/features-available/mainlog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+install_if_not_exists(icinga2/conf.d/notifications.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/conf.d/satellite.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
@@ -54,7 +53,6 @@
+install_if_not_exists(icinga2/conf.d/users.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+install_if_not_exists(icinga2/features-available/api.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+install_if_not_exists(icinga2/features-available/debuglog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/features-available/icingastatus.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+install_if_not_exists(icinga2/features-available/mainlog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
if(NOT WIN32)
- install_if_not_exists(icinga2/features-available/syslog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
diff --git a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
index 7aba163577cb..fb2675905aa6 100644
--- a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/checker/CMakeLists.txt.orig 2015-03-26 21:20:09.330968000 +0100
-+++ lib/checker/CMakeLists.txt 2015-03-26 21:20:26.783894000 +0100
-@@ -38,7 +38,7 @@ set_target_properties (
+--- lib/checker/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/checker/CMakeLists.txt
+@@ -37,7 +37,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
index 2cb618f80758..690b9817f3b1 100644
--- a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/compat/CMakeLists.txt.orig 2015-03-26 22:05:37.746370000 +0100
-+++ lib/compat/CMakeLists.txt 2015-03-26 22:05:53.107180000 +0100
-@@ -43,17 +43,17 @@ set_target_properties (
+--- lib/compat/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/compat/CMakeLists.txt
+@@ -42,17 +42,17 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_db_ido_mysql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
index 74bed5f772a1..f681eaf34e0d 100644
--- a/net-mgmt/icinga2/files/patch-lib_db_ido_mysql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/db_ido_mysql/CMakeLists.txt.orig 2015-03-26 22:17:27.671671000 +0100
-+++ lib/db_ido_mysql/CMakeLists.txt 2015-03-26 22:17:38.242327000 +0100
-@@ -42,7 +42,7 @@ if(MYSQL_FOUND)
+--- lib/db_ido_mysql/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/db_ido_mysql/CMakeLists.txt
+@@ -41,7 +41,7 @@ if(MYSQL_FOUND)
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_db_ido_pgsql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
index 377d30826421..ad969709e850 100644
--- a/net-mgmt/icinga2/files/patch-lib_db_ido_pgsql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/db_ido_pgsql/CMakeLists.txt.orig 2015-03-26 22:16:57.945333000 +0100
-+++ lib/db_ido_pgsql/CMakeLists.txt 2015-03-26 22:17:17.498830000 +0100
-@@ -44,7 +44,7 @@ if(PostgreSQL_FOUND)
+--- lib/db_ido_pgsql/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/db_ido_pgsql/CMakeLists.txt
+@@ -43,7 +43,7 @@ if(PostgreSQL_FOUND)
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
index 1a89705a8fb1..869c8787a5b0 100644
--- a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/livestatus/CMakeLists.txt.orig 2015-03-26 22:21:52.808117000 +0100
-+++ lib/livestatus/CMakeLists.txt 2015-03-26 22:22:17.663409000 +0100
-@@ -49,7 +49,7 @@ set_target_properties (
+--- lib/livestatus/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/livestatus/CMakeLists.txt
+@@ -47,7 +47,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
index 8f2f47c19b41..25ae50a59515 100644
--- a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/notification/CMakeLists.txt.orig 2015-03-26 22:23:26.170689000 +0100
-+++ lib/notification/CMakeLists.txt 2015-03-26 22:23:41.985022000 +0100
-@@ -38,7 +38,7 @@ set_target_properties (
+--- lib/notification/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/notification/CMakeLists.txt
+@@ -37,7 +37,7 @@ set_target_properties (
)
install_if_not_exists(
diff --git a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
index cb187304c4d3..08ed0bdb5584 100644
--- a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lib/perfdata/CMakeLists.txt.orig 2015-03-26 22:24:35.550156000 +0100
-+++ lib/perfdata/CMakeLists.txt 2015-03-26 22:24:49.596242000 +0100
-@@ -41,22 +41,22 @@ set_target_properties (
+--- lib/perfdata/CMakeLists.txt.orig 2016-08-17 14:19:24 UTC
++++ lib/perfdata/CMakeLists.txt
+@@ -41,27 +41,27 @@ set_target_properties (
)
install_if_not_exists(
@@ -16,6 +16,12 @@
)
install_if_not_exists(
+- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/influxdb.conf
++ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/influxdb.conf.sample
+ ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ )
+
+ install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/opentsdb.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/opentsdb.conf.sample
${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
diff --git a/net-mgmt/icinga2/files/pkg-message.in b/net-mgmt/icinga2/files/pkg-message.in
index 3a2297e6dfd9..3afe9242a030 100644
--- a/net-mgmt/icinga2/files/pkg-message.in
+++ b/net-mgmt/icinga2/files/pkg-message.in
@@ -1,3 +1,6 @@
If you do a major upgrade of Icinga 2 and use a database, please see
http://docs.icinga.org/icinga2/latest/doc/module/icinga2/chapter/upgrading-icinga-2
how to upgrade the database.
+
+To rotate Icinga 2's logfiles, you can copy %%EXAMPLESDIR%%/newsyslog/icinga2
+to %%LOCALBASE%%/etc/newsyslog.conf.d/
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index b7ed32bcba0b..ae301a95e4b9 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -1,4 +1,5 @@
etc/bash_completion.d/icinga2
+%%EXAMPLESDIR%%/newsyslog/icinga2
@sample %%ETCDIR%%/conf.d/app.conf.sample
@sample %%ETCDIR%%/conf.d/commands.conf.sample
@sample %%ETCDIR%%/conf.d/downtimes.conf.sample
@@ -18,9 +19,9 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/features-available/debuglog.conf.sample
@sample %%ETCDIR%%/features-available/gelf.conf.sample
@sample %%ETCDIR%%/features-available/graphite.conf.sample
-@sample %%ETCDIR%%/features-available/icingastatus.conf.sample
%%MYSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-mysql.conf.sample
%%PGSQL%%@sample(%%ICINGA2USER%%,%%ICINGA2GROUP%%,0640) %%ETCDIR%%/features-available/ido-pgsql.conf.sample
+@sample %%ETCDIR%%/features-available/influxdb.conf.sample
@sample %%ETCDIR%%/features-available/livestatus.conf.sample
@sample %%ETCDIR%%/features-available/mainlog.conf.sample
@sample %%ETCDIR%%/features-available/notification.conf.sample
@@ -65,40 +66,42 @@ sbin/icinga2
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/1-about.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/10-monitoring-remote-systems.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/11-%%ICINGA2USER%%2-client.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/12-agent-based-checks.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/13-distributed-monitoring-ha.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/14-addons-plugins.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/15-features.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/16-troubleshooting.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/17-upgrading-%%ICINGA2USER%%-2.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/18-language-reference.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/19-library-reference.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/10-icinga-template-library.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/11-cli-commands.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/12-icinga2-api.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/13-addons.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/14-features.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/15-troubleshooting.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/16-upgrading-icinga-2.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/17-language-reference.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/18-library-reference.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/19-script-debugger.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/2-getting-started.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/20-script-debugger.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/21-development.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/22-migrating-from-%%ICINGA2USER%%-1x.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/20-development.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/21-selinux.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/22-migrating-from-icinga-1x.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/23-appendix.md
%%PORTDOCS%%%%DOCSDIR%%/markdown/3-monitoring-basics.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/4-configuring-%%ICINGA2USER%%-2.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/5-advanced-topics.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/6-object-types.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/7-%%ICINGA2USER%%-template-library.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/8-cli-commands.md
-%%PORTDOCS%%%%DOCSDIR%%/markdown/9-icinga2-api.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/4-configuring-icinga-2.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/5-service-monitoring.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/6-distributed-monitoring.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/7-agent-based-monitoring.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/8-advanced-topics.md
+%%PORTDOCS%%%%DOCSDIR%%/markdown/9-object-types.md
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/mysql.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.0.2.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.1.0.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.2.0.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.3.0.sql
%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.4.0.sql
+%%MYSQL%%%%DATADIR%%-ido-mysql/schema/upgrade/2.5.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/pgsql.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.0.2.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.1.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.2.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.3.0.sql
%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.4.0.sql
+%%PGSQL%%%%DATADIR%%-ido-pgsql/schema/upgrade/2.5.0.sql
%%DATADIR%%/include/command-icinga.conf
%%DATADIR%%/include/command-nscp-local.conf
%%DATADIR%%/include/command-plugins-manubulon.conf
@@ -115,12 +118,13 @@ sbin/icinga2
%%DATADIR%%/include/plugins-contrib.d/hardware.conf
%%DATADIR%%/include/plugins-contrib.d/icingacli.conf
%%DATADIR%%/include/plugins-contrib.d/ipmi.conf
+%%DATADIR%%/include/plugins-contrib.d/metrics.conf
%%DATADIR%%/include/plugins-contrib.d/network-components.conf
+%%DATADIR%%/include/plugins-contrib.d/network-services.conf
%%DATADIR%%/include/plugins-contrib.d/operating-system.conf
%%DATADIR%%/include/plugins-contrib.d/virtualization.conf
%%DATADIR%%/include/plugins-contrib.d/vmware.conf
%%DATADIR%%/include/plugins-contrib.d/web.conf
-%%DATADIR%%/include/timeperiod.conf
%%DATADIR%%/include/windows-plugins
@dir %%ETCDIR%%/pki
@dir(%%ICINGA2USER%%,%%ICINGA2GROUP%%) /var/cache/icinga2