aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2018-10-16 14:08:38 +0000
committerLars Engels <lme@FreeBSD.org>2018-10-16 14:08:38 +0000
commit70b6b4ad44e52195c629d60fbf2630f203735b87 (patch)
tree3626aec3212beb1e3de52bc26ef7b36b6fbf88ab /net-mgmt/icinga2
parent53a71700187e34918a4a5db4dd2044d60b1d4b3c (diff)
downloadports-70b6b4ad44e52195c629d60fbf2630f203735b87.tar.gz
ports-70b6b4ad44e52195c629d60fbf2630f203735b87.zip
net-mgmt/icinga2:
Update to 2.10.0
Notes
Notes: svn path=/head/; revision=482229
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile3
-rw-r--r--net-mgmt/icinga2/distinfo6
-rw-r--r--net-mgmt/icinga2/files/patch-CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-etc_CMakeLists.txt88
-rw-r--r--net-mgmt/icinga2/files/patch-itl_command-plugins.conf4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt8
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt4
-rw-r--r--net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt14
-rw-r--r--net-mgmt/icinga2/pkg-plist5
13 files changed, 76 insertions, 76 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 84a7d2ffce4c..afb44ec0cf3f 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,8 +2,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.9.2
-PORTREVISION= 1
+DISTVERSION= 2.10.0
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index a65eed87575b..8eed2f777302 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538041940
-SHA256 (icinga-icinga2-v2.9.2_GH0.tar.gz) = 3d46e61bc45a369c757a9f91111b80fb2405099a32e04e7d259f8c3a72cfe762
-SIZE (icinga-icinga2-v2.9.2_GH0.tar.gz) = 2194226
+TIMESTAMP = 1539689899
+SHA256 (icinga-icinga2-v2.10.0_GH0.tar.gz) = 6f6c03979db7195d80f9aff153e6816adfb42bf60343186c6c0fb00e02796478
+SIZE (icinga-icinga2-v2.10.0_GH0.tar.gz) = 2227324
diff --git a/net-mgmt/icinga2/files/patch-CMakeLists.txt b/net-mgmt/icinga2/files/patch-CMakeLists.txt
index a9a67a7d609c..ea94d37d068e 100644
--- a/net-mgmt/icinga2/files/patch-CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ CMakeLists.txt
@@ -28,8 +28,8 @@ if(NOT CMAKE_BUILD_TYPE)
FORCE)
@@ -11,7 +11,7 @@
option(ICINGA2_WITH_CHECKER "Build the checker module" ON)
option(ICINGA2_WITH_COMPAT "Build the compat module" ON)
option(ICINGA2_WITH_LIVESTATUS "Build the Livestatus module" ON)
-@@ -217,6 +217,12 @@ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
+@@ -241,6 +241,12 @@ if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
endif()
endif()
diff --git a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
index 634f9dfcf2d6..47ad09aa939f 100644
--- a/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-etc_CMakeLists.txt
@@ -1,61 +1,61 @@
---- etc/CMakeLists.txt.orig 2018-03-22 10:26:19 UTC
+--- etc/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ etc/CMakeLists.txt
@@ -24,39 +24,39 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux"
endif()
if(NOT WIN32)
-- install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-- install_if_not_exists(icinga2/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-+ install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-+ install_if_not_exists(icinga2/icinga2.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+- install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf ${ICINGA2_CONFIGDIR})
+- install_if_not_exists(icinga2/icinga2.conf ${ICINGA2_CONFIGDIR})
++ install_if_not_exists(${CMAKE_CURRENT_BINARY_DIR}/icinga2/constants.conf.sample ${ICINGA2_CONFIGDIR})
++ install_if_not_exists(icinga2/icinga2.conf.sample ${ICINGA2_CONFIGDIR})
else()
- install_if_not_exists(${CMAKE_CURRENT_SOURCE_DIR}/icinga2/win32/constants.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
- install_if_not_exists(icinga2/win32/icinga2.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
+ install_if_not_exists(${CMAKE_CURRENT_SOURCE_DIR}/icinga2/win32/constants.conf ${ICINGA2_CONFIGDIR})
+ install_if_not_exists(icinga2/win32/icinga2.conf ${ICINGA2_CONFIGDIR})
endif()
--install_if_not_exists(icinga2/zones.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
--install_if_not_exists(icinga2/conf.d/app.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/commands.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/downtimes.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/groups.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/zones.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2)
-+install_if_not_exists(icinga2/conf.d/app.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/commands.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/downtimes.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/groups.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+-install_if_not_exists(icinga2/zones.conf ${ICINGA2_CONFIGDIR})
+-install_if_not_exists(icinga2/conf.d/app.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/commands.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/downtimes.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/groups.conf ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/zones.conf.sample ${ICINGA2_CONFIGDIR})
++install_if_not_exists(icinga2/conf.d/app.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/commands.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/downtimes.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/groups.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
if(NOT WIN32)
-- install_if_not_exists(icinga2/conf.d/hosts.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-- install_if_not_exists(icinga2/conf.d/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+ install_if_not_exists(icinga2/conf.d/hosts.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+ install_if_not_exists(icinga2/conf.d/services.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+- install_if_not_exists(icinga2/conf.d/hosts.conf ${ICINGA2_CONFIGDIR}/conf.d)
+- install_if_not_exists(icinga2/conf.d/services.conf ${ICINGA2_CONFIGDIR}/conf.d)
++ install_if_not_exists(icinga2/conf.d/hosts.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++ install_if_not_exists(icinga2/conf.d/services.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
else()
- install_if_not_exists(icinga2/conf.d/win32/hosts.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
- install_if_not_exists(icinga2/conf.d/win32/services.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
+ install_if_not_exists(icinga2/conf.d/win32/hosts.conf ${ICINGA2_CONFIGDIR}/conf.d)
+ install_if_not_exists(icinga2/conf.d/win32/services.conf ${ICINGA2_CONFIGDIR}/conf.d)
endif()
--install_if_not_exists(icinga2/conf.d/notifications.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/templates.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/timeperiods.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/conf.d/users.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
--install_if_not_exists(icinga2/features-available/api.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
--install_if_not_exists(icinga2/features-available/debuglog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
--install_if_not_exists(icinga2/features-available/mainlog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/conf.d/notifications.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/templates.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/timeperiods.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/conf.d/users.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/conf.d)
-+install_if_not_exists(icinga2/features-available/api.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/features-available/debuglog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+install_if_not_exists(icinga2/features-available/mainlog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+-install_if_not_exists(icinga2/conf.d/notifications.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/templates.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/timeperiods.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/conf.d/users.conf ${ICINGA2_CONFIGDIR}/conf.d)
+-install_if_not_exists(icinga2/features-available/api.conf ${ICINGA2_CONFIGDIR}/features-available)
+-install_if_not_exists(icinga2/features-available/debuglog.conf ${ICINGA2_CONFIGDIR}/features-available)
+-install_if_not_exists(icinga2/features-available/mainlog.conf ${ICINGA2_CONFIGDIR}/features-available)
++install_if_not_exists(icinga2/conf.d/notifications.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/templates.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/timeperiods.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/conf.d/users.conf.sample ${ICINGA2_CONFIGDIR}/conf.d)
++install_if_not_exists(icinga2/features-available/api.conf.sample ${ICINGA2_CONFIGDIR}/features-available)
++install_if_not_exists(icinga2/features-available/debuglog.conf.sample ${ICINGA2_CONFIGDIR}/features-available)
++install_if_not_exists(icinga2/features-available/mainlog.conf.sample ${ICINGA2_CONFIGDIR}/features-available)
if(NOT WIN32)
-- install_if_not_exists(icinga2/features-available/syslog.conf ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
-+ install_if_not_exists(icinga2/features-available/syslog.conf.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available)
+- install_if_not_exists(icinga2/features-available/syslog.conf ${ICINGA2_CONFIGDIR}/features-available)
++ install_if_not_exists(icinga2/features-available/syslog.conf.sample ${ICINGA2_CONFIGDIR}/features-available)
endif()
--install_if_not_exists(icinga2/scripts/mail-host-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
--install_if_not_exists(icinga2/scripts/mail-service-notification.sh ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
-+install_if_not_exists(icinga2/scripts/mail-host-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
-+install_if_not_exists(icinga2/scripts/mail-service-notification.sh.sample ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/scripts)
- install_if_not_exists(icinga2/zones.d/README ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/zones.d)
+-install_if_not_exists(icinga2/scripts/mail-host-notification.sh ${ICINGA2_CONFIGDIR}/scripts)
+-install_if_not_exists(icinga2/scripts/mail-service-notification.sh ${ICINGA2_CONFIGDIR}/scripts)
++install_if_not_exists(icinga2/scripts/mail-host-notification.sh.sample ${ICINGA2_CONFIGDIR}/scripts)
++install_if_not_exists(icinga2/scripts/mail-service-notification.sh.sample ${ICINGA2_CONFIGDIR}/scripts)
+ install_if_not_exists(icinga2/zones.d/README ${ICINGA2_CONFIGDIR}/zones.d)
if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
diff --git a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
index a9580a342255..bdf1a47f419f 100644
--- a/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
+++ b/net-mgmt/icinga2/files/patch-itl_command-plugins.conf
@@ -1,6 +1,6 @@
---- itl/command-plugins.conf.orig 2018-07-17 12:27:32 UTC
+--- itl/command-plugins.conf.orig 2018-10-11 12:01:05 UTC
+++ itl/command-plugins.conf
-@@ -1627,6 +1627,10 @@ object CheckCommand "procs" {
+@@ -1628,6 +1628,10 @@ object CheckCommand "procs" {
set_if = "$procs_nokthreads$"
description = "Only scan for non kernel threads"
}
diff --git a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
index 0ff2715c3718..41f6ea3085f3 100644
--- a/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_checker_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/checker/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/checker/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/checker/CMakeLists.txt
@@ -35,7 +35,7 @@ set_target_properties (
)
@@ -6,6 +6,6 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/checker.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/checker.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
index 5d75dd5f9167..939feb064f48 100644
--- a/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_compat_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/compat/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/compat/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/compat/CMakeLists.txt
@@ -41,17 +41,17 @@ set_target_properties (
)
@@ -6,18 +6,18 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/command.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/command.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/compatlog.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/compatlog.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/statusdata.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/statusdata.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
index b151b4ca3406..086dfb2ca34c 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__mysql_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/db_ido_mysql/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/db_ido_mysql/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/db_ido_mysql/CMakeLists.txt
@@ -37,7 +37,7 @@ set_target_properties (
)
@@ -6,6 +6,6 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-mysql.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
index 45a6067afec6..7f0a61b8e337 100644
--- a/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_db__ido__pgsql_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/db_ido_pgsql/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/db_ido_pgsql/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/db_ido_pgsql/CMakeLists.txt
@@ -37,7 +37,7 @@ set_target_properties (
)
@@ -6,6 +6,6 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/ido-pgsql.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
index 8193a562a575..e19ba05602d9 100644
--- a/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_livestatus_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/livestatus/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/livestatus/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/livestatus/CMakeLists.txt
@@ -71,7 +71,7 @@ set_target_properties (
)
@@ -6,6 +6,6 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/livestatus.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/livestatus.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
index d619f480f592..50e7bcc37910 100644
--- a/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_notification_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/notification/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/notification/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/notification/CMakeLists.txt
@@ -35,7 +35,7 @@ set_target_properties (
)
@@ -6,6 +6,6 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/notification.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/notification.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
index a2eb210800e8..b42de356a14c 100644
--- a/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
+++ b/net-mgmt/icinga2/files/patch-lib_perfdata_CMakeLists.txt
@@ -1,4 +1,4 @@
---- lib/perfdata/CMakeLists.txt.orig 2018-07-17 12:27:32 UTC
+--- lib/perfdata/CMakeLists.txt.orig 2018-10-11 12:01:05 UTC
+++ lib/perfdata/CMakeLists.txt
@@ -45,32 +45,32 @@ set_target_properties (
)
@@ -6,36 +6,36 @@
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/gelf.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/gelf.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/graphite.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/graphite.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/influxdb.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/influxdb.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/elasticsearch.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/elasticsearch.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/opentsdb.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/opentsdb.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
install_if_not_exists(
- ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/perfdata.conf
+ ${PROJECT_SOURCE_DIR}/etc/icinga2/features-available/perfdata.conf.sample
- ${CMAKE_INSTALL_SYSCONFDIR}/icinga2/features-available
+ ${ICINGA2_CONFIGDIR}/features-available
)
diff --git a/net-mgmt/icinga2/pkg-plist b/net-mgmt/icinga2/pkg-plist
index 765d22826f67..5c98a6e56442 100644
--- a/net-mgmt/icinga2/pkg-plist
+++ b/net-mgmt/icinga2/pkg-plist
@@ -37,9 +37,9 @@ etc/bash_completion.d/icinga2
@sample %%ETCDIR%%/zones.conf.sample
%%ETCDIR%%/zones.d/README
%%MYSQL%%lib/icinga2/libmysql_shim.so
-%%MYSQL%%lib/icinga2/libmysql_shim.so.2.9.2
+%%MYSQL%%lib/icinga2/libmysql_shim.so.2.10.0
%%PGSQL%%lib/icinga2/libpgsql_shim.so
-%%PGSQL%%lib/icinga2/libpgsql_shim.so.2.9.2
+%%PGSQL%%lib/icinga2/libpgsql_shim.so.2.10.0
lib/icinga2/sbin/icinga2
libexec/nagios/check_nscp_api
man/man8/icinga2.8.gz
@@ -146,6 +146,7 @@ sbin/icinga2
%%DATADIR%%/include/nscp
%%DATADIR%%/include/plugins
%%DATADIR%%/include/plugins-contrib
+%%DATADIR%%/include/plugins-contrib.d/big-data.conf
%%DATADIR%%/include/plugins-contrib.d/databases.conf
%%DATADIR%%/include/plugins-contrib.d/hardware.conf
%%DATADIR%%/include/plugins-contrib.d/icingacli.conf