aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icingaweb2-module-idoreports
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2019-05-17 12:50:41 +0000
committerLars Engels <lme@FreeBSD.org>2019-05-17 12:50:41 +0000
commitb9541f9b5e3f0542ab4d207882aad93a34b78cb3 (patch)
treecbb1c47ee6474c9957abcb6c1a7a6301a41aa17f /net-mgmt/icingaweb2-module-idoreports
parent88ba50c2e2061ca593cb1e1d3b537de5d64c424d (diff)
downloadports-b9541f9b5e3f0542ab4d207882aad93a34b78cb3.tar.gz
ports-b9541f9b5e3f0542ab4d207882aad93a34b78cb3.zip
Notes
Diffstat (limited to 'net-mgmt/icingaweb2-module-idoreports')
-rw-r--r--net-mgmt/icingaweb2-module-idoreports/Makefile30
-rw-r--r--net-mgmt/icingaweb2-module-idoreports/distinfo3
-rw-r--r--net-mgmt/icingaweb2-module-idoreports/pkg-descr4
-rw-r--r--net-mgmt/icingaweb2-module-idoreports/pkg-plist12
4 files changed, 49 insertions, 0 deletions
diff --git a/net-mgmt/icingaweb2-module-idoreports/Makefile b/net-mgmt/icingaweb2-module-idoreports/Makefile
new file mode 100644
index 000000000000..66d72c802029
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-idoreports/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-idoreports
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.0
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Host and service availability reports for Icinga
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= icingaweb2>=2.6.0:net-mgmt/icingaweb2 \
+ icingaweb2-module-reporting>=0.9:net-mgmt/icingaweb2-module-reporting
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icingaweb2-module-idoreports/distinfo b/net-mgmt/icingaweb2-module-idoreports/distinfo
new file mode 100644
index 000000000000..2059d5251a12
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-idoreports/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557838708
+SHA256 (icinga-icingaweb2-module-idoreports-v0.9.0_GH0.tar.gz) = 6f9786ea8ce621f9ddb75387f7b9c9a652dc6c63dadb26060c6eec1577280f25
+SIZE (icinga-icingaweb2-module-idoreports-v0.9.0_GH0.tar.gz) = 101439
diff --git a/net-mgmt/icingaweb2-module-idoreports/pkg-descr b/net-mgmt/icingaweb2-module-idoreports/pkg-descr
new file mode 100644
index 000000000000..8c6b5b0921b2
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-idoreports/pkg-descr
@@ -0,0 +1,4 @@
+Icinga IDO Reports provides host and service availability reports for Icinga
+1.x and Icinga 2.x based on the monitoring database (IDO).
+
+WWW: https://github.com/Icinga/icingaweb2-module-idoreports
diff --git a/net-mgmt/icingaweb2-module-idoreports/pkg-plist b/net-mgmt/icingaweb2-module-idoreports/pkg-plist
new file mode 100644
index 000000000000..870da9162622
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-idoreports/pkg-plist
@@ -0,0 +1,12 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README.md
+%%WWWDIR%%/doc/02-Installation.md
+%%WWWDIR%%/doc/res/host-sla-report.png
+%%WWWDIR%%/library/Idoreports/HostSlaReport.php
+%%WWWDIR%%/library/Idoreports/IdoReport.php
+%%WWWDIR%%/library/Idoreports/ServiceSlaReport.php
+%%WWWDIR%%/module.info
+%%WWWDIR%%/run.php
+%%WWWDIR%%/schema/get_sla_ok_percent.sql
+%%WWWDIR%%/schema/slaperiods.sql