aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icingaweb2-module-reactbundle/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2019-05-17 12:47:10 +0000
committerLars Engels <lme@FreeBSD.org>2019-05-17 12:47:10 +0000
commitcae70149871597f7bf1f2161df8ec3df81a8b0b8 (patch)
treec096f3e53fcc9d69f8febad22cd2daa8a6c435bc /net-mgmt/icingaweb2-module-reactbundle/Makefile
parent03fa42d47c191dfd8b5a2c772721a264027fbd97 (diff)
downloadports-cae70149871597f7bf1f2161df8ec3df81a8b0b8.tar.gz
ports-cae70149871597f7bf1f2161df8ec3df81a8b0b8.zip
Notes
Diffstat (limited to 'net-mgmt/icingaweb2-module-reactbundle/Makefile')
-rw-r--r--net-mgmt/icingaweb2-module-reactbundle/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mgmt/icingaweb2-module-reactbundle/Makefile b/net-mgmt/icingaweb2-module-reactbundle/Makefile
new file mode 100644
index 000000000000..99623638fc12
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-reactbundle/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-reactbundle
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.1
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Icinga Web 2 ReactPHP-based 3rd party libraries
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>