aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icingaweb2
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-03-19 09:03:47 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-03-19 09:03:47 +0000
commit30b4416cd0744428dcbff63852833553b33bcdce (patch)
tree4e54f1dfd4a39400de4235db0bb3b049fdd69277 /net-mgmt/icingaweb2
parent06159628a5b77c5266f319bbcd269a9d5e3e4685 (diff)
downloadports-30b4416cd0744428dcbff63852833553b33bcdce.tar.gz
ports-30b4416cd0744428dcbff63852833553b33bcdce.zip
Import changes from upstream to make icingaweb2 work with php 7.4
Approved by: lme (maintainer) Obtained from: Upstream repository head
Notes
Notes: svn path=/head/; revision=528703
Diffstat (limited to 'net-mgmt/icingaweb2')
-rw-r--r--net-mgmt/icingaweb2/Makefile2
-rw-r--r--net-mgmt/icingaweb2/files/patch-library_Icinga_Web_View.php44
-rw-r--r--net-mgmt/icingaweb2/files/patch-library_vendor_Zend_Registry.php18
-rw-r--r--net-mgmt/icingaweb2/files/patch-library_vendor_lessphp_lessc.inc.php11
4 files changed, 74 insertions, 1 deletions
diff --git a/net-mgmt/icingaweb2/Makefile b/net-mgmt/icingaweb2/Makefile
index a828bfe7d3cc..0029d970a5d5 100644
--- a/net-mgmt/icingaweb2/Makefile
+++ b/net-mgmt/icingaweb2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= icingaweb2
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt www
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
diff --git a/net-mgmt/icingaweb2/files/patch-library_Icinga_Web_View.php b/net-mgmt/icingaweb2/files/patch-library_Icinga_Web_View.php
new file mode 100644
index 000000000000..975acdad3f5c
--- /dev/null
+++ b/net-mgmt/icingaweb2/files/patch-library_Icinga_Web_View.php
@@ -0,0 +1,44 @@
+--- library/Icinga/Web/View.php.orig 2019-10-18 05:39:24 UTC
++++ library/Icinga/Web/View.php
+@@ -60,13 +60,6 @@ class View extends Zend_View_Abstract
+ const CHARSET = 'UTF-8';
+
+ /**
+- * Flag to register stream wrapper
+- *
+- * @var bool
+- */
+- private $useViewStream = false;
+-
+- /**
+ * Registered helper functions
+ */
+ private $helperFunctions = array();
+@@ -86,13 +79,6 @@ class View extends Zend_View_Abstract
+ */
+ public function __construct($config = array())
+ {
+- $this->useViewStream = (bool) ini_get('short_open_tag') ? false : true;
+- if ($this->useViewStream) {
+- if (!in_array('zend.view', stream_get_wrappers())) {
+- stream_wrapper_register('zend.view', '\Icinga\Web\ViewStream');
+- }
+- }
+-
+ $config['helperPath']['Icinga\\Web\\View\\Helper\\'] = Icinga::app()->getLibraryDir('Icinga/Web/View/Helper');
+
+ parent::__construct($config);
+@@ -258,11 +244,8 @@ class View extends Zend_View_Abstract
+ // Exporting global variables to view scripts:
+ $$k = $v;
+ }
+- if ($this->useViewStream) {
+- include 'zend.view://' . func_get_arg(0);
+- } else {
+- include func_get_arg(0);
+- }
++
++ include func_get_arg(0);
+ }
+
+ /**
diff --git a/net-mgmt/icingaweb2/files/patch-library_vendor_Zend_Registry.php b/net-mgmt/icingaweb2/files/patch-library_vendor_Zend_Registry.php
new file mode 100644
index 000000000000..ed25d9267514
--- /dev/null
+++ b/net-mgmt/icingaweb2/files/patch-library_vendor_Zend_Registry.php
@@ -0,0 +1,18 @@
+--- library/vendor/Zend/Registry.php.orig 2019-10-18 05:39:24 UTC
++++ library/vendor/Zend/Registry.php
+@@ -190,15 +190,4 @@ class Zend_Registry extends ArrayObject
+ parent::__construct($array, $flags);
+ }
+
+- /**
+- * @param string $index
+- * @returns mixed
+- *
+- * Workaround for http://bugs.php.net/bug.php?id=40442 (ZF-960).
+- */
+- public function offsetExists($index)
+- {
+- return array_key_exists($index, $this);
+- }
+-
+ }
diff --git a/net-mgmt/icingaweb2/files/patch-library_vendor_lessphp_lessc.inc.php b/net-mgmt/icingaweb2/files/patch-library_vendor_lessphp_lessc.inc.php
new file mode 100644
index 000000000000..57ae780ca64d
--- /dev/null
+++ b/net-mgmt/icingaweb2/files/patch-library_vendor_lessphp_lessc.inc.php
@@ -0,0 +1,11 @@
+--- library/vendor/lessphp/lessc.inc.php.orig 2019-10-18 05:39:24 UTC
++++ library/vendor/lessphp/lessc.inc.php
+@@ -662,7 +662,7 @@ class lessc {
+
+ // check for a rest
+ $last = end($args);
+- if ($last[0] == "rest") {
++ if (is_array($last) && $last[0] == "rest") {
+ $rest = array_slice($orderedValues, count($args) - 1);
+ $this->set($last[1], $this->reduce(array("list", " ", $rest)));
+ }