aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/iftop
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2015-01-31 08:36:37 +0000
committerVasil Dimov <vd@FreeBSD.org>2015-01-31 08:36:37 +0000
commit825c3dca1da2914736bb03d14ad8b0dff1694212 (patch)
tree698b5af3b338207a43f705f4377a0b7a1f872e0a /net-mgmt/iftop
parentdc3408f7174c20b8c7a5cfbdd925e7c8890c70e2 (diff)
downloadports-825c3dca1da2914736bb03d14ad8b0dff1694212.tar.gz
ports-825c3dca1da2914736bb03d14ad8b0dff1694212.zip
Notes
Diffstat (limited to 'net-mgmt/iftop')
-rw-r--r--net-mgmt/iftop/Makefile9
-rw-r--r--net-mgmt/iftop/distinfo4
-rw-r--r--net-mgmt/iftop/files/patch-cfgfile.c10
3 files changed, 7 insertions, 16 deletions
diff --git a/net-mgmt/iftop/Makefile b/net-mgmt/iftop/Makefile
index 861f31a662f8..18b2dd7f08a8 100644
--- a/net-mgmt/iftop/Makefile
+++ b/net-mgmt/iftop/Makefile
@@ -2,25 +2,26 @@
# $FreeBSD$
PORTNAME= iftop
-PORTVERSION= 0.17
+DISTVERSION= 1.0pre4
CATEGORIES= net-mgmt
MASTER_SITES= http://www.ex-parrot.com/~pdw/iftop/download/
MAINTAINER= vd@FreeBSD.org
COMMENT= Display bandwidth usage on an interface by host
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-resolver=netdb_1thread
PORTDOCS= README
-PLIST_FILES= bin/iftop man/man8/iftop.8.gz
+PLIST_FILES= sbin/iftop man/man8/iftop.8.gz
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/net-mgmt/iftop/distinfo b/net-mgmt/iftop/distinfo
index 6d3a60c1e1c2..bceb1fad0b30 100644
--- a/net-mgmt/iftop/distinfo
+++ b/net-mgmt/iftop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (iftop-0.17.tar.gz) = d032547c708307159ff5fd0df23ebd3cfa7799c31536fa0aea1820318a8e0eac
-SIZE (iftop-0.17.tar.gz) = 160381
+SHA256 (iftop-1.0pre4.tar.gz) = f733eeea371a7577f8fe353d86dd88d16f5b2a2e702bd96f5ffb2c197d9b4f97
+SIZE (iftop-1.0pre4.tar.gz) = 204665
diff --git a/net-mgmt/iftop/files/patch-cfgfile.c b/net-mgmt/iftop/files/patch-cfgfile.c
deleted file mode 100644
index 148cd8844a20..000000000000
--- a/net-mgmt/iftop/files/patch-cfgfile.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- cfgfile.c.orig Tue Nov 11 22:10:29 2003
-+++ cfgfile.c Tue Nov 11 22:10:43 2003
-@@ -8,6 +8,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <errno.h>
-+#include <sys/types.h>
-
- #include "stringmap.h"
- #include "iftop.h"