aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ipaudit
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-06-26 16:46:32 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-06-26 16:46:32 +0000
commit3dec7703be5de5a0e06097490e7a0d608c6509b5 (patch)
tree014dd773d7845bb7bcda256f7ec9c28e332efff4 /net-mgmt/ipaudit
parent8af6f9429acfc432e62957093ad6fffa2679b218 (diff)
downloadports-3dec7703be5de5a0e06097490e7a0d608c6509b5.tar.gz
ports-3dec7703be5de5a0e06097490e7a0d608c6509b5.zip
* Updated to 1.1
* New maintainer Jov <amutu@amutu.com> * Removed obsolete patches - Fix typo in add_ports(), change to tcp_ports[] to udp_ports[] - Fixed pid file, write it from parent process *after* terminal is detached. - Fixed daemon mode, no longer depends on pid file option - In ipaudit.c, now apply pcap filters (-f option) to packets read from capture file. - In total.c, now handle command-line option errors correctly. - In hash.c, fix reallocation of data potions of hash table items when memory reallocated. PR: 220097 Submitted by: Jov <amutu@amutu.com> (maintainer) Reviewed by: lifanov (mentor), matthew (mentor) Approved by: lifanov (mentor), matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11356
Notes
Notes: svn path=/head/; revision=444377
Diffstat (limited to 'net-mgmt/ipaudit')
-rw-r--r--net-mgmt/ipaudit/Makefile17
-rw-r--r--net-mgmt/ipaudit/distinfo5
-rw-r--r--net-mgmt/ipaudit/files/patch-Makefile15
-rw-r--r--net-mgmt/ipaudit/files/patch-src__Makefile50
-rw-r--r--net-mgmt/ipaudit/files/patch-src__hash.h11
-rw-r--r--net-mgmt/ipaudit/files/patch-src_ipaudit.conf.sample11
-rw-r--r--net-mgmt/ipaudit/pkg-plist9
7 files changed, 25 insertions, 93 deletions
diff --git a/net-mgmt/ipaudit/Makefile b/net-mgmt/ipaudit/Makefile
index 02bbff49ec3e..0fdc440e7ef6 100644
--- a/net-mgmt/ipaudit/Makefile
+++ b/net-mgmt/ipaudit/Makefile
@@ -2,28 +2,23 @@
# $FreeBSD$
PORTNAME= ipaudit
-PORTVERSION= 0.95
+PORTVERSION= 1.1
CATEGORIES= net-mgmt sysutils
-MASTER_SITES= http://ipaudit.sourceforge.net/download/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ipaudit/ipaudit
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amutu@amutu.com
COMMENT= IP traffic summarizer
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:tgz
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS
+GNU_CONFIGURE= yes
-do-install:
-.for f in ipaudit ipstrings total
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${f} ${STAGEDIR}${PREFIX}/bin
-.endfor
-.for f in ipaudit.1 ipstrings.1 total.1
- ${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${STAGEDIR}${PREFIX}/man/man1
-.endfor
+post-install:
${INSTALL_DATA} ${WRKSRC}/src/ipaudit.conf.sample ${STAGEDIR}${PREFIX}/etc
do-install-DOCS-on:
diff --git a/net-mgmt/ipaudit/distinfo b/net-mgmt/ipaudit/distinfo
index 3d3b809131a9..ab9a16164d19 100644
--- a/net-mgmt/ipaudit/distinfo
+++ b/net-mgmt/ipaudit/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ipaudit-0.95.tgz) = 82c47fba296e93ee50b0a033e0689d4c3fbc08ebd6e1026dcd7f069a05d0e872
-SIZE (ipaudit-0.95.tgz) = 52412
+TIMESTAMP = 1497756455
+SHA256 (ipaudit-1.1.tar.gz) = ef97c9ff232f4e57624643b6b0e99b1951b55bc12d50f9b8b5e10ed267836458
+SIZE (ipaudit-1.1.tar.gz) = 170253
diff --git a/net-mgmt/ipaudit/files/patch-Makefile b/net-mgmt/ipaudit/files/patch-Makefile
deleted file mode 100644
index 3e4aa81735ce..000000000000
--- a/net-mgmt/ipaudit/files/patch-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig Wed Oct 18 01:38:27 2000
-+++ Makefile Tue Jul 15 18:20:49 2003
-@@ -8,10 +8,10 @@
- BIN=ipaudit ipstrings total pdate
-
- MAKE=make
--CIDIR=-I/usr/include/pcap
-+#CIDIR=-I/usr/include/pcap
-
- all:
-- $(MAKE) -C src all
-+ cd src && $(MAKE) all
-
- clean:
- $(MAKE) -C src clean
diff --git a/net-mgmt/ipaudit/files/patch-src__Makefile b/net-mgmt/ipaudit/files/patch-src__Makefile
deleted file mode 100644
index 7024a9dec573..000000000000
--- a/net-mgmt/ipaudit/files/patch-src__Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/Makefile.orig Mon Jan 8 05:56:59 2001
-+++ src/Makefile Tue Jul 15 18:19:58 2003
-@@ -1,36 +1,36 @@
--CIDIR=-I/usr/include/pcap
-+#CIDIR=-I/usr/include/pcap
-
- #LIB=../../libpcap-0.5/libpcap.a
- LIB=-lpcap
-
--all: ipaudit total ipstrings beta-dir
-+all: ipaudit total ipstrings
-
- ipaudit: ipaudit.o hash.o
-- $(CC) -o ipaudit ipaudit.o hash.o $(LIB)
-+ $(CC) $(CFLAGS) -o ipaudit ipaudit.o hash.o $(LIB)
-
- total: total.o hash.o
-- $(CC) -o total total.o hash.o -lm
-+ $(CC) $(CFLAGS) -o total total.o hash.o -lm
-
- ipstrings: ipstrings.o
-- $(CC) -o ipstrings ipstrings.o $(LIB)
-+ $(CC) $(CFLAGS) -o ipstrings ipstrings.o $(LIB)
-
- ipaudit.o: ipaudit.c hash.h
-- $(CC) -c ipaudit.c $(CIDIR) $(DFLAGS)
-+ $(CC) $(CFLAGS) -c ipaudit.c $(CIDIR) $(DFLAGS)
-
- hash.o: hash.c hash.h
-- $(CC) -c hash.c
-+ $(CC) $(CFLAGS) -c hash.c
-
- total.o: total.c hash.c hash.h
-- $(CC) -c total.c
-+ $(CC) $(CFLAGS) -c total.c
-
- ipstrings.o: ipstrings.c
-- $(CC) -c ipstrings.c $(CIDIR) $(DFLAGS)
-+ $(CC) $(CFLAGS) -c ipstrings.c $(CIDIR) $(DFLAGS)
-
- iprange: iprange.c
- $(CC) -g -o iprange iprange.c
-
--beta-dir:
-- $(MAKE) -C beta
-+#beta-dir:
-+# $(MAKE) -C beta
-
- clean:
- rm -f *.o
diff --git a/net-mgmt/ipaudit/files/patch-src__hash.h b/net-mgmt/ipaudit/files/patch-src__hash.h
deleted file mode 100644
index ed2cf54dd670..000000000000
--- a/net-mgmt/ipaudit/files/patch-src__hash.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hash.h.orig Tue Jul 15 16:53:16 2003
-+++ src/hash.h Tue Jul 15 16:53:49 2003
-@@ -1,6 +1,8 @@
- #ifndef _HASH_H
- #define _HASH_H
-
-+#include <sys/types.h>
-+
- /*
- ------------------------------------------------------------------------
- Type Definitions
diff --git a/net-mgmt/ipaudit/files/patch-src_ipaudit.conf.sample b/net-mgmt/ipaudit/files/patch-src_ipaudit.conf.sample
new file mode 100644
index 000000000000..bd8e17b7e8f8
--- /dev/null
+++ b/net-mgmt/ipaudit/files/patch-src_ipaudit.conf.sample
@@ -0,0 +1,11 @@
+--- src/ipaudit.conf.sample.orig 2017-06-18 04:09:55 UTC
++++ src/ipaudit.conf.sample
+@@ -0,0 +1,8 @@
++#
++# test configuration file for ipaudit
++#
++# interface lo eth0
++interface lo eth0
++writetime on
++icmptype on
++# saveport 1:6,21,23,111,6667,65301
diff --git a/net-mgmt/ipaudit/pkg-plist b/net-mgmt/ipaudit/pkg-plist
index 6ff993ad1470..f4a6bdcd7807 100644
--- a/net-mgmt/ipaudit/pkg-plist
+++ b/net-mgmt/ipaudit/pkg-plist
@@ -1,8 +1,9 @@
-bin/ipaudit
-bin/ipstrings
+bin/makelocal
bin/total
etc/ipaudit.conf.sample
-man/man1/ipaudit.1.gz
-man/man1/ipstrings.1.gz
man/man1/total.1.gz
+man/man8/ipaudit.8.gz
+man/man8/ipstrings.8.gz
+sbin/ipaudit
+sbin/ipstrings
%%PORTDOCS%%%%DOCSDIR%%/README