aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/kismet
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2014-07-07 16:45:48 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2014-07-07 16:45:48 +0000
commitb060d1ce6f9ff533d7a7e876c5a6555b79a7a6f3 (patch)
tree44a9a3b390cc6f65d4369fd170571544342695c7 /net-mgmt/kismet
parent8288fe324b90a5dcef363d27b1ffa9908a222c8c (diff)
downloadports-b060d1ce6f9ff533d7a7e876c5a6555b79a7a6f3.tar.gz
ports-b060d1ce6f9ff533d7a7e876c5a6555b79a7a6f3.zip
Use staging; provide manufacturer file distinfo
Notes
Notes: svn path=/head/; revision=361105
Diffstat (limited to 'net-mgmt/kismet')
-rw-r--r--net-mgmt/kismet/Makefile30
-rw-r--r--net-mgmt/kismet/distinfo3
-rw-r--r--net-mgmt/kismet/pkg-plist6
3 files changed, 22 insertions, 17 deletions
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index cb20656880fe..84fd58417c2c 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -21,22 +21,17 @@ USES= gmake tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= kismet.1 kismet_drone.1
-MAN5= kismet.conf.5 kismet_drone.conf.5
-
OPTIONS_DEFINE= PCRE PLUGINS SETUID
OPTIONS_DEFAULT= PCRE PLUGINS SETUID
SETUID_DESC= Use privilege separation
WRKSRC= ${WRKDIR}/${DISTNAME:S/a$$//}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= README manuf
DISTFILES+= manuf:2
-BROKEN= no distinfo provided for some of the distfiles
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@@ -45,22 +40,22 @@ PORTEXAMPLES= *
.if ${PORT_OPTIONS:MPCRE}
CONFIGURE_ARGS+=--enable-pcre
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
.else
CONFIGURE_ARGS+=--disable-pcre
.endif
.if ${PORT_OPTIONS:MSETUID}
GROUPS = kismet
-CONFIGURE_ARGS+=--with-suidgroup=${GROUPS}
+CONFIGURE_ARGS+=--with-suidgroup=wheel
INSTALL_TARGET = suidinstall
-PLIST_SUB+= SUID=""
+PLIST_SUB+= SUID="" SUIDGROUP="${GROUPS}"
PKGMESSAGE= ${WRKDIR}/suid_pkg-message
SUB_FILES+= suid_pkg-message
.else
INSTALL_TARGET = install
CONFIGURE_ARGS+=--without-suidgroup
-PLIST_SUB+= SUID="@comment "
+PLIST_SUB+= SUID="@comment " SUIDGROUP=""
.endif
.if ${PORT_OPTIONS:MPLUGINS}
@@ -86,19 +81,22 @@ post-patch:
${REINPLACE_CMD} -E \
'/C(XX)?FLAGS[[:blank:]]*\+=/s/ -g / /'
+post-build:
+ @cd ${WRKSRC}; ${STRIP_CMD} kismet_client kismet_drone kismet_server */*.so
+
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manuf ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manuf ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/ruby/* ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ruby/* ${STAGEDIR}${EXAMPLESDIR}
.endif
@${INSTALL_DATA} ${WRKSRC}/conf/kismet.conf \
- ${PREFIX}/etc/kismet.conf.sample
+ ${STAGEDIR}${PREFIX}/etc/kismet.conf.sample
@${INSTALL_DATA} ${WRKSRC}/conf/kismet_drone.conf \
- ${PREFIX}/etc/kismet_drone.conf.sample
+ ${STAGEDIR}${PREFIX}/etc/kismet_drone.conf.sample
.include <bsd.port.mk>
diff --git a/net-mgmt/kismet/distinfo b/net-mgmt/kismet/distinfo
index 6ee28141dec5..2019619f3767 100644
--- a/net-mgmt/kismet/distinfo
+++ b/net-mgmt/kismet/distinfo
@@ -1,3 +1,4 @@
SHA256 (kismet/kismet-2013-03-R1b.tar.xz) = 636d4d7ef8c67ae6ee8d8e1635f5115700eecb9fa4c208afaee30238db527c2c
SIZE (kismet/kismet-2013-03-R1b.tar.xz) = 699968
-SHA256 (kismet/manuf) = IGNORE
+SHA256 (kismet/manuf) = 42dcb7c3a677cfd23d0c08d30b9cd8abc8a57237ea2f7b90014eb4ea98446140
+SIZE (kismet/manuf) = 1393916
diff --git a/net-mgmt/kismet/pkg-plist b/net-mgmt/kismet/pkg-plist
index 41779baca18c..2647bf052b80 100644
--- a/net-mgmt/kismet/pkg-plist
+++ b/net-mgmt/kismet/pkg-plist
@@ -1,5 +1,7 @@
bin/kismet
+@group %%SUIDGROUP%%
%%SUID%%bin/kismet_capture
+@group
bin/kismet_client
bin/kismet_drone
bin/kismet_server
@@ -13,6 +15,10 @@ etc/kismet_drone.conf.sample
%%PLUGINS%%lib/kismet/kismet-syslog.so
%%PLUGINS%%lib/kismet/spectool_net.so
%%PLUGINS%%lib/kismet_client/spectools_ui.so
+man/man1/kismet.1.gz
+man/man1/kismet_drone.1.gz
+man/man5/kismet.conf.5.gz
+man/man5/kismet_drone.conf.5.gz
%%DATADIR%%/wav/alert.wav
%%DATADIR%%/wav/gpslock.wav
%%DATADIR%%/wav/gpslost.wav