aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/librenms
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2019-05-12 01:02:56 +0000
committerDan Langille <dvl@FreeBSD.org>2019-05-12 01:02:56 +0000
commitf74ab1336fb00d47dc02ea47a53455a57a6c3808 (patch)
tree1767e0386dada93dbca5ede410308ab0548cc37c /net-mgmt/librenms
parent7490ba867580eb790993f5c9bf98c3783ad6e0a6 (diff)
downloadports-f74ab1336fb00d47dc02ea47a53455a57a6c3808.tar.gz
ports-f74ab1336fb00d47dc02ea47a53455a57a6c3808.zip
Notes
Diffstat (limited to 'net-mgmt/librenms')
-rw-r--r--net-mgmt/librenms/Makefile21
-rw-r--r--net-mgmt/librenms/distinfo10
-rw-r--r--net-mgmt/librenms/files/patch-html_install.php16
3 files changed, 26 insertions, 21 deletions
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index 4b391d66c9c6..ee60566c58af 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= librenms
-PORTVERSION= 1.50
+PORTVERSION= 1.51
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= LOCAL/dvl:vendor
@@ -18,7 +18,7 @@ USES= python${PY_MYSQL} shebangfix
# RELEASE_TIMESTAMP is used for a patch inside the vendor code
# it represents the release date via: git show --pretty='%H|%ct' -s 1.42.01
# It sits here so you remember to update it with each release
-RELEASE_TIMESTAMP= 1554090241
+RELEASE_TIMESTAMP= 1556573781
# perhaps we also need python-memcache python-mysqldb
RUN_DEPENDS+= rrdtool:databases/rrdtool \
@@ -96,12 +96,14 @@ SUB_LIST+= PHP="${PHPBASE}/bin/php" PYTHON=${PYTHON_CMD}
ROOT_FILES= .env.example addhost.php adduser.php alerts.php artisan billing-calculate.php \
build-base.php build.sql check-services.php composer.json \
- composer.lock config.php.default config_to_json.php cronic daily.php daily.sh \
- delhost.php discovery-wrapper.py discovery.php dist-pollers.php irc.php lnms \
+ composer.lock config.php.default config_to_json.php cronic daily.php \
+ delhost.php discovery-wrapper.py discovery.php dist-pollers.php irc.php \
librenms-service.py mkdocs.yml pbin.sh phpunit.xml ping.php poll-billing.php poller.php poller-service.py \
poller-wrapper.py readmegen.yml renamehost.php services-wrapper.py snmp-scan.py \
snmptrap.php syslog.php validate.php
+SCRIPT_FILES= daily.sh lnms
+
ROOT_DIRS= LibreNMS app bootstrap config contrib database doc html includes licenses logs mibs misc resources routes scripts sql-schema storage tests
# these are directories which require a generic @DIR entry in pkg-plist
@@ -149,12 +151,15 @@ do-install:
.for f in ${ROOT_FILES}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${WWWDIR}
.endfor
+.for f in ${SCRIPT_FILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}/${WWWDIR}
+.endfor
${MKDIR} ${STAGEDIR}/${WWWDIR}/vendor
(cd ${WRKDIR}/${PORTNAME}-vendor-${PORTVERSION} && ${COPYTREE_SHARE} . ${STAGEDIR}/${WWWDIR}/vendor)
# Make daily.sh executable
- ${CHMOD} 0755 ${STAGEDIR}/${WWWDIR}/daily.sh
+# ${CHMOD} 0755 ${STAGEDIR}/${WWWDIR}/daily.sh
# lnms does not fall into any other +x category
- ${CHMOD} 0755 ${STAGEDIR}/${WWWDIR}/lnms
+# ${CHMOD} 0755 ${STAGEDIR}/${WWWDIR}/lnms
# Files in scripts dir should be executable
${FIND} ${STAGEDIR}/${WWWDIR}/scripts -type f -exec ${CHMOD} +x {} \;
# Ensure PHP and Python scripts are executable
@@ -180,9 +185,11 @@ do-install-EXAMPLES-on:
post-install:
@${FIND} -s ${STAGEDIR}${WWWDIR} -type f '(' -name '*.orig' -or -name '*.bak' -or -name '.gitignore' ')' -delete
@${FIND} -s ${STAGEDIR}${WWWDIR} -not -type d | ${SORT} | \
- ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
+ ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
@${ECHO_CMD} "@dir(www,www,0775) ${WWWDIR}/logs" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(www,www,0775) ${WWWDIR}/bootstrap/cache" >> ${TMPPLIST}
+# @${ECHO_CMD} "@(www,www,0775) ${WWWDIR}/daily.sh" >> ${TMPPLIST}
+# @${ECHO_CMD} "@(www,www,0775) ${WWWDIR}/lnms" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(www,www,0775) ${WWWDIR}/storage" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(www,www,0775) ${WWWDIR}/storage/framework/cache" >> ${TMPPLIST}
@${ECHO_CMD} "@dir(www,www,0775) ${WWWDIR}/storage/framework/sessions" >> ${TMPPLIST}
diff --git a/net-mgmt/librenms/distinfo b/net-mgmt/librenms/distinfo
index 4cdbbd402529..457002869fca 100644
--- a/net-mgmt/librenms/distinfo
+++ b/net-mgmt/librenms/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1554405883
-SHA256 (librenms-vendor-1.50.tar.gz) = 5a86e35a93151956cb3ba8f01a76e360bdd5e80a7a80807879b1b781d18aaa03
-SIZE (librenms-vendor-1.50.tar.gz) = 32638908
-SHA256 (librenms-librenms-1.50_GH0.tar.gz) = 6b6f1b3300fabf062cfc20efc68faabd071786e6c2039c4dc2e9cd05fa3c1d86
-SIZE (librenms-librenms-1.50_GH0.tar.gz) = 35986338
+TIMESTAMP = 1556824503
+SHA256 (librenms-vendor-1.51.tar.gz) = 03e19ead3b20e8b7e820b4b8264f2d387cc132748bf71e510266b922b75e54b6
+SIZE (librenms-vendor-1.51.tar.gz) = 32641978
+SHA256 (librenms-librenms-1.51_GH0.tar.gz) = fc04635d1e86af776b5ad8c0936f54b6071e791293a88a5942cf0e23f2daffef
+SIZE (librenms-librenms-1.51_GH0.tar.gz) = 36806669
diff --git a/net-mgmt/librenms/files/patch-html_install.php b/net-mgmt/librenms/files/patch-html_install.php
index 6eaec2d41b3e..3ca726b33a53 100644
--- a/net-mgmt/librenms/files/patch-html_install.php
+++ b/net-mgmt/librenms/files/patch-html_install.php
@@ -1,6 +1,6 @@
---- html/install.php.orig 2018-10-17 10:33:28 UTC
+--- html/install.php.orig 2019-05-12 00:03:11 UTC
+++ html/install.php
-@@ -358,7 +358,7 @@ $config_file = <<<"EOD"
+@@ -362,7 +362,7 @@ $config_file = <<<"EOD"
// This is the user LibreNMS will run as
//Please ensure this user is created and has the correct permissions to your install
@@ -9,18 +9,16 @@
### Locations - it is recommended to keep the default
#\$config\['install_dir'\] = "$install_dir";
-@@ -384,15 +384,15 @@ $config_file = <<<"EOD"
- #\$config\['nets'\]\[\] = "192.168.0.0/16";
+@@ -389,14 +389,14 @@ $config_file = <<<"EOD"
# Update configuration
--#\$config\['update_channel'\] = 'release'; # uncomment to follow the monthly release channel
+ #\$config\['update_channel'\] = 'release'; # uncomment to follow the monthly release channel
-#\$config\['update'\] = 0; # uncomment to completely disable updates
-+\$config\['update_channel'\] = 'release'; # uncomment to follow the monthly release channel
+\$config\['update'\] = 0; # uncomment to completely disable updates
EOD;
- if (!file_exists("../config.php")) {
- $conf = fopen("../config.php", 'w');
+ if (!file_exists("config.php")) {
+ $conf = fopen("config.php", 'w');
if ($conf != false) {
if (fwrite($conf, "<?php\n") === false) {
- echo("<div class='alert alert-danger'>We couldn't create the config.php file, please create this manually before continuing by copying the below into a config.php in the root directory of your install (typically /opt/librenms/)</div>");
@@ -28,7 +26,7 @@
echo("<pre>&lt;?php\n".stripslashes($config_file)."</pre>");
} else {
$config_file = stripslashes($config_file);
-@@ -400,7 +400,7 @@ if (!file_exists("../config.php")) {
+@@ -404,7 +404,7 @@ if (!file_exists("config.php")) {
echo("<div class='alert alert-success'>The config file has been created</div>");
}
} else {