aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/lldpd
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2015-02-05 17:03:14 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2015-02-05 17:03:14 +0000
commita07165ca86e197ff094f6516ff171c78ecd0eac8 (patch)
tree0051a214b0df1832f3f54eeea7a2e0cf2637dddd /net-mgmt/lldpd
parenta9b09537bb044036bcd24fa7f8b26cd7e9cadd24 (diff)
downloadports-a07165ca86e197ff094f6516ff171c78ecd0eac8.tar.gz
ports-a07165ca86e197ff094f6516ff171c78ecd0eac8.zip
Add lldp, an implementation of the LLDP industry protocol
PR: 189824 Submitted by: freebsd@simweb.ch Reviewed by: danfe
Notes
Notes: svn path=/head/; revision=378477
Diffstat (limited to 'net-mgmt/lldpd')
-rw-r--r--net-mgmt/lldpd/Makefile55
-rw-r--r--net-mgmt/lldpd/distinfo2
-rw-r--r--net-mgmt/lldpd/files/README.bsd3
-rw-r--r--net-mgmt/lldpd/files/lldpd.in32
-rw-r--r--net-mgmt/lldpd/pkg-descr18
-rw-r--r--net-mgmt/lldpd/pkg-message2
-rw-r--r--net-mgmt/lldpd/pkg-plist21
7 files changed, 133 insertions, 0 deletions
diff --git a/net-mgmt/lldpd/Makefile b/net-mgmt/lldpd/Makefile
new file mode 100644
index 000000000000..73982793d7d0
--- /dev/null
+++ b/net-mgmt/lldpd/Makefile
@@ -0,0 +1,55 @@
+# Created by: Mathieu Simon <freebsd@simweb.ch>
+# $FreeBSD$
+
+PORTNAME= lldpd
+PORTVERSION= 0.7.13
+CATEGORIES= net-mgmt
+MASTER_SITES= http://media.luffy.cx/files/${PORTNAME}/
+
+MAINTAINER= freebsd@simweb.ch
+COMMENT= LLDP (802.1ab)/CDP/EDP/SONMP/FDP daemon and SNMP subagent
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+
+USES= libtool
+USE_LDCONFIG= yes
+USE_RC_SUBR= ${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-privsep \
+ --with-privsep-chroot=/var/empty \
+ --with-lldpd-ctl-socket=/var/run/lldpd.socket \
+ --with-lldpd-pid-file=/var/run/lldpd.pid \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+INSTALL_TARGET= install-strip
+
+USERS= _lldpd
+GROUPS= _lldpd
+
+OPTIONS_DEFINE= BASH DOCS DTRACE JSON PROPRIETARY READLINE SNMP XML ZSH
+OPTIONS_DEFAULT= BASH JSON PROPRIETARY SNMP XML
+OPTIONS_SUB= yes
+
+DTRACE_DESC= DTrace support
+JSON_DESC= JSON output support
+PROPRIETARY_DESC= Support proprietary protocols (CDP/EDP/FDP/SONMP)
+SNMP_DESC= Enable the use of SNMP
+XML_DESC= XML output support
+
+DTRACE_CONFIGURE_ENABLE= dtrace
+JSON_CONFIGURE_WITH= json
+READLINE_CONFIGURE_WITH= readline
+SNMP_CONFIGURE_WITH= snmp
+XML_CONFIGURE_WITH= xml
+PROPRIETARY_CONFIGURE_ENABLE= cdp edp fdp sonmp
+
+JSON_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson
+JSON_USES= pkgconfig
+SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+XML_LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
+
+post-install:
+ ${INSTALL_DATA} ${FILESDIR}/README.bsd ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/lldpd/distinfo b/net-mgmt/lldpd/distinfo
new file mode 100644
index 000000000000..4f3d604b18dd
--- /dev/null
+++ b/net-mgmt/lldpd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lldpd-0.7.13.tar.gz) = bbba3ef922f6b6cc6d2c0f008066dc882750557661c54dd1b97ae7936678d92d
+SIZE (lldpd-0.7.13.tar.gz) = 1523864
diff --git a/net-mgmt/lldpd/files/README.bsd b/net-mgmt/lldpd/files/README.bsd
new file mode 100644
index 000000000000..51da26c7958f
--- /dev/null
+++ b/net-mgmt/lldpd/files/README.bsd
@@ -0,0 +1,3 @@
+A normal user has to be member of the _lldpd group in order to run lldpcli.
+
+-- Mathieu Simon <freebsd@simweb.ch>, Tue, 10 Dec 2014 13:40:00 +01:00
diff --git a/net-mgmt/lldpd/files/lldpd.in b/net-mgmt/lldpd/files/lldpd.in
new file mode 100644
index 000000000000..a632beeab204
--- /dev/null
+++ b/net-mgmt/lldpd/files/lldpd.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: lldpd
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# lldpd_enable (bool): Set to NO by default.
+# Set it to YES to enable lldpd.
+# lldpd_flags (str): Flags passed to lldpd on startup.
+# Default is "".
+
+. /etc/rc.subr
+
+name=lldpd
+rcvar=lldpd_enable
+
+load_rc_config $name
+
+: ${lldpd_enable:="NO"}
+: ${lldpd_flags=""}
+
+command=%%PREFIX%%/sbin/${name}
+pidfile=/var/run/${name}.pid
+
+command_args=${lldpd_flags}
+
+run_rc_command "$1"
diff --git a/net-mgmt/lldpd/pkg-descr b/net-mgmt/lldpd/pkg-descr
new file mode 100644
index 000000000000..0e3a7744143f
--- /dev/null
+++ b/net-mgmt/lldpd/pkg-descr
@@ -0,0 +1,18 @@
+LLDP (Link Layer Discovery Protocol) is an industry standard protocol
+designed to supplant proprietary Link-Layer protocols such as
+Extreme's EDP (Extreme Discovery Protocol) and CDP (Cisco Discovery
+Protocol). The goal of LLDP is to provide an inter-vendor compatible
+mechanism to deliver Link-Layer notifications to adjacent network
+devices.
+
+lldpd implements both reception and sending. It also implements an
+SNMP subagent for net-snmp to get local and remote LLDP
+information. The LLDP MIB is partially implemented but the most useful
+tables are here. lldpd also partially implements LLDP-MED.
+
+lldpd supports bridge, vlan and bonding. Bonding need to be done on
+real physical devices, not on bridges, vlans, etc. However, vlans can
+be mapped on the bonding device. You can bridge vlan but not add vlans
+on bridges. More complex setups may give false results.
+
+WWW: http://vincentbernat.github.io/lldpd/
diff --git a/net-mgmt/lldpd/pkg-message b/net-mgmt/lldpd/pkg-message
new file mode 100644
index 000000000000..f775efa6e7eb
--- /dev/null
+++ b/net-mgmt/lldpd/pkg-message
@@ -0,0 +1,2 @@
+To run lldpd from startup, add lldpd_enable="YES" to your rc.conf.
+Add lldpd_flags to your rc.conf to set options.
diff --git a/net-mgmt/lldpd/pkg-plist b/net-mgmt/lldpd/pkg-plist
new file mode 100644
index 000000000000..08e67e3c08a0
--- /dev/null
+++ b/net-mgmt/lldpd/pkg-plist
@@ -0,0 +1,21 @@
+%%BASH%%etc/bash_completion.d/lldpcli.bash-completion
+%%ETCDIR%%.d/README.conf
+include/lldp-const.h
+include/lldpctl.h
+lib/liblldpctl.a
+lib/liblldpctl.so
+lib/liblldpctl.so.4
+lib/liblldpctl.so.4.4.0
+libdata/pkgconfig/lldpctl.pc
+man/man8/lldpcli.8.gz
+man/man8/lldpctl.8.gz
+man/man8/lldpd.8.gz
+sbin/lldpcli
+sbin/lldpctl
+sbin/lldpd
+%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/CONTRIBUTE.md
+%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/README.bsd
+%%DOCS%%%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%ZSH%%share/zsh/vendor-completions/_lldpcli