aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mbrowse/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-04-04 14:04:25 +0000
committerMark Pulford <markp@FreeBSD.org>2002-04-04 14:04:25 +0000
commit1aabbe84954c8863acbe59733143e307c5ddc90b (patch)
treeed3531c7be304a65ec7c5904c098975e5a3f5a8b /net-mgmt/mbrowse/Makefile
parent267499ca8a2474cd051e913c7e26ebf1e3b9dd9e (diff)
downloadports-1aabbe84954c8863acbe59733143e307c5ddc90b.tar.gz
ports-1aabbe84954c8863acbe59733143e307c5ddc90b.zip
Notes
Diffstat (limited to 'net-mgmt/mbrowse/Makefile')
-rw-r--r--net-mgmt/mbrowse/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
new file mode 100644
index 000000000000..c795db7f45ef
--- /dev/null
+++ b/net-mgmt/mbrowse/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mbrowse
+# Date created: Apr 4, 2002
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mbrowse
+PORTVERSION= 0.2.3
+CATEGORIES= net
+MASTER_SITES= http://goldplated.atlcartel.com/
+
+MAINTAINER= markp@FreeBSD.org
+
+LIB_DEPENDS= snmp.4:${PORTSDIR}/net/net-snmp
+
+GNU_CONFIGURE= yes
+USE_GTK= yes
+CONFIGURE_ARGS+= --with-ucdsnmp-prefix=${LOCALBASE}
+
+post-patch:
+ @${PERL} -pi -e 'print "#include <sys/types.h>\n" if !$$a; $$a=1' \
+ ${WRKSRC}/src/callbacks.h
+
+.include <bsd.port.mk>