aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mk-livestatus
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2019-02-25 14:49:41 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2019-02-25 14:49:41 +0000
commit22b14ea7432b7e9d9e8a942dca09183892f9d83a (patch)
tree417181438b88e3707d5afa9d5c42e098acde2d7c /net-mgmt/mk-livestatus
parent66358923d0188e84e15a5450596942c73b0b05da (diff)
downloadports-22b14ea7432b7e9d9e8a942dca09183892f9d83a.tar.gz
ports-22b14ea7432b7e9d9e8a942dca09183892f9d83a.zip
net-mgmt/mk-livestatus: enable Nagios4 support by default
- ../UPDATING add note regarding default options being changed. - Makefile adopt the port; update '1.2.8p22' to '1.2.8p24'; enable Nagios 4.x as the default supported version; RUN_DEPENDS uses respective Nagios package as dependency; delete unnecessary ${RM} -r api/perl; new option now provides mk-livestatus' Perl API; clean USES variable; built just fine. - pkg-message update documentation's URL (linked the one with text in English); add clear note that Nagios' event broker support needs to be enabled. Approved by: rene (mentor) Differential Revision: https://reviews.freebsd.org/D18513
Notes
Notes: svn path=/head/; revision=493872
Diffstat (limited to 'net-mgmt/mk-livestatus')
-rw-r--r--net-mgmt/mk-livestatus/Makefile35
-rw-r--r--net-mgmt/mk-livestatus/distinfo6
-rw-r--r--net-mgmt/mk-livestatus/files/pkg-message.in14
3 files changed, 25 insertions, 30 deletions
diff --git a/net-mgmt/mk-livestatus/Makefile b/net-mgmt/mk-livestatus/Makefile
index c502d6087877..44e1053de8e6 100644
--- a/net-mgmt/mk-livestatus/Makefile
+++ b/net-mgmt/mk-livestatus/Makefile
@@ -2,18 +2,16 @@
# $FreeBSD$
PORTNAME= mk-livestatus
-PORTVERSION= 1.2.8p22
+PORTVERSION= 1.2.8p24
CATEGORIES= net-mgmt
MASTER_SITES= http://mathias-kettner.de/download/
DIST_SUBDIR= check_mk
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@FreeBSD.org
COMMENT= Nagios event broker module
LICENSE= GPLv2
-USES= compiler:c++11-lib gmake
-
GNU_CONFIGURE= yes
PLIST_FILES= lib/mk-livestatus/unixcat \
@@ -28,31 +26,28 @@ EXAMPLE_FILES= example_multisite.py example.py \
# parameter "command_file" from nagios.cfg
COMMAND_FILE?= /var/spool/nagios/rw/live
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= EXAMPLES PERL
OPTIONS_SINGLE= NAGIOS
OPTIONS_SINGLE_NAGIOS= NAGIOS3 NAGIOS4
-OPTIONS_DEFAULT= NAGIOS3
-
-EXAMPLES_USES= python
+OPTIONS_DEFAULT= NAGIOS4
-NAGIOS3_DESC= build for nagios-3.x
-NAGIOS4_DESC= build for nagios-4.x
+NAGIOS3_DESC= Build support for Nagios 3.x
+NAGIOS4_DESC= Build support for Nagios 4.x
+PERL_DESC= Install Monitoring-Livestatus Perl API
-NAGIOS4_CONFIGURE_ON= --with-nagios4
-
-# perl api is really outdated, do not install!
-# Actual version can be found on CPAN
-# https://metacpan.org/release/Monitoring-Livestatus
-post-extract:
- @${RM} -r ${WRKSRC}/api/perl
+EXAMPLES_USES= python
+NAGIOS3_RUN_DEPENDS= nagios>=3.5.1:net-mgmt/nagios
+NAGIOS4_CONFIGURE_WITH= nagios4
+NAGIOS4_RUN_DEPENDS= nagios4>=4.4:net-mgmt/nagios4
+PERL_RUN_DEPENDS= p5-Monitoring-Livestatus>=0:net-mgmt/p5-Monitoring-Livestatus
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/nagios/var/rw/live|${COMMAND_FILE}|' \
+ ${REINPLACE_CMD} -e 's|/usr/local/nagios/var/rw/live|${COMMAND_FILE}|' \
${WRKSRC}/src/livestatus.h
post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' \
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|g' \
-e 's|/var/lib/nagios/rw/live|${COMMAND_FILE}|g' \
-e 's|/var/run/nagios/rw/live|${COMMAND_FILE}|g' \
${PORTEXAMPLES:S|^|${WRKSRC}/api/python/|}
diff --git a/net-mgmt/mk-livestatus/distinfo b/net-mgmt/mk-livestatus/distinfo
index 1d78fb8d670b..a8623d62ee82 100644
--- a/net-mgmt/mk-livestatus/distinfo
+++ b/net-mgmt/mk-livestatus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1547305942
-SHA256 (check_mk/mk-livestatus-1.2.8p22.tar.gz) = 3cae2efe1059e2dc647090993b1024ec4ca0e7d3bfbf21ec9ff439984e6bb931
-SIZE (check_mk/mk-livestatus-1.2.8p22.tar.gz) = 453535
+TIMESTAMP = 1549545300
+SHA256 (check_mk/mk-livestatus-1.2.8p24.tar.gz) = 54ee1bd7da5dee157121b0acb1a0302ab5fc21e904c1c9cb53f7012c4427eae9
+SIZE (check_mk/mk-livestatus-1.2.8p24.tar.gz) = 453519
diff --git a/net-mgmt/mk-livestatus/files/pkg-message.in b/net-mgmt/mk-livestatus/files/pkg-message.in
index 17b46766802c..f6b3fe206b90 100644
--- a/net-mgmt/mk-livestatus/files/pkg-message.in
+++ b/net-mgmt/mk-livestatus/files/pkg-message.in
@@ -2,17 +2,17 @@
Notes:
- * See the documentation at http://mathias-kettner.de/checkmk_livestatus.html
+ * See the documentation at https://mathias-kettner.com/checkmk_livestatus.html
- * Requires that net-mgmt/nagios be built with WITH_EVENT_BROKER=yes or
- livestatus.o will never be loaded...
+ * Requires Nagios (net-mgmt/nagios, or net-mgmt/nagios4) be built with event
+ broker support enabled, or 'livestatus.o' will never be loaded. This is
+ the default for net-mgmt/nagios4.
* unixcat (for use with reading from the socket and/or inetd(8) support)
- moved from %%PREFIX%%/bin
- to %%PREFIX%%/lib/mk-livestatus
+ moved from %%PREFIX%%/bin to %%PREFIX%%/lib/mk-livestatus
in order to avoid a conflict with sysutils/ucspi-unix
- * livecheck was removed in 1.2.3.i5,
- Please adjust your "broker_module=..." directive in etc/nagios/nagios.cfg!
+ * livecheck was removed in 1.2.3.i5. Please adjust your "broker_module=..."
+ directive in %%PREFIX%%/etc/nagios/nagios.cfg!
=============================================================================