aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/mk-livestatus
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-02-23 22:20:05 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-02-23 22:20:05 +0000
commit83e0604660144d5b65112b6e8e36801eef686d17 (patch)
treeab15c08f2f20be31a08e756c0220d5b1e61658af /net-mgmt/mk-livestatus
parent7111199bb3eb9cfbbbb730785d53aaa8540d8f10 (diff)
downloadports-83e0604660144d5b65112b6e8e36801eef686d17.tar.gz
ports-83e0604660144d5b65112b6e8e36801eef686d17.zip
- update to 1.2.4
- add option to build for Nagios3 (default) and Nagios4 - add stage support - remove livecheck patches (broker was removed) Changes: ======== 1.2.4 o nagios4 livestatus support 1.2.4b1 o New header for limiting the execution time of a query o FIX: Parse state of downtime notification log entries correctly o FIX: Limit the number of lines read from a single logfile o FIX: Fix semantics of columns num_services_hard_* 1.2.3.i7 o livedump: new option to mark the mode at the beginning of the dump and documentation fixes o FIX: Fixed incorrect starttime of table statehist entries o FIX: Availability no longer showes incorrect entries when only one logfile exists o FIX: Fixed missing entries in log file and availability view 1.2.3.i5 o Removed "livecheck". It never was really stable. Nagios4 has something similar built in. o table statehist: no longer computes an unmonitored state for hosts and services on certain instances. (showed up as no hosts/services in the multisite gui) o table statehist: fixed SIGSEGV chance on larger queries 1.2.3.i3 o FIX: check_mk snmp checks with a custom check interval no longer have an incorrect staleness value 1.2.3.i2 o new service column staleness: indicator for outdated service checks o new host column staleness: indicator for outdated host checks 1.2.3i1 o Table statehist: Improved detection of vanished hosts and services. Now able to detect and remove nonsense check plugin output o FIX: able to handle equal comment_id between host and service o livestatus.log: show utf-8 decoding problems only with debug logging >=2 o livestatus: fixed incorrect output formatting of comments_with_info column 1.2.2p3 o livestatus: fixed incorrect output formatting of comments_with_info column o table statehist: fixed memory leak
Notes
Notes: svn path=/head/; revision=345774
Diffstat (limited to 'net-mgmt/mk-livestatus')
-rw-r--r--net-mgmt/mk-livestatus/Makefile31
-rw-r--r--net-mgmt/mk-livestatus/distinfo4
-rw-r--r--net-mgmt/mk-livestatus/files/patch-src__Makefile.in28
-rw-r--r--net-mgmt/mk-livestatus/files/patch-src__check_icmp.c22
-rw-r--r--net-mgmt/mk-livestatus/files/patch-src__livecheck.c63
-rw-r--r--net-mgmt/mk-livestatus/files/pkg-message.in3
6 files changed, 41 insertions, 110 deletions
diff --git a/net-mgmt/mk-livestatus/Makefile b/net-mgmt/mk-livestatus/Makefile
index b05a44bd5f8a..60e8154b2448 100644
--- a/net-mgmt/mk-livestatus/Makefile
+++ b/net-mgmt/mk-livestatus/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mk-livestatus
-PORTVERSION= 1.2.2p2
+PORTVERSION= 1.2.4
CATEGORIES= net-mgmt
MASTER_SITES= http://mathias-kettner.de/download/ \
LOCAL/ohauer
@@ -13,11 +13,21 @@ COMMENT= Nagios event broker module
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
+OPTIONS_SINGLE= NAGIOS
+OPTIONS_SINGLE_NAGIOS= NAGIOS3 NAGIOS4
+OPTIONS_DEFAULT= NAGIOS3
+
+NAGIOS3_DESC= build for nagios-3.x
+NAGIOS4_DESC= build for nagios-4.x
+
+NAGIOS4_CONFIGURE_ON= --with-nagios4
+
+.include <bsd.port.options.mk>
+
PLIST_FILES= lib/mk-livestatus/unixcat \
- lib/mk-livestatus/livecheck \
lib/mk-livestatus/livestatus.o
PLIST_DIRS= lib/${PORTNAME}
SUB_FILES= pkg-message
@@ -36,24 +46,19 @@ COMMAND_FILE?= /var/spool/nagios/rw/live
# perl api is really outdated, do not install!
# Actual version can be found on CPAN
# http://search.cpan.org/~nierlein/Monitoring-Livestatus/
-NO_STAGE= yes
post-extract:
@${RM} -rf ${WRKSRC}/api/perl
post-patch:
-.for i in ${EXAMPLE_FILES}
- @${SED} -i '' -e 's|/usr/bin/python|${LOCALBASE}/bin/python|g' \
+ @${SED} -i '' -e 's|/usr/bin/python|${LOCALBASE}/bin/python2.7|g' \
-e 's|/var/lib/nagios/rw/live|${COMMAND_FILE}|g' \
- -e 's|/var/run/nagios/rw/live|${COMMAND_FILE}|g' ${WRKSRC}/$i
-.endfor
+ -e 's|/var/run/nagios/rw/live|${COMMAND_FILE}|g' \
+ ${EXAMPLE_FILES:S|^|${WRKSRC}/|}
@${SED} -i '' -e 's|/usr/local/nagios/var/rw/live|${COMMAND_FILE}|' \
${WRKSRC}/src/livestatus.h
post-install:
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ( cd ${WRKSRC} && ${COPYTREE_SHARE} api\* ${EXAMPLESDIR}/ )
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} api\* ${STAGEDIR}${EXAMPLESDIR}/ )
.include <bsd.port.mk>
diff --git a/net-mgmt/mk-livestatus/distinfo b/net-mgmt/mk-livestatus/distinfo
index e665a473273d..3df8eb59aeda 100644
--- a/net-mgmt/mk-livestatus/distinfo
+++ b/net-mgmt/mk-livestatus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (check_mk/mk-livestatus-1.2.2p2.tar.gz) = 77213f22898cd6280196293743e9ef9486ffccca878350ed277d358146a6d0b5
-SIZE (check_mk/mk-livestatus-1.2.2p2.tar.gz) = 382165
+SHA256 (check_mk/mk-livestatus-1.2.4.tar.gz) = 1ae6c30ac2f7f182b2a4d5ca01d09cd84afb300ad75fea3bb5db8f5ae95d4eff
+SIZE (check_mk/mk-livestatus-1.2.4.tar.gz) = 434179
diff --git a/net-mgmt/mk-livestatus/files/patch-src__Makefile.in b/net-mgmt/mk-livestatus/files/patch-src__Makefile.in
index e39e7292457c..0a5f3860c2ff 100644
--- a/net-mgmt/mk-livestatus/files/patch-src__Makefile.in
+++ b/net-mgmt/mk-livestatus/files/patch-src__Makefile.in
@@ -1,6 +1,6 @@
---- ./src/Makefile.in.orig 2013-06-10 14:49:28.000000000 +0200
-+++ ./src/Makefile.in 2013-06-16 22:13:23.000000000 +0200
-@@ -264,7 +264,7 @@
+--- ./src/Makefile.in.orig 2014-02-10 10:54:03.000000000 +0100
++++ ./src/Makefile.in 2014-02-20 22:47:49.000000000 +0100
+@@ -260,7 +260,7 @@
am__quote = @am__quote@
am__tar = @am__tar@
am__untar = @am__untar@
@@ -9,11 +9,19 @@
build_alias = @build_alias@
builddir = @builddir@
datadir = @datadir@
-@@ -1966,7 +1966,6 @@
- $(INSTALL_PROGRAM) livestatus.o $(DESTDIR)$(pkglibdir)
- rm -f $(DESTDIR)$(pkglibdir)/livestatus.so
- $(INSTALL_PROGRAM) livecheck $(DESTDIR)$(pkglibdir)
-- rm -f $(DESTDIR)$(bindir)/livecheck
+@@ -366,15 +366,6 @@
+ test -z "$$list2" || { \
+ echo " $(INSTALL_DATA) $$list2 '$(DESTDIR)$(pkglibdir)'"; \
+ $(INSTALL_DATA) $$list2 "$(DESTDIR)$(pkglibdir)" || exit $$?; }
+- @$(POST_INSTALL)
+- @list='$(pkglib_LIBRARIES)'; test -n "$(pkglibdir)" || list=; \
+- for p in $$list; do \
+- if test -f $$p; then \
+- $(am__strip_dir) \
+- echo " ( cd '$(DESTDIR)$(pkglibdir)' && $(RANLIB) $$f )"; \
+- ( cd "$(DESTDIR)$(pkglibdir)" && $(RANLIB) $$f ) || exit $$?; \
+- else :; fi; \
+- done
- clean-local:
- rm -f *~
+ uninstall-pkglibLIBRARIES:
+ @$(NORMAL_UNINSTALL)
diff --git a/net-mgmt/mk-livestatus/files/patch-src__check_icmp.c b/net-mgmt/mk-livestatus/files/patch-src__check_icmp.c
deleted file mode 100644
index f2ba3f60b174..000000000000
--- a/net-mgmt/mk-livestatus/files/patch-src__check_icmp.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./src/check_icmp.c.orig 2012-11-03 13:00:18.000000000 +0100
-+++ ./src/check_icmp.c 2012-11-03 13:05:33.000000000 +0100
-@@ -65,12 +65,19 @@
- #include <netdb.h>
- #include <sys/socket.h>
- #include <net/if.h>
-+#ifdef __FreeBSD__
-+#include <netinet/in.h>
-+#include <arpa/inet.h>
-+#include <netinet/ip.h>
-+#endif
- #include "/usr/include/netinet/ip_icmp.h"
- // #include <netinet/ip_icmp.h>
- #include <netinet/in_systm.h>
-+#ifndef __FreeBSD__
- #include <netinet/in.h>
- #include <netinet/ip.h>
- #include <arpa/inet.h>
-+#endif
- #include <signal.h>
- #include <float.h>
-
diff --git a/net-mgmt/mk-livestatus/files/patch-src__livecheck.c b/net-mgmt/mk-livestatus/files/patch-src__livecheck.c
deleted file mode 100644
index 14f57066511e..000000000000
--- a/net-mgmt/mk-livestatus/files/patch-src__livecheck.c
+++ /dev/null
@@ -1,63 +0,0 @@
---- ./src/livecheck.c.orig 2013-06-10 14:49:02.000000000 +0200
-+++ ./src/livecheck.c 2013-06-16 22:13:23.000000000 +0200
-@@ -27,8 +27,14 @@
- #include <sys/wait.h>
- #include <sys/timeb.h>
- #include <sys/resource.h>
-+#ifdef __FreeBSD__
-+#include <arpa/inet.h>
-+#endif
- #include <netinet/ip.h>
- #include <stdlib.h>
-+#ifdef __FreeBSD__
-+#include <signal.h>
-+#endif
- #include <fcntl.h>
- #include <string.h>
-
-@@ -80,8 +86,13 @@
- }
-
- int is_host_check = service[0] == '\n';
-+#ifndef __FreeBSD__
- struct timeb start;
- ftime(&start);
-+#else
-+ struct timeval start;
-+ gettimeofday(&start);
-+#endif
- char output[16384];
- int return_code;
- // Optimization(1):
-@@ -188,8 +199,13 @@
- }
- }
- }
-+#ifndef __FreeBSD__
- struct timeb end;
- ftime(&end);
-+#else
-+ struct timeval end;
-+ gettimeofday(&end);
-+#endif
- char template[256];
- snprintf(template, sizeof(template), "%s/cXXXXXX", check_result_path);
- int fd = mkstemp(template);
-@@ -212,10 +228,17 @@
- getpid(),
- 0,
- latency,
-+#ifndef __FreeBSD__
- (int)start.time,
- start.millitm,
- (int)end.time,
- end.millitm,
-+#else
-+ (int)start.tv_sec,
-+ start.tv_usec / 1000,
-+ (int)end.tv_sec,
-+ end.tv_usec / 1000,
-+#endif
- return_code);
- char *ptr_output = output;
- char *ptr_walk = output;
diff --git a/net-mgmt/mk-livestatus/files/pkg-message.in b/net-mgmt/mk-livestatus/files/pkg-message.in
index 42af36e61d30..17b46766802c 100644
--- a/net-mgmt/mk-livestatus/files/pkg-message.in
+++ b/net-mgmt/mk-livestatus/files/pkg-message.in
@@ -12,4 +12,7 @@ Notes:
to %%PREFIX%%/lib/mk-livestatus
in order to avoid a conflict with sysutils/ucspi-unix
+ * livecheck was removed in 1.2.3.i5,
+ Please adjust your "broker_module=..." directive in etc/nagios/nagios.cfg!
+
=============================================================================