aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-openldap-plugins
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-08-10 08:29:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-08-10 08:29:14 +0000
commitac710b0a76a217783f9c179176ff22f3357fcf26 (patch)
tree9f5a13b7a5449482b1d47a71543b13eddb5dd89f /net-mgmt/nagios-openldap-plugins
parent5b9fd5277921ae09ba13536915cf44d9217c6ad8 (diff)
downloadports-ac710b0a76a217783f9c179176ff22f3357fcf26.tar.gz
ports-ac710b0a76a217783f9c179176ff22f3357fcf26.zip
Fix a stage violation and shebangfix
Notes
Notes: svn path=/head/; revision=364512
Diffstat (limited to 'net-mgmt/nagios-openldap-plugins')
-rw-r--r--net-mgmt/nagios-openldap-plugins/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-mgmt/nagios-openldap-plugins/Makefile b/net-mgmt/nagios-openldap-plugins/Makefile
index a91422faf015..68f60c789621 100644
--- a/net-mgmt/nagios-openldap-plugins/Makefile
+++ b/net-mgmt/nagios-openldap-plugins/Makefile
@@ -21,8 +21,9 @@ RUN_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
PORTSCOUT= ignore:1
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= check_*.pl
PLIST_FILES= libexec/nagios/check_berkeleydb_locks.pl \
libexec/nagios/check_ldap_dn.pl \
@@ -44,7 +45,7 @@ post-patch:
${WRKSRC}/*.pl
do-install:
- @${MKDIR} ${PREFIX}/libexec/nagios
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
@(cd ${WRKSRC} && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/libexec/nagios/)
.include <bsd.port.mk>