aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-05-02 10:46:27 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-05-02 10:46:27 +0000
commit1486d28ef0e935d046258d8f867b4bc1f82be649 (patch)
tree52b37fe6310b3c4928a5f80f0837f435ccea85df /net-mgmt/nagios-plugins
parent01439e73e0055e5d60235a029d33780946b7e308 (diff)
downloadports-1486d28ef0e935d046258d8f867b4bc1f82be649.tar.gz
ports-1486d28ef0e935d046258d8f867b4bc1f82be649.zip
Update to 2.2.1.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=439937
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios-plugins/distinfo6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-configure4
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_check__http.c25
4 files changed, 6 insertions, 32 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index fc0e06ee82ed..89b50383494a 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTVERSION= 2.2.1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index 1e27d1b5b71c..b0bac70f7569 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486472062
-SHA256 (nagios-plugins-2.2.0.tar.gz) = c37b9ceadea54786799da6078c6720cea2dd408879cfb7f401bef84b808a9e1c
-SIZE (nagios-plugins-2.2.0.tar.gz) = 2725282
+TIMESTAMP = 1493720605
+SHA256 (nagios-plugins-2.2.1.tar.gz) = 647c0ba4583d891c965fc29b77c4ccfeccc21f409fdf259cb8af52cb39c21e18
+SIZE (nagios-plugins-2.2.1.tar.gz) = 2728818
diff --git a/net-mgmt/nagios-plugins/files/patch-configure b/net-mgmt/nagios-plugins/files/patch-configure
index d8bdfcc2b871..5c3a7dbcc395 100644
--- a/net-mgmt/nagios-plugins/files/patch-configure
+++ b/net-mgmt/nagios-plugins/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2016-09-12 15:45:43 UTC
+--- configure.orig 2017-04-19 16:03:27 UTC
+++ configure
-@@ -21949,7 +21949,7 @@ then
+@@ -22004,7 +22004,7 @@ then
$as_echo "$ac_cv_ps_command" >&6; }
elif ps -axwwo 'stat comm vsz rss user uid pid ppid args' 2>/dev/null | \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins_check__http.c b/net-mgmt/nagios-plugins/files/patch-plugins_check__http.c
deleted file mode 100644
index 2f3573b755bd..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins_check__http.c
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7300528aca1da07b93cab52493552b445b1c276b Mon Sep 17 00:00:00 2001
-From: "John C. Frickson" <jfrickson@nagios.com>
-Date: Mon, 27 Feb 2017 15:29:06 -0600
-Subject: [PATCH] check_http reports warning where it should report ok with -e
-
-Fix for issue #236
---- plugins/check_http.c.orig 2017-01-19 16:01:31 UTC
-+++ plugins/check_http.c
-@@ -1263,12 +1263,14 @@ check_http (void)
- /* server errors result in a critical state */
- else if (http_status >= 500) {
- xasprintf (&msg, _("%s%s - "), msg, status_line);
-- result = STATE_CRITICAL;
-+ if (bad_response || !server_expect_yn)
-+ result = STATE_CRITICAL;
- }
- /* client errors result in a warning state */
- else if (http_status >= 400) {
- xasprintf (&msg, _("%s%s - "), msg, status_line);
-- result = max_state_alt(STATE_WARNING, result);
-+ if (bad_response || !server_expect_yn)
-+ result = max_state_alt(STATE_WARNING, result);
- }
- /* check redirected page if specified */
- else if (http_status >= 300) {