aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-10-29 07:56:53 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-10-29 07:56:53 +0000
commit2277b0a71f7580c251317e281c38ad2fc508bb39 (patch)
tree71b663083d6fdfe6a35a6905f5eed58dc6a7c121 /net-mgmt/nagios-plugins
parent4f62a9966b234bf9c024d7102a46c094c8984b22 (diff)
downloadports-2277b0a71f7580c251317e281c38ad2fc508bb39.tar.gz
ports-2277b0a71f7580c251317e281c38ad2fc508bb39.zip
Add an option to build with ssh from security/openssh-portable instead of base ssh.
PR: 193754 Submitted by: chrysalis chrysalisnet org Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=371665
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 7ad2807a884e..05958e0ae45c 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.0.3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
@@ -19,8 +19,8 @@ CONFLICTS_INSTALL= monitoring-plugins-*
USES= charsetfix gmake perl5 libtool
USE_SUBMAKE= yes
-
-OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 JAIL NLS DBI EXTRAOPTS
+WITH=SSH_PORTABLE
+OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 JAIL NLS DBI EXTRAOPTS SSH_PORTABLE
OPTIONS_SINGLE= DNS
OPTIONS_SINGLE_DNS= DNS_BASE DNS_BINDTOOLS DNS_BIND99 DNS_BIND910
OPTIONS_DEFAULT=IPV6 EXTRAOPTS DNS_BASE
@@ -36,6 +36,7 @@ LDAP_DESC= OpenLDAP support (check_ldap)
JAIL_DESC= Compilation within jail(8) (see help)
DBI_DESC= Check database using DBI
EXTRAOPTS_DESC= Parsing of plugins ini config files for extra options
+SSH_PORTABLE_DESC= Build check_ssh with ports openssh (instead of base)
DNS_DESC= Configuration of check_dig and check_dns (see help)
@@ -127,6 +128,10 @@ DNS_BIND910_BUILD_DEPENDS= ${LOCALBASE}/bin/dig:${PORTSDIR}/dns/bind910
DNS_BIND910_CONFIGURE_ON= --with-dig-command=${LOCALBASE}/bin/dig \
--with-nslookup-command=${LOCALBASE}/bin/nslookup
+SSH_PORTABLE_BUILD_DEPENDS= ${LOCALBASE}/bin/ssh:${PORTSDIR}/security/openssh-portable
+SSH_PORTABLE_RUN_DEPENDS:= ${SSH_PORTABLE_BUILD_DEPENDS}
+SSH_PORTABLE_CONFIGURE_ON= --with-ssh-command=${LOCALBASE}/bin/ssh
+
.include <bsd.port.options.mk>
.if ${OSVERSION} > 1000055 && ${PORT_OPTIONS:MDNS_BASE}
@@ -141,7 +146,7 @@ CONFIGURE_ARGS+= --with-dig-command=/usr/bin/dig \
PLIST_SUB+= CHECK_DNS=""
.endif
-.if !exists(/usr/bin/ssh)
+.if !exists(/usr/bin/ssh) && empty(PORT_OPTIONS:MSSH_PORTABLE)
PLIST_SUB+= SSH="@comment "
.else
PLIST_SUB+= SSH=""