aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-plugins
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-03 14:21:35 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-03 14:21:35 +0000
commitd462f7ed56b19a09201e92ccbb7110c3a96071fa (patch)
treef1776f9cd597a801ac61b9a83432c99559d59da9 /net-mgmt/nagios-plugins
parent1eb5c2f1365e5393c6d06aaa59307027de225aa3 (diff)
downloadports-d462f7ed56b19a09201e92ccbb7110c3a96071fa.tar.gz
ports-d462f7ed56b19a09201e92ccbb7110c3a96071fa.zip
Update to 2.1.2.
Reported by: portscout Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=419525
Diffstat (limited to 'net-mgmt/nagios-plugins')
-rw-r--r--net-mgmt/nagios-plugins/Makefile10
-rw-r--r--net-mgmt/nagios-plugins/distinfo5
-rw-r--r--net-mgmt/nagios-plugins/files/patch-configure8
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c21
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl12
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__mailq.pl11
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_netutils.c14
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c16
10 files changed, 28 insertions, 81 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 0b686da3d0fe..5effeda361ac 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= nagios-plugins
-PORTVERSION= 2.1.1
-PORTREVISION= 5
+PORTVERSION= 2.1.2
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
@@ -23,7 +23,7 @@ USE_SUBMAKE= yes
OPTIONS_DEFINE= QSTAT FPING NETSNMP RADIUS MYSQL PGSQL LDAP IPV6 NLS DBI EXTRAOPTS SSH_PORTABLE
OPTIONS_SINGLE= DNS
-OPTIONS_SINGLE_DNS= DNS_BASE DNS_BINDTOOLS DNS_BIND99 DNS_BIND910
+OPTIONS_SINGLE_DNS= DNS_BASE DNS_BINDTOOLS DNS_BIND99 DNS_BIND910 DNS_BIND911
OPTIONS_DEFAULT=EXTRAOPTS DNS_BASE
OPTIONS_SUB= yes
@@ -44,6 +44,7 @@ DNS_BASE_DESC= >= 10 means drill for check_dig and no check_dns
DNS_BINDTOOLS_DESC= Use dig and nslookup from dns/bind-tools
DNS_BIND99_DESC= Use dig and nslookup from dns/bind99
DNS_BIND910_DESC= Use dig and nslookup from dns/bind910
+DNS_BIND911_DESC= Use dig and nslookup from dns/bind911
EXTRAOPTS_CONFIGURE_ENABLE= extra-opts
@@ -127,6 +128,9 @@ DNS_BIND99_CONFIGURE_ON= --with-dig-command=${LOCALBASE}/bin/dig \
DNS_BIND910_BUILD_DEPENDS= ${LOCALBASE}/bin/dig:dns/bind910
DNS_BIND910_CONFIGURE_ON= --with-dig-command=${LOCALBASE}/bin/dig \
--with-nslookup-command=${LOCALBASE}/bin/nslookup
+DNS_BIND911_BUILD_DEPENDS= ${LOCALBASE}/bin/dig:dns/bind911
+DNS_BIND911_CONFIGURE_ON= --with-dig-command=${LOCALBASE}/bin/dig \
+ --with-nslookup-command=${LOCALBASE}/bin/nslookup
SSH_PORTABLE_BUILD_DEPENDS= ${LOCALBASE}/bin/ssh:security/openssh-portable
SSH_PORTABLE_RUN_DEPENDS:= ${SSH_PORTABLE_BUILD_DEPENDS}
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index f9a63f13325e..89f63274061f 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,2 +1,3 @@
-SHA256 (nagios-plugins-2.1.1.tar.gz) = c7daf95ecbf6909724258e55a319057b78dcca23b2a6cc0a640b90c90d4feae3
-SIZE (nagios-plugins-2.1.1.tar.gz) = 2677352
+TIMESTAMP = 1470231717
+SHA256 (nagios-plugins-2.1.2.tar.gz) = f2ed5d07b1823341f9db56b187ae5c0ee9018b6c69a152b6a240c5e14cd94ea4
+SIZE (nagios-plugins-2.1.2.tar.gz) = 2695301
diff --git a/net-mgmt/nagios-plugins/files/patch-configure b/net-mgmt/nagios-plugins/files/patch-configure
index d096efb5232c..cf652921b7ce 100644
--- a/net-mgmt/nagios-plugins/files/patch-configure
+++ b/net-mgmt/nagios-plugins/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig 2015-07-31 17:47:20 UTC
+--- configure.orig 2016-08-01 16:28:00 UTC
+++ configure
-@@ -22224,7 +22224,7 @@ then
+@@ -21947,7 +21947,7 @@ then
$as_echo "$ac_cv_ps_command" >&6; }
- elif ps -axwo 'stat comm vsz rss user uid pid ppid args' 2>/dev/null | \
+ elif ps -axwwo 'stat comm vsz rss user uid pid ppid args' 2>/dev/null | \
- egrep -i "^ *STAT +[UCOMAND]+ +VSZ +RSS +USER +UID +PID +PPID +COMMAND" > /dev/null
+ egrep -i "^ *STAT +COMMAND +VSZ +RSS +USER +UID +PID +PPID +COMMAND" > /dev/null
then
ac_cv_ps_varlist="procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos"
- ac_cv_ps_command="$PATH_TO_PS -axwo 'stat uid pid ppid vsz rss pcpu comm args'"
+ ac_cv_ps_command="$PATH_TO_PS -axwwo 'stat uid pid ppid vsz rss pcpu comm args'"
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c b/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
deleted file mode 100644
index 926d3b7eddff..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins-root_check__dhcp.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- plugins-root/check_dhcp.c.orig 2015-07-30 21:40:06 UTC
-+++ plugins-root/check_dhcp.c
-@@ -326,7 +326,8 @@ int get_hardware_address(int sock,char *
- #elif defined(__bsd__)
- /* King 2004 see ACKNOWLEDGEMENTS */
-
-- int mib[6], len;
-+ int mib[6];
-+ size_t len;
- char *buf;
- unsigned char *ptr;
- struct if_msghdr *ifm;
-@@ -1194,7 +1195,7 @@ int call_getopt(int argc, char **argv){
- }
- }
-
-- return i;
-+ return i+1;
- }
-
-
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl
deleted file mode 100644
index 38475e97ba3e..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl
+++ /dev/null
@@ -1,12 +0,0 @@
---- plugins-scripts/check_file_age.pl.orig 2015-07-30 21:40:06 UTC
-+++ plugins-scripts/check_file_age.pl
-@@ -26,7 +26,8 @@ use English;
- use Getopt::Long;
- use File::stat;
- use vars qw($PROGNAME);
--use lib ".";
-+use FindBin;
-+use lib "$FindBin::Bin";
- use utils qw (%ERRORS &print_revision &support);
-
- sub print_help ();
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl
index 5b09476f279d..f901c3061bc5 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl
@@ -1,6 +1,6 @@
---- plugins-scripts/check_ircd.pl.orig 2015-07-30 21:40:06 UTC
+--- plugins-scripts/check_ircd.pl.orig 2016-08-01 16:27:46 UTC
+++ plugins-scripts/check_ircd.pl
-@@ -67,6 +67,7 @@ sub bindRemote ($$);
+@@ -68,6 +68,7 @@ sub bindRemote ($$);
$ENV{'PATH'}='@TRUSTED_PATH@';
$ENV{'BASH_ENV'}='';
$ENV{'ENV'}='';
@@ -8,7 +8,7 @@
# -----------------------------------------------------------------[ Global ]--
-@@ -154,7 +155,7 @@ sub bindRemote ($$)
+@@ -155,7 +156,7 @@ sub bindRemote ($$)
print "IRCD UNKNOWN: Could not start socket ($!)\n";
exit $ERRORS{"UNKNOWN"};
}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__mailq.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__mailq.pl
deleted file mode 100644
index b77b2406b81f..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__mailq.pl
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins-scripts/check_mailq.pl.orig 2015-07-30 21:40:06 UTC
-+++ plugins-scripts/check_mailq.pl
-@@ -35,7 +35,7 @@ use FindBin;
- use lib "$FindBin::Bin";
- use utils qw(%ERRORS &print_revision &support &usage );
-
--my ($sudo)
-+my ($sudo);
-
- sub print_help ();
- sub print_usage ();
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl
index 40e8668f427b..f1e43e6e5009 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl
@@ -1,6 +1,6 @@
---- plugins-scripts/check_ntp.pl.orig 2015-07-30 21:40:06 UTC
+--- plugins-scripts/check_ntp.pl.orig 2016-08-01 16:27:46 UTC
+++ plugins-scripts/check_ntp.pl
-@@ -313,7 +313,6 @@ if ($have_ntpq) {
+@@ -314,7 +314,6 @@ if ($have_ntpq) {
}
} else {
print "No match!\n" if $verbose;
@@ -8,7 +8,7 @@
}
}
-@@ -427,7 +426,7 @@ if ($ntpdate_error != $ERRORS{'OK'}) {
+@@ -428,7 +427,7 @@ if ($ntpdate_error != $ERRORS{'OK'}) {
foreach my $key (keys %ERRORS) {
if ($state==$ERRORS{$key}) {
# print ("NTP $key: $answer");
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c b/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c
index b94e00358ba4..b211deaf4615 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins_netutils.c
@@ -1,6 +1,6 @@
---- plugins/netutils.c.orig 2015-07-30 21:40:06 UTC
+--- plugins/netutils.c.orig 2016-08-01 16:27:46 UTC
+++ plugins/netutils.c
-@@ -158,7 +158,7 @@ int
+@@ -179,7 +179,7 @@ int
np_net_connect (const char *host_name, int port, int *sd, int proto)
{
struct addrinfo hints;
@@ -9,7 +9,7 @@
struct sockaddr_un su;
char port_str[6], host[MAX_HOST_ADDRESS_LENGTH];
size_t len;
-@@ -185,12 +185,13 @@ np_net_connect (const char *host_name, i
+@@ -206,7 +206,7 @@ np_net_connect (const char *host_name, i
memcpy (host, host_name, len);
host[len] = '\0';
snprintf (port_str, sizeof (port_str), "%d", port);
@@ -17,14 +17,16 @@
+ result = getaddrinfo (host, port_str, &hints, &res0);
if (result != 0) {
- printf ("%s\n", gai_strerror (result));
+ if (result == EAI_NONAME)
+@@ -215,6 +215,7 @@ np_net_connect (const char *host_name, i
+ printf ("%s\n", gai_strerror (result));
return STATE_UNKNOWN;
}
+ res = res0;
while (res) {
/* attempt to create a socket */
-@@ -198,7 +199,7 @@ np_net_connect (const char *host_name, i
+@@ -222,7 +223,7 @@ np_net_connect (const char *host_name, i
if (*sd < 0) {
printf ("%s\n", _("Socket creation failed"));
@@ -33,7 +35,7 @@
return STATE_UNKNOWN;
}
-@@ -221,7 +222,7 @@ np_net_connect (const char *host_name, i
+@@ -245,7 +246,7 @@ np_net_connect (const char *host_name, i
close (*sd);
res = res->ai_next;
}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c b/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c
deleted file mode 100644
index 1c531d4ca98c..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- plugins/sslutils.c.orig 2015-07-30 21:40:06 UTC
-+++ plugins/sslutils.c
-@@ -70,8 +70,13 @@ int np_net_ssl_init_with_hostname_versio
- #endif
- break;
- case 3: /* SSLv3 protocol */
-+#if defined(OPENSSL_NO_SSL3)
-+ printf(("%s\n", _("CRITICAL - SSL protocol version 3 is not supported by your SSL library.")));
-+ return STATE_CRITICAL;
-+#else
- method = SSLv3_client_method();
- ssl_options = SSL_OP_NO_SSLv2 | SSL_OP_NO_TLSv1;
-+#endif
- break;
- default: /* Unsupported */
- printf("%s\n", _("CRITICAL - Unsupported SSL protocol version."));