aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagiosql
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-08-23 09:08:44 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-08-23 09:08:44 +0000
commit0ce3269bc4fdbf23058199f84b034ea1329ebbdc (patch)
tree9829290324eae320de2b5d2460807373e29cf2c2 /net-mgmt/nagiosql
parent95d1e8b57f1d4bcdc3b1509e28e9e0301f429cb8 (diff)
downloadports-0ce3269bc4fdbf23058199f84b034ea1329ebbdc.tar.gz
ports-0ce3269bc4fdbf23058199f84b034ea1329ebbdc.zip
- Update to 3.2.0
- Incorporate SP1 - Superseed ports/170391 PR: ports/170396 Submitted by: Helmut Schneider <jumper99@gmx.de> Approved by: maintainer, timeout (14 days)
Notes
Notes: svn path=/head/; revision=302984
Diffstat (limited to 'net-mgmt/nagiosql')
-rw-r--r--net-mgmt/nagiosql/Makefile8
-rw-r--r--net-mgmt/nagiosql/distinfo4
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-admin-contacts.php24
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-admin-hosts.php23
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-admin-services.php23
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-admin-templatedefinitions.php44
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-functions-config__class.php61
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-functions-import__class.php24
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__adm.php11
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__content.php32
-rw-r--r--net-mgmt/nagiosql/files/patch-nagiosql32-templates-admin-user.tpl.htm11
-rw-r--r--net-mgmt/nagiosql/pkg-plist138
12 files changed, 329 insertions, 74 deletions
diff --git a/net-mgmt/nagiosql/Makefile b/net-mgmt/nagiosql/Makefile
index 0f91c126f8c3..2363f17c73af 100644
--- a/net-mgmt/nagiosql/Makefile
+++ b/net-mgmt/nagiosql/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nagiosql
-PORTVERSION= 3.1.1
+PORTVERSION= 3.2.0
CATEGORIES= net-mgmt www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NagiosQL%20${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
@@ -14,11 +14,11 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= chris@smartt.com
COMMENT= A web based administration tool for Nagios
+LICENSE= GPLv2
+
RUN_DEPENDS= nagios:${PORTSDIR}/net-mgmt/nagios \
${PEARDIR}/HTML/Template/IT.php:${PORTSDIR}/devel/pear-HTML_Template_IT
-LICENSE= GPLv2
-
USE_BZIP2= yes
USE_MYSQL= yes
USE_GETTEXT= yes
@@ -48,7 +48,7 @@ USE_PHP+= ssh2
do-install:
${MKDIR} ${WWWDIR}
- ${CP} -R ${WRKSRC}/${PORTNAME}/ ${WWWDIR}
+ ${CP} -R ${WRKSRC}/${PORTNAME}32/ ${WWWDIR}
${CHOWN} ${WWWOWN}:${WWWGROUP} ${WWWDIR}/config
post-install:
diff --git a/net-mgmt/nagiosql/distinfo b/net-mgmt/nagiosql/distinfo
index 0c7299f67740..66dc86eb018a 100644
--- a/net-mgmt/nagiosql/distinfo
+++ b/net-mgmt/nagiosql/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nagiosql_311.tar.bz2) = 1664701d5b114dfce4716d3644ebc399e50ef9a6478f7282ca3c92abd40e7814
-SIZE (nagiosql_311.tar.bz2) = 978963
+SHA256 (nagiosql_320.tar.bz2) = a5259d2342752949f005533eec5a68c10e7476b83f192e972d9edcd3ec92d5d1
+SIZE (nagiosql_320.tar.bz2) = 921396
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-admin-contacts.php b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-contacts.php
new file mode 100644
index 000000000000..6f86fe57893b
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-contacts.php
@@ -0,0 +1,24 @@
+--- ../nagiosql/work/./nagiosql32/admin/contacts.php 2012-03-27 12:47:56.000000000 +0200
++++ ./nagiosql32/admin/contacts.php 2012-04-20 12:39:56.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Contact definitions
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-27 12:47:56 +0200 (Tue, 27 Mar 2012) $
++// Date : $LastChangedDate: 2012-04-20 12:39:53 +0200 (Fr, 20. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1308 $
++// Revision : $LastChangedRevision: 1323 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////
+ //
+@@ -259,7 +259,7 @@
+ } else {
+ $conttp->setVariable("HOST_OPTION_FIELDS","chbGr1a,chbGr1b,chbGr1c,chbGr1d,chbGr1f");
+ $conttp->setVariable("SERVICE_OPTION_FIELDS","chbGr2a,chbGr2b,chbGr2c,chbGr2d,chbGr2e,chbGr2g");
+- $conttp->setVariable("VERSION_20_VALUE_MUST",",tfFriendly");
++ $conttp->setVariable("VERSION_20_VALUE_MUST",",tfValue2");
+ }
+ // Insert data from database in "modify" mode
+ if (isset($arrModifyData) && ($chkSelModify == "modify")) {
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-admin-hosts.php b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-hosts.php
new file mode 100644
index 000000000000..f95da42c5c9c
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-hosts.php
@@ -0,0 +1,23 @@
+--- ../nagiosql/work/./nagiosql32/admin/hosts.php 2012-03-09 07:43:00.000000000 +0100
++++ ./nagiosql32/admin/hosts.php 2012-04-17 11:54:12.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Host definition
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-09 07:43:00 +0100 (Fri, 09 Mar 2012) $
++// Date : $LastChangedDate: 2012-04-05 08:11:59 +0200 (Do, 05. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1282 $
++// Revision : $LastChangedRevision: 1315 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////
+ //
+@@ -41,7 +41,6 @@
+ if ($chkSelValue1 != "") {
+ for ($i=1;$i<=8;$i++) {
+ ${"chkTfArg$i"} = str_replace("!","::bang::",${"chkTfArg$i"});
+- ${"chkTfArg$i"} = str_replace("\\","::back::",${"chkTfArg$i"});
+ if (${"chkTfArg$i"} != "") $chkSelValue1 .= "!".${"chkTfArg$i"};
+ }
+ }
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-admin-services.php b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-services.php
new file mode 100644
index 000000000000..d2c348ecbedf
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-services.php
@@ -0,0 +1,23 @@
+--- ../nagiosql/work/./nagiosql32/admin/services.php 2012-03-09 07:43:00.000000000 +0100
++++ ./nagiosql32/admin/services.php 2012-04-17 11:53:36.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Service definition
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-09 07:43:00 +0100 (Fri, 09 Mar 2012) $
++// Date : $LastChangedDate: 2012-04-05 08:11:59 +0200 (Do, 05. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1282 $
++// Revision : $LastChangedRevision: 1315 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////
+ //
+@@ -41,7 +41,6 @@
+ if ($chkSelValue1 != "") {
+ for ($i=1;$i<=8;$i++) {
+ ${"chkTfArg$i"} = str_replace("!","::bang::",${"chkTfArg$i"});
+- ${"chkTfArg$i"} = str_replace("\\","::back::",${"chkTfArg$i"});
+ if (${"chkTfArg$i"} != "") $chkSelValue1 .= "!".${"chkTfArg$i"};
+ }
+ }
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-admin-templatedefinitions.php b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-templatedefinitions.php
new file mode 100644
index 000000000000..1cdfb1e56f49
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-admin-templatedefinitions.php
@@ -0,0 +1,44 @@
+--- ../nagiosql/work/./nagiosql32/admin/templatedefinitions.php 2012-02-27 13:01:17.000000000 +0100
++++ ./nagiosql32/admin/templatedefinitions.php 2012-04-05 08:12:08.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Template definition list
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-02-27 13:01:17 +0100 (Mon, 27 Feb 2012) $
++// Date : $LastChangedDate: 2012-04-05 08:11:59 +0200 (Do, 05. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1257 $
++// Revision : $LastChangedRevision: 1315 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////
+ //
+@@ -102,8 +102,10 @@
+ if ($chkMode == "add") {
+ if ($arrDefinition[1] == 1) {
+ $strSQL2 = "SELECT `template_name` FROM `tbl_".$chkPreTab."template` WHERE `id` = ".$arrDefinition[0];
++ $strSQL3 = "SELECT `active` FROM `tbl_".$chkPreTab."template` WHERE `id` = ".$arrDefinition[0];
+ } else {
+ $strSQL2 = "SELECT `name` FROM `tbl_".$chkPreTab."` WHERE `id` = ".$arrDefinition[0];
++ $strSQL3 = "SELECT `active` FROM `tbl_".$chkPreTab."` WHERE `id` = ".$arrDefinition[0];
+ }
+ if (isset($_SESSION['templatedefinition']) && is_array($_SESSION['templatedefinition'])) {
+ $intCheck = 0;
+@@ -118,7 +120,7 @@
+ $arrTemp['idTable'] = $arrDefinition[1];
+ $arrTemp['idSort'] = 0;
+ $arrTemp['status'] = 0;
+- $arrTemp['active'] = 0;
++ $arrTemp['active'] = $myDBClass->getFieldData($strSQL3)+0;
+ $_SESSION['templatedefinition'][] = $arrTemp;
+ }
+ } else {
+@@ -127,7 +129,7 @@
+ $arrTemp['idTable'] = $arrDefinition[1];
+ $arrTemp['idSort'] = 0;
+ $arrTemp['status'] = 0;
+- $arrTemp['active'] = 0;
++ $arrTemp['active'] = $myDBClass->getFieldData($strSQL3)+0;
+ $_SESSION['templatedefinition'][] = $arrTemp;
+ }
+ }
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-functions-config__class.php b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-config__class.php
new file mode 100644
index 000000000000..7282c7213220
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-config__class.php
@@ -0,0 +1,61 @@
+--- ../nagiosql/work/./nagiosql32/functions/config_class.php 2012-03-07 10:38:34.000000000 +0100
++++ ./nagiosql32/functions/config_class.php 2012-04-17 11:59:16.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Configuration Class
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-07 10:38:34 +0100 (Wed, 07 Mar 2012) $
++// Date : $LastChangedDate: 2012-04-17 11:47:05 +0200 (Di, 17. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1275 $
++// Revision : $LastChangedRevision: 1319 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////////////////////
+ //
+@@ -749,13 +749,6 @@
+ //
+ ///////////////////////////////////////////////////////////////////////////////////////////
+ function createConfigSingle($strTableName,$intDbId = 0,$intMode = 0) {
+- // Get write access groups
+- if (isset($_SESSION['userid'])) {
+- $strAccess = $this->myVisClass->getAccGroups('write');
+- $strAccWhere = " AND `access_group` IN ($strAccess) ";
+- } else {
+- $strAccWhere = "";
+- }
+ // Do not create configs in common domain
+ if ($this->intDomainId == 0) {
+ $this->processClassMessage(translate('It is not possible to write config files directly from the common domain!')."::",$this->strErrorMessage);
+@@ -769,9 +762,9 @@
+ $strDomainWhere = " (`config_id`=".$this->intDomainId.") ";
+ }
+ if ($intDbId == 0) {
+- $strSQL = "SELECT * FROM `".$strTableName."` WHERE $strDomainWhere AND `active`='1' $strAccWhere ORDER BY `id`";
++ $strSQL = "SELECT * FROM `".$strTableName."` WHERE $strDomainWhere AND `active`='1' ORDER BY `id`";
+ } else {
+- $strSQL = "SELECT * FROM `".$strTableName."` WHERE $strDomainWhere AND `active`='1' $strAccWhere AND `id`=$intDbId";
++ $strSQL = "SELECT * FROM `".$strTableName."` WHERE $strDomainWhere AND `active`='1' AND `id`=$intDbId";
+ }
+ $booReturn = $this->myDBClass->getDataArray($strSQL,$arrData,$intDataCount);
+ if (($booReturn != false) && ($intDataCount != 0)) {
+@@ -1381,8 +1374,8 @@
+ if ($key == "contacts") $value = $this->checkTpl($value,"contacts_tploptions","tbl_host",$intDataId,$intSkip);
+ if ($key == "contact_groups") $value = $this->checkTpl($value,"contact_groups_tploptions","tbl_host",$intDataId,$intSkip);
+ if ($key == "use") $value = $this->checkTpl($value,"use_template_tploptions","tbl_host",$intDataId,$intSkip);
++ if ($key == "check_command") $value = str_replace("\::bang::","\!",$value);
+ if ($key == "check_command") $value = str_replace("::bang::","\!",$value);
+- if ($key == "check_command") $value = str_replace("::back::","\\\\",$value);
+ }
+ if ($strTableName == "tbl_service") {
+ if ($key == "use_template") $key = "use";
+@@ -1403,8 +1396,8 @@
+ if ($key == "contacts") $value = $this->checkTpl($value,"contacts_tploptions","tbl_service",$intDataId,$intSkip);
+ if ($key == "contact_groups") $value = $this->checkTpl($value,"contact_groups_tploptions","tbl_service",$intDataId,$intSkip);
+ if ($key == "use") $value = $this->checkTpl($value,"use_template_tploptions","tbl_service",$intDataId,$intSkip);
++ if ($key == "check_command") $value = str_replace("\::bang::","\!",$value);
+ if ($key == "check_command") $value = str_replace("::bang::","\!",$value);
+- if ($key == "check_command") $value = str_replace("::back::","\\\\",$value);
+ }
+ if ($strTableName == "tbl_hosttemplate") {
+ if ($key == "template_name") $key = "name";
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-functions-import__class.php b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-import__class.php
new file mode 100644
index 000000000000..74da2c80d9ac
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-import__class.php
@@ -0,0 +1,24 @@
+--- ../nagiosql/work/./nagiosql32/functions/import_class.php 2012-03-07 10:38:34.000000000 +0100
++++ ./nagiosql32/functions/import_class.php 2012-04-17 11:47:08.000000000 +0200
+@@ -10,10 +10,10 @@
+ // Project : NagiosQL
+ // Component : Import Class
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-07 10:38:34 +0100 (Wed, 07 Mar 2012) $
++// Date : $LastChangedDate: 2012-04-17 11:47:05 +0200 (Di, 17. Apr 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+-// Revision : $LastChangedRevision: 1275 $
++// Revision : $LastChangedRevision: 1319 $
+ //
+ ///////////////////////////////////////////////////////////////////////////////////////////////
+ //
+@@ -75,7 +75,7 @@
+ $intRemoveTmp = 0;
+ $strFileName = trim($strFileName);
+ $intReturn = $this->myConfigClass->getConfigData($intConfigId,"method",$intMethod);
+- if ($intReturn != 0) { $this->strErrorMessage .= translate('Unable to get configuration data:')."method::"; return(1); }
++ if ($intReturn != 0) { $this->strErrorMessage .= translate('Unable to get configuration data:')." method::"; return(1); }
+ // Read import file
+ // Local file system
+ if ($intMethod == 1) {
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__adm.php b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__adm.php
new file mode 100644
index 000000000000..7109fa87ab71
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__adm.php
@@ -0,0 +1,11 @@
+--- ../nagiosql/work/./nagiosql32/functions/prepend_adm.php 2012-03-27 12:47:56.000000000 +0200
++++ ./nagiosql32/functions/prepend_adm.php 2012-03-27 12:47:58.000000000 +0200
+@@ -9,7 +9,7 @@
+ // Project : NagiosQL
+ // Component : Preprocessing script
+ // Website : http://www.nagiosql.org
+-// Date : $LastChangedDate: 2012-03-27 12:47:56 +0200 (Tue, 27 Mar 2012) $
++// Date : $LastChangedDate: 2012-03-27 12:47:56 +0200 (Di, 27. Mär 2012) $
+ // Author : $LastChangedBy: martin $
+ // Version : 3.2.0
+ // Revision : $LastChangedRevision: 1308 $
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__content.php b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__content.php
new file mode 100644
index 000000000000..9a1bff1f9ef8
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-functions-prepend__content.php
@@ -0,0 +1,32 @@
+--- ../nagiosql/work/./nagiosql32/functions/prepend_content.php 2012-02-29 11:01:14.000000000 +0100
++++ ./nagiosql32/functions/prepend_content.php 2012-04-04 07:30:16.000000000 +0200
+@@ -178,6 +178,14 @@
+ $chkTfValue19 = addslashes($chkTfValue19);
+ $chkTfValue20 = addslashes($chkTfValue20);
+ $chkTaValue1 = addslashes($chkTaValue1);
++ $chkTfArg1 = addslashes($chkTfArg1);
++ $chkTfArg2 = addslashes($chkTfArg2);
++ $chkTfArg3 = addslashes($chkTfArg3);
++ $chkTfArg4 = addslashes($chkTfArg4);
++ $chkTfArg5 = addslashes($chkTfArg5);
++ $chkTfArg6 = addslashes($chkTfArg6);
++ $chkTfArg7 = addslashes($chkTfArg7);
++ $chkTfArg8 = addslashes($chkTfArg8);
+ $chkTaFileText = addslashes($chkTaFileText);
+ }
+ //
+@@ -204,6 +212,14 @@
+ $chkTfValue18 = $myVisClass->tfSecure($chkTfValue18);
+ $chkTfValue19 = $myVisClass->tfSecure($chkTfValue19);
+ $chkTfValue20 = $myVisClass->tfSecure($chkTfValue20);
++$chkTfArg1 = $myVisClass->tfSecure($chkTfArg1);
++$chkTfArg2 = $myVisClass->tfSecure($chkTfArg2);
++$chkTfArg3 = $myVisClass->tfSecure($chkTfArg3);
++$chkTfArg4 = $myVisClass->tfSecure($chkTfArg4);
++$chkTfArg5 = $myVisClass->tfSecure($chkTfArg5);
++$chkTfArg6 = $myVisClass->tfSecure($chkTfArg6);
++$chkTfArg7 = $myVisClass->tfSecure($chkTfArg7);
++$chkTfArg8 = $myVisClass->tfSecure($chkTfArg8);
+ $chkTaValue1 = $myVisClass->tfSecure($chkTaValue1);
+ $chkTaFileText = stripslashes($chkTaFileText);
+ //
diff --git a/net-mgmt/nagiosql/files/patch-nagiosql32-templates-admin-user.tpl.htm b/net-mgmt/nagiosql/files/patch-nagiosql32-templates-admin-user.tpl.htm
new file mode 100644
index 000000000000..86ab3decb81e
--- /dev/null
+++ b/net-mgmt/nagiosql/files/patch-nagiosql32-templates-admin-user.tpl.htm
@@ -0,0 +1,11 @@
+--- ../nagiosql/work/./nagiosql32/templates/admin/user.tpl.htm 2012-03-27 12:47:56.000000000 +0200
++++ ./nagiosql32/templates/admin/user.tpl.htm 2012-03-27 12:47:58.000000000 +0200
+@@ -3,7 +3,7 @@
+ <!-- Project : NagiosQL -->
+ <!-- Component : User template -->
+ <!-- Website : http://www.nagiosql.org -->
+-<!-- Date : $LastChangedDate: 2012-03-27 12:47:56 +0200 (Tue, 27 Mar 2012) $ -->
++<!-- Date : $LastChangedDate: 2012-03-27 12:47:56 +0200 (Di, 27. Mär 2012) $ -->
+ <!-- Author : $LastChangedBy: martin $ -->
+ <!-- Version : 3.2.0 -->
+ <!-- Revision : $LastChangedRevision: 1308 $ -->
diff --git a/net-mgmt/nagiosql/pkg-plist b/net-mgmt/nagiosql/pkg-plist
index 6d5e51646738..432eeb3efa03 100644
--- a/net-mgmt/nagiosql/pkg-plist
+++ b/net-mgmt/nagiosql/pkg-plist
@@ -5,12 +5,14 @@
%%WWWDIR%%/admin/checkcommands.php
%%WWWDIR%%/admin/commandline.php
%%WWWDIR%%/admin/commands.php
+%%WWWDIR%%/admin/configtargets.php
%%WWWDIR%%/admin/contactgroups.php
%%WWWDIR%%/admin/contacts.php
+%%WWWDIR%%/admin/contacts.php.orig
%%WWWDIR%%/admin/contacttemplates.php
+%%WWWDIR%%/admin/datadomain.php
%%WWWDIR%%/admin/delbackup.php
%%WWWDIR%%/admin/delconfig.php
-%%WWWDIR%%/admin/domain.php
%%WWWDIR%%/admin/download.php
%%WWWDIR%%/admin/group.php
%%WWWDIR%%/admin/groupusers.php
@@ -20,6 +22,7 @@
%%WWWDIR%%/admin/hostextinfo.php
%%WWWDIR%%/admin/hostgroups.php
%%WWWDIR%%/admin/hosts.php
+%%WWWDIR%%/admin/hosts.php.orig
%%WWWDIR%%/admin/hosttemplates.php
%%WWWDIR%%/admin/import.php
%%WWWDIR%%/admin/index.html
@@ -35,16 +38,21 @@
%%WWWDIR%%/admin/serviceextinfo.php
%%WWWDIR%%/admin/servicegroups.php
%%WWWDIR%%/admin/services.php
+%%WWWDIR%%/admin/services.php.orig
%%WWWDIR%%/admin/servicetemplates.php
%%WWWDIR%%/admin/settings.php
%%WWWDIR%%/admin/specials.php
+%%WWWDIR%%/admin/support.php
%%WWWDIR%%/admin/templatedefinitions.php
+%%WWWDIR%%/admin/templatedefinitions.php.orig
%%WWWDIR%%/admin/timedefinitions.php
%%WWWDIR%%/admin/timeperiods.php
%%WWWDIR%%/admin/tools.php
%%WWWDIR%%/admin/user.php
%%WWWDIR%%/admin/variabledefinitions.php
%%WWWDIR%%/admin/verify.php
+%%WWWDIR%%/admin/versioncheck.php
+%%WWWDIR%%/config/content.css
%%WWWDIR%%/config/fieldvars.php
%%WWWDIR%%/config/locale/da_DK/LC_MESSAGES/da_DK.mo
%%WWWDIR%%/config/locale/da_DK/LC_MESSAGES/da_DK.po
@@ -58,10 +66,6 @@
%%WWWDIR%%/config/locale/en_GB/LC_MESSAGES/en_GB.po
%%WWWDIR%%/config/locale/en_GB/LC_MESSAGES/index.html
%%WWWDIR%%/config/locale/en_GB/index.html
-%%WWWDIR%%/config/locale/es_AR/LC_MESSAGES/es_AR.mo
-%%WWWDIR%%/config/locale/es_AR/LC_MESSAGES/es_AR.po
-%%WWWDIR%%/config/locale/es_AR/LC_MESSAGES/index.html
-%%WWWDIR%%/config/locale/es_AR/index.html
%%WWWDIR%%/config/locale/es_ES/LC_MESSAGES/es_ES.mo
%%WWWDIR%%/config/locale/es_ES/LC_MESSAGES/es_ES.po
%%WWWDIR%%/config/locale/es_ES/LC_MESSAGES/index.html
@@ -74,18 +78,10 @@
%%WWWDIR%%/config/locale/it_IT/LC_MESSAGES/it_IT.mo
%%WWWDIR%%/config/locale/it_IT/LC_MESSAGES/it_IT.po
%%WWWDIR%%/config/locale/it_IT/index.html
-%%WWWDIR%%/config/locale/ja_JP/LC_MESSAGES/index.html
-%%WWWDIR%%/config/locale/ja_JP/LC_MESSAGES/ja_JP.mo
-%%WWWDIR%%/config/locale/ja_JP/LC_MESSAGES/ja_JP.po
-%%WWWDIR%%/config/locale/ja_JP/index.html
%%WWWDIR%%/config/locale/nl_NL/LC_MESSAGES/index.html
%%WWWDIR%%/config/locale/nl_NL/LC_MESSAGES/nl_NL.mo
%%WWWDIR%%/config/locale/nl_NL/LC_MESSAGES/nl_NL.po
%%WWWDIR%%/config/locale/nl_NL/index.html
-%%WWWDIR%%/config/locale/pl_PL/LC_MESSAGES/index.html
-%%WWWDIR%%/config/locale/pl_PL/LC_MESSAGES/pl_PL.mo
-%%WWWDIR%%/config/locale/pl_PL/LC_MESSAGES/pl_PL.po
-%%WWWDIR%%/config/locale/pl_PL/index.html
%%WWWDIR%%/config/locale/pt_BR/LC_MESSAGES/index.html
%%WWWDIR%%/config/locale/pt_BR/LC_MESSAGES/pt_BR.mo
%%WWWDIR%%/config/locale/pt_BR/LC_MESSAGES/pt_BR.po
@@ -99,14 +95,26 @@
%%WWWDIR%%/config/locale/zh_CN/LC_MESSAGES/zh_CN.po
%%WWWDIR%%/config/locale/zh_CN/index.html
%%WWWDIR%%/config/main.css
+%%WWWDIR%%/doc/CHANGELOG
+%%WWWDIR%%/doc/INSTALLATION_deDE.txt
+%%WWWDIR%%/doc/INSTALLATION_enGB.txt
+%%WWWDIR%%/doc/LICENSE
+%%WWWDIR%%/doc/LIZENZ
+%%WWWDIR%%/doc/README_SSH_KEY
%%WWWDIR%%/favicon.ico
%%WWWDIR%%/functions/common.js
%%WWWDIR%%/functions/config_class.php
+%%WWWDIR%%/functions/config_class.php.orig
+%%WWWDIR%%/functions/content_class.php
%%WWWDIR%%/functions/data_class.php
%%WWWDIR%%/functions/import_class.php
+%%WWWDIR%%/functions/import_class.php.orig
%%WWWDIR%%/functions/mysql_class.php
%%WWWDIR%%/functions/nag_class.php
%%WWWDIR%%/functions/prepend_adm.php
+%%WWWDIR%%/functions/prepend_adm.php.orig
+%%WWWDIR%%/functions/prepend_content.php
+%%WWWDIR%%/functions/prepend_content.php.orig
%%WWWDIR%%/functions/prepend_scripting.php
%%WWWDIR%%/functions/tinyMCE/jscripts/tiny_mce/langs/en.js
%%WWWDIR%%/functions/tinyMCE/jscripts/tiny_mce/license.txt
@@ -208,13 +216,21 @@
%%WWWDIR%%/functions/yui/build/container/assets/tip16_1.gif
%%WWWDIR%%/functions/yui/build/container/assets/warn16_1.gif
%%WWWDIR%%/functions/yui/build/container/container-min.js
+%%WWWDIR%%/functions/yui/build/datasource/datasource-min.js
+%%WWWDIR%%/functions/yui/build/datatable/assets/skins/sam/datatable.css
+%%WWWDIR%%/functions/yui/build/datatable/assets/skins/sam/dt-arrow-dn.png
+%%WWWDIR%%/functions/yui/build/datatable/assets/skins/sam/dt-arrow-up.png
+%%WWWDIR%%/functions/yui/build/datatable/datatable-min.js
%%WWWDIR%%/functions/yui/build/element/element-min.js
+%%WWWDIR%%/functions/yui/build/event-delegate/event-delegate-min.js
%%WWWDIR%%/functions/yui/build/fonts/fonts-min.css
+%%WWWDIR%%/functions/yui/build/json/json-min.js
+%%WWWDIR%%/functions/yui/build/paginator/assets/skins/sam/paginator.css
+%%WWWDIR%%/functions/yui/build/paginator/paginator-min.js
%%WWWDIR%%/functions/yui/build/tabview/assets/skins/sam/tabview.css
%%WWWDIR%%/functions/yui/build/tabview/tabview-min.js
%%WWWDIR%%/functions/yui/build/utilities/utilities.js
%%WWWDIR%%/functions/yui/build/yahoo-dom-event/yahoo-dom-event.js
-%%WWWDIR%%/images/admin.png
%%WWWDIR%%/images/bg_menu_aktiv.png
%%WWWDIR%%/images/bg_menu_inaktiv.png
%%WWWDIR%%/images/bg_submenu.png
@@ -223,67 +239,51 @@
%%WWWDIR%%/images/copy.gif
%%WWWDIR%%/images/del.png
%%WWWDIR%%/images/delete.gif
+%%WWWDIR%%/images/donate.png
+%%WWWDIR%%/images/donate_2.png
%%WWWDIR%%/images/down.gif
%%WWWDIR%%/images/download.gif
%%WWWDIR%%/images/edit.gif
%%WWWDIR%%/images/exclude_01.gif
-%%WWWDIR%%/images/exclude_02.gif
-%%WWWDIR%%/images/exclude_03.gif
%%WWWDIR%%/images/info.gif
%%WWWDIR%%/images/input.png
%%WWWDIR%%/images/inputlock.png
%%WWWDIR%%/images/inputmust.png
-%%WWWDIR%%/images/left.gif
-%%WWWDIR%%/images/login-form.png
-%%WWWDIR%%/images/logo_top.png
+%%WWWDIR%%/images/loader.gif
%%WWWDIR%%/images/lupe.gif
%%WWWDIR%%/images/menu.gif
-%%WWWDIR%%/images/menu_bg.png
-%%WWWDIR%%/images/menu_bg2.png
-%%WWWDIR%%/images/menusub_bg.png
%%WWWDIR%%/images/mut.gif
%%WWWDIR%%/images/nagiosql_logo.png
%%WWWDIR%%/images/pfeil_l.gif
%%WWWDIR%%/images/pfeil_r.gif
-%%WWWDIR%%/images/pfeil_r_red.gif
%%WWWDIR%%/images/pixel.gif
-%%WWWDIR%%/images/right.gif
+%%WWWDIR%%/images/sort_asc.png
+%%WWWDIR%%/images/sort_desc.png
%%WWWDIR%%/images/tip.gif
-%%WWWDIR%%/images/tip.png
%%WWWDIR%%/images/up.gif
-%%WWWDIR%%/images/upArrow.png
%%WWWDIR%%/images/write.gif
%%WWWDIR%%/index.php
-%%WWWDIR%%/install/css/cmxform.css
-%%WWWDIR%%/install/css/core.css
-%%WWWDIR%%/install/css/index.html
%%WWWDIR%%/install/css/install.css
-%%WWWDIR%%/install/css/reset.css
-%%WWWDIR%%/install/css/screen.css
-%%WWWDIR%%/install/doc/INSTALLATION_deDE.txt
-%%WWWDIR%%/install/doc/INSTALLATION_enGB.txt
-%%WWWDIR%%/install/doc/README_SSH_KEY
-%%WWWDIR%%/install/functions/func_installer.php
-%%WWWDIR%%/install/functions/index.html
+%%WWWDIR%%/install/functions/initial_settings.php
+%%WWWDIR%%/install/functions/install_class.php
+%%WWWDIR%%/install/functions/prepend_install.php
%%WWWDIR%%/install/images/background.png
%%WWWDIR%%/install/images/body_background.png
-%%WWWDIR%%/install/images/cmxform-divider.gif
-%%WWWDIR%%/install/images/cmxform-fieldset.gif
%%WWWDIR%%/install/images/favicon.ico
%%WWWDIR%%/install/images/index-install.png
%%WWWDIR%%/install/images/index-update.png
%%WWWDIR%%/install/images/index.html
+%%WWWDIR%%/install/images/input.png
+%%WWWDIR%%/install/images/inputlock.png
+%%WWWDIR%%/install/images/inputmust.png
%%WWWDIR%%/install/images/install.png
%%WWWDIR%%/install/images/invalid.png
-%%WWWDIR%%/install/images/minus.png
%%WWWDIR%%/install/images/nagiosql.png
%%WWWDIR%%/install/images/next.png
%%WWWDIR%%/install/images/onlinehelp.png
%%WWWDIR%%/install/images/pixel.gif
-%%WWWDIR%%/install/images/plus.png
%%WWWDIR%%/install/images/previous.png
%%WWWDIR%%/install/images/reload.png
-%%WWWDIR%%/install/images/skip.png
%%WWWDIR%%/install/images/step1_active.png
%%WWWDIR%%/install/images/step1_deactive.png
%%WWWDIR%%/install/images/step2_active.png
@@ -296,47 +296,41 @@
%%WWWDIR%%/install/images/warning.png
%%WWWDIR%%/install/index.php
%%WWWDIR%%/install/install.php
-%%WWWDIR%%/install/js/cmxform.js
-%%WWWDIR%%/install/js/index.html
-%%WWWDIR%%/install/js/jquery.js
-%%WWWDIR%%/install/js/prototype.js
-%%WWWDIR%%/install/js/validation.js
-%%WWWDIR%%/install/js/yh_tooltip.js
%%WWWDIR%%/install/sql/import_nagios_sample.sql
-%%WWWDIR%%/install/sql/index.html
-%%WWWDIR%%/install/sql/nagiosQL_v31_db_mysql.sql
-%%WWWDIR%%/install/sql/update_200_202.sql
-%%WWWDIR%%/install/sql/update_202_302.sql
+%%WWWDIR%%/install/sql/nagiosQL_v32_db_mysql.sql
%%WWWDIR%%/install/sql/update_300_301.sql
-%%WWWDIR%%/install/sql/update_300b1_300b2.sql
-%%WWWDIR%%/install/sql/update_300b2_300rc1.sql
-%%WWWDIR%%/install/sql/update_300rc1_300.sql
+%%WWWDIR%%/install/sql/update_300_310.sql
%%WWWDIR%%/install/sql/update_301_302.sql
%%WWWDIR%%/install/sql/update_302_303.sql
%%WWWDIR%%/install/sql/update_303_304.sql
%%WWWDIR%%/install/sql/update_304_310.sql
-%%WWWDIR%%/install/sql/update_304_310b1.sql
%%WWWDIR%%/install/sql/update_310_311.sql
-%%WWWDIR%%/install/sql/update_310b1_310b2.sql
-%%WWWDIR%%/install/sql/update_310b2_310b3.sql
-%%WWWDIR%%/install/sql/update_310b3_310rc1.sql
-%%WWWDIR%%/install/sql/update_310rc1_310.sql
-%%WWWDIR%%/install/status.php
+%%WWWDIR%%/install/sql/update_310_320.sql
+%%WWWDIR%%/install/sql/update_311_320.sql
%%WWWDIR%%/install/step1.php
%%WWWDIR%%/install/step2.php
%%WWWDIR%%/install/step3.php
+%%WWWDIR%%/install/templates/index.tpl.htm
+%%WWWDIR%%/install/templates/install.tpl.htm
+%%WWWDIR%%/install/templates/step1.tpl.htm
+%%WWWDIR%%/install/templates/step2.tpl.htm
+%%WWWDIR%%/install/templates/step3.tpl.htm
%%WWWDIR%%/libraries/pear/HTML/Template/IT.php
%%WWWDIR%%/libraries/pear/HTML/Template/ITX.php
%%WWWDIR%%/libraries/pear/HTML/Template/IT_Error.php
+%%WWWDIR%%/libraries/pear/JSON/JSON.php
+%%WWWDIR%%/libraries/pear/JSON/index.html
%%WWWDIR%%/libraries/pear/PEAR.php
%%WWWDIR%%/libraries/pear/PEAR5.php
%%WWWDIR%%/libraries/pear/index.html
%%WWWDIR%%/scripts/do_config.php
%%WWWDIR%%/templates/admin/admin_master.tpl.htm
%%WWWDIR%%/templates/admin/checkcommands.tpl.htm
+%%WWWDIR%%/templates/admin/configtargets.tpl.htm
%%WWWDIR%%/templates/admin/contactgroups.tpl.htm
%%WWWDIR%%/templates/admin/contacts.tpl.htm
%%WWWDIR%%/templates/admin/contacttemplates.tpl.htm
+%%WWWDIR%%/templates/admin/datadomain.tpl.htm
%%WWWDIR%%/templates/admin/delbackup.tpl.htm
%%WWWDIR%%/templates/admin/domain.tpl.htm
%%WWWDIR%%/templates/admin/group.tpl.htm
@@ -358,8 +352,10 @@
%%WWWDIR%%/templates/admin/services.tpl.htm
%%WWWDIR%%/templates/admin/servicetemplates.tpl.htm
%%WWWDIR%%/templates/admin/settings.tpl.htm
+%%WWWDIR%%/templates/admin/support.tpl.htm
%%WWWDIR%%/templates/admin/timeperiods.tpl.htm
%%WWWDIR%%/templates/admin/user.tpl.htm
+%%WWWDIR%%/templates/admin/user.tpl.htm.orig
%%WWWDIR%%/templates/admin/verify.tpl.htm
%%WWWDIR%%/templates/files/commands.tpl.dat
%%WWWDIR%%/templates/files/contactgroups.tpl.dat
@@ -384,15 +380,15 @@
@dirrm %%WWWDIR%%/templates/admin
@dirrm %%WWWDIR%%/templates
@dirrm %%WWWDIR%%/scripts
+@dirrm %%WWWDIR%%/libraries/pear/JSON
@dirrm %%WWWDIR%%/libraries/pear/HTML/Template
@dirrm %%WWWDIR%%/libraries/pear/HTML
@dirrm %%WWWDIR%%/libraries/pear
@dirrm %%WWWDIR%%/libraries
+@dirrm %%WWWDIR%%/install/templates
@dirrm %%WWWDIR%%/install/sql
-@dirrm %%WWWDIR%%/install/js
@dirrm %%WWWDIR%%/install/images
@dirrm %%WWWDIR%%/install/functions
-@dirrm %%WWWDIR%%/install/doc
@dirrm %%WWWDIR%%/install/css
@dirrm %%WWWDIR%%/install
@dirrm %%WWWDIR%%/images
@@ -402,8 +398,19 @@
@dirrm %%WWWDIR%%/functions/yui/build/tabview/assets/skins
@dirrm %%WWWDIR%%/functions/yui/build/tabview/assets
@dirrm %%WWWDIR%%/functions/yui/build/tabview
+@dirrm %%WWWDIR%%/functions/yui/build/paginator/assets/skins/sam
+@dirrm %%WWWDIR%%/functions/yui/build/paginator/assets/skins
+@dirrm %%WWWDIR%%/functions/yui/build/paginator/assets
+@dirrm %%WWWDIR%%/functions/yui/build/paginator
+@dirrm %%WWWDIR%%/functions/yui/build/json
@dirrm %%WWWDIR%%/functions/yui/build/fonts
+@dirrm %%WWWDIR%%/functions/yui/build/event-delegate
@dirrm %%WWWDIR%%/functions/yui/build/element
+@dirrm %%WWWDIR%%/functions/yui/build/datatable/assets/skins/sam
+@dirrm %%WWWDIR%%/functions/yui/build/datatable/assets/skins
+@dirrm %%WWWDIR%%/functions/yui/build/datatable/assets
+@dirrm %%WWWDIR%%/functions/yui/build/datatable
+@dirrm %%WWWDIR%%/functions/yui/build/datasource
@dirrm %%WWWDIR%%/functions/yui/build/container/assets/skins/sam
@dirrm %%WWWDIR%%/functions/yui/build/container/assets/skins
@dirrm %%WWWDIR%%/functions/yui/build/container/assets
@@ -449,26 +456,21 @@
@dirrm %%WWWDIR%%/functions/tinyMCE/jscripts
@dirrm %%WWWDIR%%/functions/tinyMCE
@dirrm %%WWWDIR%%/functions
+@dirrm %%WWWDIR%%/doc
@dirrm %%WWWDIR%%/config/locale/zh_CN/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/zh_CN
@dirrm %%WWWDIR%%/config/locale/ru_RU/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/ru_RU
@dirrm %%WWWDIR%%/config/locale/pt_BR/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/pt_BR
-@dirrm %%WWWDIR%%/config/locale/pl_PL/LC_MESSAGES
-@dirrm %%WWWDIR%%/config/locale/pl_PL
@dirrm %%WWWDIR%%/config/locale/nl_NL/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/nl_NL
-@dirrm %%WWWDIR%%/config/locale/ja_JP/LC_MESSAGES
-@dirrm %%WWWDIR%%/config/locale/ja_JP
@dirrm %%WWWDIR%%/config/locale/it_IT/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/it_IT
@dirrm %%WWWDIR%%/config/locale/fr_FR/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/fr_FR
@dirrm %%WWWDIR%%/config/locale/es_ES/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/es_ES
-@dirrm %%WWWDIR%%/config/locale/es_AR/LC_MESSAGES
-@dirrm %%WWWDIR%%/config/locale/es_AR
@dirrm %%WWWDIR%%/config/locale/en_GB/LC_MESSAGES
@dirrm %%WWWDIR%%/config/locale/en_GB
@dirrm %%WWWDIR%%/config/locale/de_DE/LC_MESSAGES