aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nbtscan
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-29 16:05:00 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-04-29 16:05:00 +0000
commit06fe441889e3c36d25a6afa09601d17e7fedf82a (patch)
treec006fe640d7fcb7d139465c06fed0167148ab06e /net-mgmt/nbtscan
parentfcb76845288b36c172354c682a7ffb64b8f7a327 (diff)
downloadports-06fe441889e3c36d25a6afa09601d17e7fedf82a.tar.gz
ports-06fe441889e3c36d25a6afa09601d17e7fedf82a.zip
- Fix segfault on 64 bit systems
- Bump PORTREVISION - Reassign to ports@ Submitted by: Samu Nuutamo
Notes
Notes: svn path=/head/; revision=253428
Diffstat (limited to 'net-mgmt/nbtscan')
-rw-r--r--net-mgmt/nbtscan/Makefile3
-rw-r--r--net-mgmt/nbtscan/files/patch-statusq.h11
2 files changed, 13 insertions, 1 deletions
diff --git a/net-mgmt/nbtscan/Makefile b/net-mgmt/nbtscan/Makefile
index 4b8b961aa1d9..53fae8c6d6f2 100644
--- a/net-mgmt/nbtscan/Makefile
+++ b/net-mgmt/nbtscan/Makefile
@@ -7,12 +7,13 @@
PORTNAME= nbtscan
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.inetcat.net/software/ \
${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
-MAINTAINER= tabthorpe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= NetBIOS name network scanner
MAKE_JOBS_SAFE= yes
diff --git a/net-mgmt/nbtscan/files/patch-statusq.h b/net-mgmt/nbtscan/files/patch-statusq.h
new file mode 100644
index 000000000000..8587d04368db
--- /dev/null
+++ b/net-mgmt/nbtscan/files/patch-statusq.h
@@ -0,0 +1,11 @@
+--- statusq.h.orig 2010-04-26 16:39:16.000000000 +0300
++++ statusq.h 2010-04-26 16:39:28.000000000 +0300
+@@ -22,6 +22,8 @@
+
+ #define NB_DGRAM 137
+
++struct nb_host_info* parse_response(char*, int);
++
+ struct nbname {
+ char ascii_name [16] ;
+ my_uint16_t rr_flags;