aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ndpmon
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-22 01:19:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-22 01:19:35 +0000
commit9679497bb3053e21d24b9a1130562689d9b2cd90 (patch)
tree6eda8446cf3fb7bf93fad90afe6af96517fd3510 /net-mgmt/ndpmon
parent3f5a1f3ea6054a58ca64be2c2f6207de79086e7a (diff)
downloadports-9679497bb3053e21d24b9a1130562689d9b2cd90.tar.gz
ports-9679497bb3053e21d24b9a1130562689d9b2cd90.zip
- Update to 1.1b
PR: ports/110606 Submitted by: maintainer (Janos Mohacsi)
Notes
Notes: svn path=/head/; revision=187958
Diffstat (limited to 'net-mgmt/ndpmon')
-rw-r--r--net-mgmt/ndpmon/Makefile10
-rw-r--r--net-mgmt/ndpmon/distinfo6
-rw-r--r--net-mgmt/ndpmon/files/patch-config__ndpmon.xml15
-rw-r--r--net-mgmt/ndpmon/files/patch-demopipeprogram.pl21
-rw-r--r--net-mgmt/ndpmon/pkg-plist1
5 files changed, 47 insertions, 6 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index 844843701d4a..a917d7328694 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= ndpmon
-PORTVERSION= 1.0
+PORTVERSION= 1.1b
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${PORTNAME}-${PORTVERSION}b.tgz
+EXTRACT_SUFX= .tgz
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= On-link icmpv6 message monitoring and reporting daemon
USE_GNOME= libxml2
+USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
@@ -27,7 +28,8 @@ post-patch:
${WRKSRC}/ndpmon.c \
${WRKSRC}/ndpmon.8 \
${WRKSRC}/config_ndpmon.xml \
- ${WRKSRC}/neighbor_list.xml
+ ${WRKSRC}/neighbor_list.xml \
+ ${WRKSRC}/demopipeprogram.pl
do-install:
${INSTALL_MAN} ${WRKSRC}/ndpmon.8 ${PREFIX}/man/man8
@@ -35,6 +37,8 @@ do-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dtd \
${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/demopipeprogram.pl \
+ ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${PREFIX}/etc/config_ndpmon.xml-dist
${MKDIR} ${PREFIX}/var
${INSTALL_DATA} ${WRKSRC}/neighbor_list.xml ${PREFIX}/var/ndpmon_neighbor_list.xml
diff --git a/net-mgmt/ndpmon/distinfo b/net-mgmt/ndpmon/distinfo
index 96c1742d593b..e02ba21303ba 100644
--- a/net-mgmt/ndpmon/distinfo
+++ b/net-mgmt/ndpmon/distinfo
@@ -1,3 +1,3 @@
-MD5 (ndpmon-1.0b.tgz) = 80c2076de3399fde5fd9959d487538c1
-SHA256 (ndpmon-1.0b.tgz) = c8e26f1bdf69a9609b482afe05dacbab5c129fc80964b0fdf1e272948f098651
-SIZE (ndpmon-1.0b.tgz) = 49818
+MD5 (ndpmon-1.1b.tgz) = d7d4b3397938d6a716ed6bfae4cc1e06
+SHA256 (ndpmon-1.1b.tgz) = a01b9511defbedebef05a2c614a05ba05e8bd83461e5e239af72607a62ca95b2
+SIZE (ndpmon-1.1b.tgz) = 281973
diff --git a/net-mgmt/ndpmon/files/patch-config__ndpmon.xml b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
index 309091198579..01dd6af5cf42 100644
--- a/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
+++ b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
@@ -10,3 +10,18 @@ $FreeBSD$
<config_ndpmon>
<ignor_autoconf>1</ignor_autoconf>
<syslog_facility>LOG_LOCAL1</syslog_facility>
+@@ -7,12 +7,12 @@
+ <actions_low_pri>
+ <sendmail>1</sendmail>
+ <syslog>1</syslog>
+- <exec_pipe_program>/usr/local/ndpmon/demopipeprogram.pl</exec_pipe_program>
++ <exec_pipe_program>%%PREFIX%%/share/ndpmon/demopipeprogram.pl</exec_pipe_program>
+ </actions_low_pri>
+ <actions_high_pri>
+ <sendmail>1</sendmail>
+ <syslog>1</syslog>
+- <exec_pipe_program>/usr/local/ndpmon/demopipeprogram.pl</exec_pipe_program>
++ <exec_pipe_program>%%PREFIX%%/share/ndpmon/demopipeprogram.pl</exec_pipe_program>
+ </actions_high_pri>
+ <use_reverse_hostlookups>1</use_reverse_hostlookups>
+ <routers>
diff --git a/net-mgmt/ndpmon/files/patch-demopipeprogram.pl b/net-mgmt/ndpmon/files/patch-demopipeprogram.pl
new file mode 100644
index 000000000000..1923b678ad66
--- /dev/null
+++ b/net-mgmt/ndpmon/files/patch-demopipeprogram.pl
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- demopipeprogram.pl.orig
++++ demopipeprogram.pl
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl
+
+ my $i=0;
+-open DATA, ">>/usr/local/ndpmon/test.txt" or die "Cannot open /usr/local/ndpmon/test.txt for writing\n";
++open DATA, ">>%%PREFIX%%/var/ndpmon_test.txt" or die "Cannot open %%PREFIX%%/var/ndpmon_test.txt for writing\n";
+
+ print DATA "-----\n";
+ while (<STDIN>) {
+@@ -14,4 +14,4 @@
+ }
+ print DATA "-----\n\n";
+
+-close DATA;
+\ No newline at end of file
++close DATA;
diff --git a/net-mgmt/ndpmon/pkg-plist b/net-mgmt/ndpmon/pkg-plist
index 4a30b020ed43..96287a742ae6 100644
--- a/net-mgmt/ndpmon/pkg-plist
+++ b/net-mgmt/ndpmon/pkg-plist
@@ -1,6 +1,7 @@
sbin/ndpmon
%%DATADIR%%/config_ndpmon.dtd
%%DATADIR%%/neighbor_list.dtd
+%%DATADIR%%/demopipeprogram.pl
@dirrmtry %%DATADIR%%
var/ndpmon_neighbor_list.xml
@dirrmtry var