aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp-devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-12-25 22:44:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-12-25 22:44:09 +0000
commitdb95497bd3fa39663a38cf541cff23b781a82aba (patch)
tree65d1d764ab66a9cedf3a6c1fa1542977e33612d6 /net-mgmt/net-snmp-devel
parent25df1516520a0bee6fb279a4ca91147b4c02de7d (diff)
downloadports-db95497bd3fa39663a38cf541cff23b781a82aba.tar.gz
ports-db95497bd3fa39663a38cf541cff23b781a82aba.zip
Notes
Diffstat (limited to 'net-mgmt/net-snmp-devel')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile1
-rw-r--r--net-mgmt/net-snmp-devel/files/patch-file.c24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index 17ef31072401..0afbfb88bb87 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= net-snmp
PORTVERSION= 5.1
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp-devel/files/patch-file.c b/net-mgmt/net-snmp-devel/files/patch-file.c
new file mode 100644
index 000000000000..94eab370a857
--- /dev/null
+++ b/net-mgmt/net-snmp-devel/files/patch-file.c
@@ -0,0 +1,24 @@
+--- agent/mibgroup/ucd-snmp/file.c.orig Thu Dec 25 23:57:14 2003
++++ agent/mibgroup/ucd-snmp/file.c Thu Dec 25 23:57:37 2003
+@@ -91,17 +91,19 @@
+ file_parse_config(const char *token, char *cptr)
+ {
+ char space;
++ int items;
+
+ if (fileCount < MAXFILE) {
+ fileTable[fileCount].max = -1;
+
+- sscanf(cptr, "%255s%c%d",
++ memset(fileTable[fileCount].name, 0, sizeof(fileTable[0].name));
++ items = sscanf(cptr, "%255s%c%d",
+ fileTable[fileCount].name, &space, &fileTable[fileCount].max);
+ /*
+ * Log an error then return if the string scanned in was larger then
+ * it should have been.
+ */
+- if (space != ' ') {
++ if (items != 1 && space != ' ') {
+ snmp_log(LOG_ERR, "file_parse_config: file name scanned " \
+ "in from line %s is too large. fileCount = %d\n", cptr,
+ fileCount);