aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2016-05-31 13:45:31 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2016-05-31 13:45:31 +0000
commit1e1420d07e081b066c7937b59baf61c450891d25 (patch)
tree1976bafaa52fe7044abddf57a22f221f0dd96e6c /net-mgmt/net-snmp
parent96edd35c357ceb39b820e6ea6549b3e44177f97d (diff)
downloadports-1e1420d07e081b066c7937b59baf61c450891d25.tar.gz
ports-1e1420d07e081b066c7937b59baf61c450891d25.zip
- Add OPTION to pass --disable-snmptrapd-subagent to configure
PR: 209885 Submitted by: emz@norma.perm.ru
Notes
Notes: svn path=/head/; revision=416198
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 64ad04b78fa4..e8070f9af1d4 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -16,7 +16,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= IPV6 MFD_REWRITES PERL PERL_EMBEDDED PYTHON DUMMY TKMIB \
- MYSQL AX_SOCKONLY UNPRIVILEGED SMUX DOCS JAIL
+ MYSQL AX_SOCKONLY UNPRIVILEGED SMUX DOCS JAIL AX_DISABLE_TRAP
OPTIONS_DEFAULT=PERL PERL_EMBEDDED DUMMY SMUX
MFD_REWRITES_DESC= Build with 64-bit Interface Counters
@@ -25,6 +25,7 @@ DUMMY_DESC= Enable dummy values as placeholders
TKMIB_DESC= Install graphical MIB browser
#DMALLOC_DESC= Enable dmalloc debug memory allocator
AX_SOCKONLY_DESC= Disable UDP/TCP transports for agentx
+AX_DISABLE_TRAP_DESC= Disable agentx subagent code in snmptrapd
UNPRIVILEGED_DESC= Allow unprivileged users to execute net-snmp
SMUX_DESC= Build with SNMP multiplexing (SMUX) support
JAIL_DESC= Options for running snmpd within a jail(8)
@@ -124,6 +125,10 @@ CONFIGURE_ARGS+=--with-mysql
CONFIGURE_ENV+= MYSQLCONFIG=${LOCALBASE}/bin/mysql_config
.endif
+.if ${PORT_OPTIONS:MAX_DISABLE_TRAP}
+CONFIGURE_ARGS+=--disable-snmptrapd-subagent
+.endif
+
.if ${PORT_OPTIONS:MAX_SOCKONLY}
CONFIGURE_ARGS+=--enable-agentx-dom-sock-only
.endif