aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2020-11-15 16:27:33 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2020-11-15 16:27:33 +0000
commit763e985f229e0953ba809557f4fb85e0a1427561 (patch)
tree34b53af7d25d103186d3cfa9d7dc4ab80c5bc92c /net-mgmt/net-snmp
parente921b0c378945f59259c0b8a6db9d02d0382c42e (diff)
downloadports-763e985f229e0953ba809557f4fb85e0a1427561.tar.gz
ports-763e985f229e0953ba809557f4fb85e0a1427561.zip
- Add memory calculation fix
- Bump PORTREVISION PR: 251103 Submitted by: ncrogers@gmail.com
Notes
Notes: svn path=/head/; revision=555237
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile1
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 058ebbb659a7..7fd0c1d2f357 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.9
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION} \
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c
new file mode 100644
index 000000000000..e5204974a550
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c
@@ -0,0 +1,11 @@
+--- agent/mibgroup/hardware/memory/memory_freebsd.c.orig 2015-02-20 14:44:47 UTC
++++ agent/mibgroup/hardware/memory/memory_freebsd.c
+@@ -163,7 +163,7 @@ int netsnmp_mem_arch_load( netsnmp_cache
+ if (!mem->descr)
+ mem->descr = strdup("Cached memory");
+ mem->units = pagesize;
+- mem->size = cache_count;
++ mem->size = cache_count + inact_count;
+ mem->free = 0;
+ }
+