aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netdisco
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-09-04 23:21:31 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-09-04 23:21:31 +0000
commitb591c44e6cc0f97590f6af0e6c61bd275192233d (patch)
tree4b673d8f8e91cf102c72a26b1dfcf80f032f8287 /net-mgmt/netdisco
parenta0f392a8239fae8eadb3b6f56a6c3c122099cc8c (diff)
downloadports-b591c44e6cc0f97590f6af0e6c61bd275192233d.tar.gz
ports-b591c44e6cc0f97590f6af0e6c61bd275192233d.zip
- Convert to new options framework [1]
- Fix build with new bsd.apache.mk by changing to USE_APACHE_RUN, since this port has NO_BUILD PR: ports/171284 [1] Submitted by: Geoffroy Desvernay <dgeo@centrale-marseille.fr> (maintainer) Approved by: eadler (mentor)
Notes
Notes: svn path=/head/; revision=303680
Diffstat (limited to 'net-mgmt/netdisco')
-rw-r--r--net-mgmt/netdisco/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-mgmt/netdisco/Makefile b/net-mgmt/netdisco/Makefile
index 18e0e260f84a..c0d7d113dadc 100644
--- a/net-mgmt/netdisco/Makefile
+++ b/net-mgmt/netdisco/Makefile
@@ -13,9 +13,11 @@ MASTER_SITES= SF
MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= Web-based network management tool for moderate to large networks
-OPTIONS= GRAPHVIZ "Install GraphViz for network map support" on \
- OUIDL "Download oui.txt file" off \
- MIBS "depend on net-mgmt/netdisco-mibs" on
+OPTIONS_DEFINE= GRAPHVIZ OUIDL MIBS
+OPTIONS_DEFAULT=GRAPHVIZ MIBS
+MIBS_DESC= Depend on net-mgmt/netdisco-mibs
+OUIDL_DESC= Download oui.txt file
+GRAPHVIZ_DESC= Install GraphViz for network map support
RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
p5-Apache-DBI>=0:${PORTSDIR}/www/p5-Apache-DBI \
@@ -36,7 +38,7 @@ GROUPS= netdisco
USE_PERL5= yes
USE_PGSQL= yes
-USE_APACHE= 22+
+USE_APACHE_RUN= 22+
USE_RC_SUBR= netdisco
@@ -62,7 +64,7 @@ DOCS= doc/*.pod doc/*.html INSTALL README* UPGRADE
.include <bsd.port.pre.mk>
MIBSDIR= ${PREFIX}/share/netdisco-mibs
-.if defined(WITH_MIBS)
+.if ${PORT_OPTIONS:MMIBS}
RUN_DEPENDS+= ${MIBSDIR}/mib_index.txt:${PORTSDIR}/net-mgmt/netdisco-mibs
BUILD_DEPENDS+= ${MIBSDIR}/mib_index.txt:${PORTSDIR}/net-mgmt/netdisco-mibs
. include "${.CURDIR}/../netdisco-mibs/bsd.port.netdisco.mk"
@@ -83,12 +85,12 @@ RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
-.if defined(WITH_GRAPHVIZ)
+.if ${PORT_OPTIONS:MGRAPHVIZ}
RUN_DEPENDS+= p5-Graph>=0:${PORTSDIR}/math/p5-Graph \
p5-GraphViz>=0:${PORTSDIR}/graphics/p5-GraphViz
.endif
-.if defined(WITH_OUIDL)
+.if ${PORT_OPTIONS:MOUIDL}
PLIST_SUB+= OUIDL=""
.else
PLIST_SUB+= OUIDL="@comment "
@@ -161,7 +163,7 @@ do-install:
fi)
. endif
-. if defined(WITH_OUIDL)
+. if ${PORT_OPTIONS:MOUIDL}
${FETCH_CMD} -q -o ${DATADIR}/oui.txt http://standards.ieee.org/develop/regauth/oui/oui.txt
. endif