aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netdot
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-09 15:43:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-07-09 15:43:41 +0000
commita6decd448c5fb4421d6623524ba0189f107f520e (patch)
treebab0a34fb5a97bd55cf784421c10870cfb9a9663 /net-mgmt/netdot
parent79a10462f1a944b33017fd65bce24846ed3edfa2 (diff)
downloadports-a6decd448c5fb4421d6623524ba0189f107f520e.tar.gz
ports-a6decd448c5fb4421d6623524ba0189f107f520e.zip
- Fix shebang
- Bump PORTREVISION for package change Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=391641
Diffstat (limited to 'net-mgmt/netdot')
-rw-r--r--net-mgmt/netdot/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-mgmt/netdot/Makefile b/net-mgmt/netdot/Makefile
index ed011fb1d3d2..71b750d0c7fb 100644
--- a/net-mgmt/netdot/Makefile
+++ b/net-mgmt/netdot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netdot
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://netdot.uoregon.edu/pub/dists/
@@ -40,7 +41,7 @@ RUN_DEPENDS= p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2 \
rrdtool:${PORTSDIR}/databases/rrdtool \
netdisco-mibs>=0:${PORTSDIR}/net-mgmt/netdisco-mibs
-USES= gmake perl5
+USES= gmake perl5 shebangfix
NO_BUILD= yes
USE_MYSQL= yes
@@ -51,6 +52,11 @@ SUB_LIST= WWWDIR="${WWWDIR}" \
CHOWN="${CHOWN}" \
CHMOD="${CHMOD}"
+SHEBANG_FILES= bin/*.pl bin/initdb upgrade/upgrade-tasks
+SHEBANG_LANG= perl perl2
+perl2_OLD_CMD= <<Make:PERL>>
+perl2_CMD= ${LOCALBASE}/bin/perl
+
.include <bsd.port.pre.mk>
INSTALL_TARGET= install \