aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netmond
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-06-13 12:46:12 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-06-13 12:46:12 +0000
commit011d1b9c93888489a36f84c067b2b14ca8ea0796 (patch)
tree455fba1ae23bead898a4f3345f888b6b544f5520 /net-mgmt/netmond
parent184d140a700bae4d98b57d8c1cbde8ba0797690f (diff)
downloadports-011d1b9c93888489a36f84c067b2b14ca8ea0796.tar.gz
ports-011d1b9c93888489a36f84c067b2b14ca8ea0796.zip
Notes
Diffstat (limited to 'net-mgmt/netmond')
-rw-r--r--net-mgmt/netmond/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/net-mgmt/netmond/Makefile b/net-mgmt/netmond/Makefile
index 5b4fe82f2664..1fce107e5b53 100644
--- a/net-mgmt/netmond/Makefile
+++ b/net-mgmt/netmond/Makefile
@@ -24,14 +24,9 @@ GROUPS= ${USERS}
#MK_IFGRAPH= yes
PATCHDIR= ${WRKDIR}/patches
-.if defined(MK_IFGRAPH)
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
-.else
-CONFIGURE_ARGS= --without-ifgraph
-.endif
-
GNU_CONFIGURE= yes
USES= bison
+CFLAGS+= -Wno-return-type
BINOWN= root
BINGRP= netmon
@@ -39,16 +34,21 @@ BINMODE= 0550
PLIST_FILES= sbin/netmond sbin/netmond_watchdog sbin/netmondctl \
etc/netmond.conf.sample
-.if defined(MK_IFGRAPH)
-PLIST_FILES+= sbin/ifgraph
-.endif
-
USE_RC_SUBR= netmond
-
SUB_FILES+= pkg-message netmond_watchdog netmondctl
-
PORTDOCS= README README.ru CHANGES README.port.eng README.port.ru index.html netmond.css en/ ru/
+OPTIONS_DEFINE= DOCS GD
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGD}
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+PLIST_FILES+= sbin/ifgraph
+.else
+CONFIGURE_ARGS= --without-ifgraph
+.endif
+
post-extract:
${MKDIR} ${PATCHDIR}
${TAR} -zxf ${DISTDIR}/${DISTNAME}.patch${PATCH_VERSION}${EXTRACT_SUFX} -C ${PATCHDIR}
@@ -63,8 +63,8 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/netmondctl ${PREFIX}/sbin/netmondctl
${INSTALL_DATA} ${WRKSRC}/netmon.conf.sample ${PREFIX}/etc/netmond.conf.sample
${CHMOD} u+s ${PREFIX}/sbin/netmond
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
${CHMOD} 755 ${DOCSDIR}
${TAR} -zxf ${DISTDIR}/${DISTNAME}.docs${EXTRACT_SUFX} -C ${DOCSDIR}
.endif