aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netustad
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-10 21:02:02 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-10 21:02:02 +0000
commita4f5d365fff94071d715f5caf9abbfebb047083b (patch)
tree08f58912f9c9122ed2cf4bec3177c20f4f507461 /net-mgmt/netustad
parentd0c73d6b5c7e77de66f58f7def73c56c86f14d80 (diff)
downloadports-a4f5d365fff94071d715f5caf9abbfebb047083b.tar.gz
ports-a4f5d365fff94071d715f5caf9abbfebb047083b.zip
- Update to 0.3.0
PR: ports/75987 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=126079
Diffstat (limited to 'net-mgmt/netustad')
-rw-r--r--net-mgmt/netustad/Makefile39
-rw-r--r--net-mgmt/netustad/distinfo4
-rw-r--r--net-mgmt/netustad/files/netustad.sh2
-rw-r--r--net-mgmt/netustad/files/netustadctl30
-rw-r--r--net-mgmt/netustad/pkg-descr7
-rw-r--r--net-mgmt/netustad/pkg-message16
-rw-r--r--net-mgmt/netustad/pkg-plist80
7 files changed, 96 insertions, 82 deletions
diff --git a/net-mgmt/netustad/Makefile b/net-mgmt/netustad/Makefile
index 7659cd4484c0..9c5433a9f97f 100644
--- a/net-mgmt/netustad/Makefile
+++ b/net-mgmt/netustad/Makefile
@@ -1,42 +1,47 @@
# New ports collection makefile for: netustad
-# Date created: 4 July 2004
+# Date created: 9 January 2005
# Whom: Ozkan KIRIK <ozkan@enderunix.org>
#
# $FreeBSD$
#
PORTNAME= netustad
-PORTVERSION= 0.2b
+PORTVERSION= 0.3.0
CATEGORIES= net-mgmt security
MASTER_SITES= http://www.enderunix.org/netustad/
-DISTNAME= ${PORTNAME}-0.2-BETA
MAINTAINER= ozkan@enderunix.org
COMMENT= A Web based admin tool that manages network services
-MAN8= netustad.8 netustadpasswd.8
-MAN5= netustad.conf.5
+#MAN8= netustad.8 netustadpasswd.8
+#MAN5= netustad.conf.5
USE_RC_SUBR= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+OPTIONS= SSL "Use netUstad with SSL support" on
+
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+= --without-ssl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --without-nls
+.endif
+
+.if defined(NOPORTDOCS)
+#make portlint happy :)
+.endif
+
SED_SCRIPT+= -e '{ s,%%PREFIX%%,${PREFIX},g; }'
post-build:
@${SED} ${SED_SCRIPT} ${FILESDIR}/netustad.sh >${WRKDIR}/netustad.sh
- @${SED} ${SED_SCRIPT} ${FILESDIR}/netustadctl >${WRKDIR}/netustadctl
post-install:
@${CAT} ${PKGMESSAGE} | ${SED} ${SED_SCRIPT}
${INSTALL_SCRIPT} ${WRKDIR}/netustad.sh ${PREFIX}/etc/rc.d/
- ${INSTALL_SCRIPT} ${WRKDIR}/netustadctl ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/FAQ ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/GPL-License ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/THANKS ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/netustad/distinfo b/net-mgmt/netustad/distinfo
index b1cc865badd7..d7e2be4ae50e 100644
--- a/net-mgmt/netustad/distinfo
+++ b/net-mgmt/netustad/distinfo
@@ -1,2 +1,2 @@
-MD5 (netustad-0.2-BETA.tar.gz) = 7d17d20783ab2a9d09df1f7d5daae7f8
-SIZE (netustad-0.2-BETA.tar.gz) = 54906
+MD5 (netustad-0.3.0.tar.gz) = 4f5f0087c10b7571398491fd146faaaf
+SIZE (netustad-0.3.0.tar.gz) = 282356
diff --git a/net-mgmt/netustad/files/netustad.sh b/net-mgmt/netustad/files/netustad.sh
index 7048d90f26f3..6e48bb0b3580 100644
--- a/net-mgmt/netustad/files/netustad.sh
+++ b/net-mgmt/netustad/files/netustad.sh
@@ -17,8 +17,6 @@
unset rcNG
name="netustad"
command=%%PREFIX%%/sbin/netustad
-extra_commands=reload
-reload_cmd="killall -HUP ${name}"
stop_cmd="killall ${name}"
if [ -f /etc/rc.subr ]; then
diff --git a/net-mgmt/netustad/files/netustadctl b/net-mgmt/netustad/files/netustadctl
index bec5fbef4c31..e69de29bb2d1 100644
--- a/net-mgmt/netustad/files/netustadctl
+++ b/net-mgmt/netustad/files/netustadctl
@@ -1,30 +0,0 @@
-#!/bin/csh
-######################################
-# netustadctl: netUstad ConTroLler #
-######################################
-
-set prefix="%%PREFIX%%"
-
-switch ($1)
- case start:
- $prefix/sbin/netustad
- breaksw
- case stop:
- killall netustad
- breaksw
- case reload:
- killall -HUP netustad
- echo ""
- echo "netUstad configuration reloaded"
- echo ""
- breaksw
- case restart:
- killall netustad
- $prefix/sbin/netustad
- breaksw
- default:
- echo ""
- echo "usage: netustadctl start|stop|restart|reload"
- echo ""
- exit 64
-endsw
diff --git a/net-mgmt/netustad/pkg-descr b/net-mgmt/netustad/pkg-descr
index 5389188b3b82..92acbe8600f5 100644
--- a/net-mgmt/netustad/pkg-descr
+++ b/net-mgmt/netustad/pkg-descr
@@ -6,11 +6,10 @@ netUstad.
It has been coded in C language and includes its own HTTP server.
The newly anounced version provides a web interface for
-system administrators to add/delete/update IPFW rulesets.
+system administrators to add/delete/update FreeBSD IPFW and Linux IpTables
+rulesets, manage routing table and network interfaces.
-You can manage your IPFW firewall via a TCP/IP connected remote PC, easily.
-Development version icludes modules to manage whole
-network services (routing tables, network interfaces)
+You can manage your Firewall via a TCP/IP connected remote PC, easily.
Project Page:
WWW: http://www.enderunix.org/netustad
diff --git a/net-mgmt/netustad/pkg-message b/net-mgmt/netustad/pkg-message
index fbcdf28f4633..a20fcf407163 100644
--- a/net-mgmt/netustad/pkg-message
+++ b/net-mgmt/netustad/pkg-message
@@ -1,7 +1,9 @@
-*************************************************
-* You must run this program as root *
-* Program path : %%PREFIX%%/sbin/netustad *
-* Your AdminUser : admin *
-* Your AdminPassword : admin *
-* Don't forget to change your password! *
-*************************************************
+*****************************************************************
+* You must run this program as root *
+* Program path : %%PREFIX%%/sbin/netustad *
+* Your AdminUser : admin *
+* Your AdminPassword : admin *
+* Config file path : %%PREFIX%%/etc/netustad/netustad.conf *
+* Check lc_all variable in config file. *
+* Don't forget to change your password! *
+*****************************************************************
diff --git a/net-mgmt/netustad/pkg-plist b/net-mgmt/netustad/pkg-plist
index 79124b563694..32b00e290196 100644
--- a/net-mgmt/netustad/pkg-plist
+++ b/net-mgmt/netustad/pkg-plist
@@ -1,31 +1,63 @@
+bin/netustadctl
+bin/netustadpasswd
sbin/netustad
-sbin/netustadctl
-sbin/netustadpasswd
etc/rc.d/netustad.sh
-@unexec if cmp -s %D/etc/netustad.conf %D/etc/netustad.conf-dist; then rm -f %D/etc/netustad.conf; fi
-etc/netustad.conf-dist
-@exec [ -f %B/netustad.conf ] || cp %B/%f %B/netustad.conf
-%%DATADIR%%/script/English
+@unexec if cmp -s %D/etc/netustad/netustad.conf %D/etc/netustad/netustad.conf-dist; then rm -f %D/etc/netustad/netustad.conf; fi
+etc/netustad/netustad.conf-dist
+@exec [ -f %B/netustad/netustad.conf ] || cp %B/%f %B/netustad/netustad.conf
+include/netustad/acceptrequest.h
+include/netustad/addnewrule.h
+include/netustad/auth.h
+include/netustad/common.h
+include/netustad/config.h
+include/netustad/deleterule.h
+include/netustad/editrule.h
+include/netustad/loadconfig.h
+include/netustad/mimetype.h
+include/netustad/netustad.h
+include/netustad/execcgi.h
+include/netustad/network.h
+include/netustad/snprintf.h
+share/locale/tr/LC_MESSAGES/netustad.mo
%%DATADIR%%/script/action1.inc
%%DATADIR%%/script/action2.inc
-%%DATADIR%%/script/addform
-%%DATADIR%%/script/addrule.inc
-%%DATADIR%%/script/authform
%%DATADIR%%/script/edit-parse
-%%DATADIR%%/script/editform
-%%DATADIR%%/script/editrule.inc
-%%DATADIR%%/script/footer
-%%DATADIR%%/script/header
+%%DATADIR%%/script/if-edit
+%%DATADIR%%/script/if-parse
%%DATADIR%%/script/intf-parse
-%%DATADIR%%/script/loadindex
-%%DATADIR%%/script/maketable
+%%DATADIR%%/script/nat-edit
+%%DATADIR%%/script/nat-parse
%%DATADIR%%/script/netustad.css
%%DATADIR%%/script/proto.inc
+%%DATADIR%%/script/rt-edit
+%%DATADIR%%/script/rt-parse
%%DATADIR%%/script/ruleoption1.inc
%%DATADIR%%/script/ruleoption2.inc
%%DATADIR%%/script/service-parse
-%%DATADIR%%/script/showrule
+%%DATADIR%%/script/stats-parse
%%DATADIR%%/script/static-parse
+%%DATADIR%%/script/addform
+%%DATADIR%%/script/authform
+%%DATADIR%%/script/editform
+%%DATADIR%%/script/footer
+%%DATADIR%%/script/header
+%%DATADIR%%/script/if_edit
+%%DATADIR%%/script/if_table
+%%DATADIR%%/script/loadindex
+%%DATADIR%%/script/maketable
+%%DATADIR%%/script/nat_add
+%%DATADIR%%/script/nat_del
+%%DATADIR%%/script/nat_edit
+%%DATADIR%%/script/rt_add
+%%DATADIR%%/script/rt_del
+%%DATADIR%%/script/rt_edit
+%%DATADIR%%/script/rt_table
+%%DATADIR%%/script/shownat
+%%DATADIR%%/script/showrule
+%%DATADIR%%/script/stats
+%%DATADIR%%/script/addrule.content
+%%DATADIR%%/script/editrule.content
+%%DATADIR%%/script/writeconfig
%%DATADIR%%/script/images/action_allow.png
%%DATADIR%%/script/images/action_checkstate.png
%%DATADIR%%/script/images/action_count.png
@@ -56,14 +88,22 @@ etc/netustad.conf-dist
%%DATADIR%%/script/images/menu_login.png
%%DATADIR%%/script/images/menu_logout.png
%%DATADIR%%/script/images/menu_rulelist.png
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%DATADIR%%/cert/netustad.crt
+%%DATADIR%%/cert/netustad.csr
+%%DATADIR%%/cert/netustad.key
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/GPL-License
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/ABOUT-NLS
+@dirrm include/netustad
+@dirrm etc/netustad
+@dirrm share/locale/tr/LC_MESSAGES
@dirrm %%DATADIR%%/script/images
@dirrm %%DATADIR%%/script
+@dirrm %%DATADIR%%/cert
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%