aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netustad
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-07-22 05:48:22 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-07-22 05:48:22 +0000
commitd402db43777badb08745b559e40e9e295848963f (patch)
treea2a3cbcab6d1e73997f453d655b64893f2021878 /net-mgmt/netustad
parentb1a2cec832c9015d6db795a6180e9f2aba29ca68 (diff)
downloadports-d402db43777badb08745b559e40e9e295848963f.tar.gz
ports-d402db43777badb08745b559e40e9e295848963f.zip
To ease the task of network administration,
decrease the likelihood of erronous command execution and to maintain all network services from a central point, EnderUNIX SDT anounces the availability of its 9th open-source tool, netUstad. It has been coded in C language and includes its own HTTP server. The newly anounced version provides a web interface for system administrators to add/delete/update IPFW rulesets. You can manage your IPFW firewall via a TCP/IP connected remote PC, easily. Development version icludes modules to manage whole network services (routing tables, network interfaces) PR: ports/69176 Submitted by: Ozkan KIRIK <ozkan@enderunix.org> Approved by: krion (mentor) (implicitly)
Notes
Notes: svn path=/head/; revision=114396
Diffstat (limited to 'net-mgmt/netustad')
-rw-r--r--net-mgmt/netustad/Makefile23
-rw-r--r--net-mgmt/netustad/distinfo2
-rw-r--r--net-mgmt/netustad/files/netustad.sh.sample56
-rw-r--r--net-mgmt/netustad/pkg-descr20
-rw-r--r--net-mgmt/netustad/pkg-message7
-rw-r--r--net-mgmt/netustad/pkg-plist39
6 files changed, 147 insertions, 0 deletions
diff --git a/net-mgmt/netustad/Makefile b/net-mgmt/netustad/Makefile
new file mode 100644
index 000000000000..8c9299d3c5a7
--- /dev/null
+++ b/net-mgmt/netustad/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: netustad
+# Date created: 4 July 2004
+# Whom: ozkan@enderunix.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= netustad
+PORTVERSION= 0.1.1
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://www.enderunix.org/netustad/
+
+MAINTAINER= ozkan@enderunix.org
+COMMENT= A web based admin tool that manages network services
+
+MAN8= netustad.8 netustadpasswd.8
+MAN5= netustad.conf.5
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
+ @${INSTALL_SCRIPT} ${FILESDIR}/netustad.sh.sample ${PREFIX}/etc/rc.d/
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/netustad/distinfo b/net-mgmt/netustad/distinfo
new file mode 100644
index 000000000000..e8b0618272a9
--- /dev/null
+++ b/net-mgmt/netustad/distinfo
@@ -0,0 +1,2 @@
+MD5 (netustad-0.1.1.tar.gz) = 5446b002d68367239867d4e29f039d81
+SIZE (netustad-0.1.1.tar.gz) = 39334
diff --git a/net-mgmt/netustad/files/netustad.sh.sample b/net-mgmt/netustad/files/netustad.sh.sample
new file mode 100644
index 000000000000..881833ac0ad7
--- /dev/null
+++ b/net-mgmt/netustad/files/netustad.sh.sample
@@ -0,0 +1,56 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: netustad
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD
+#
+# Note:
+# If you are running an rcNG-System (i.e. FreeBSD 5 and later or after
+# having installed the rc_subr-port on an earlier system) you must set
+# "netustad_enable=YES" in either /etc/rc.conf, /etc/rc.conf.local or
+#
+# Please see netustad(8), rc.conf(5) and rc(8) for further details.
+
+unset rcNG
+name="netustad"
+command=/usr/local/sbin/netustad
+extra_commands=reload
+reload_cmd="killall -HUP ${name}"
+stop_cmd="killall ${name}"
+
+if [ -f /etc/rc.subr ]; then
+ . /etc/rc.subr && rcNG=yes
+else
+ if [ -f /usr/local/etc/rc.subr ]; then
+ . /usr/local/etc/rc.subr && rcNG=yes
+ fi
+fi
+
+if [ "${rcNG}" ]; then
+ rcvar=`set_rcvar`
+ load_rc_config ${name}
+ run_rc_command "$1"
+else
+ case $1 in
+ start)
+ if [ -x "${command}" ]; then
+ echo -n ' netustad '
+ ${command}
+ fi
+ ;;
+ stop)
+ if [ -x "${command}" ]; then
+ echo -n ' netustad '
+ ${stop_cmd}
+ fi
+ ;;
+ *)
+ echo "usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+ esac
+ exit 0
+fi
diff --git a/net-mgmt/netustad/pkg-descr b/net-mgmt/netustad/pkg-descr
new file mode 100644
index 000000000000..5ead952f42f2
--- /dev/null
+++ b/net-mgmt/netustad/pkg-descr
@@ -0,0 +1,20 @@
+To ease the task of network administration,
+decrease the likelihood of erronous command execution and
+to maintain all network services from a central point,
+EnderUNIX SDT anounces the availability of its 9th open-source tool,
+netUstad.
+
+It has been coded in C language and includes its own HTTP server.
+The newly anounced version provides a web interface for
+system administrators to add/delete/update IPFW rulesets.
+
+You can manage your IPFW firewall via a TCP/IP connected remote PC, easily.
+Development version icludes modules to manage whole
+network services (routing tables, network interfaces)
+
+Project Page:
+WWW: http://www.enderunix.org/netustad
+
+- Ozkan KIRIK
+ozkan@enderunix.org
+EnderUNIX SDT @ Turkey
diff --git a/net-mgmt/netustad/pkg-message b/net-mgmt/netustad/pkg-message
new file mode 100644
index 000000000000..fbcdf28f4633
--- /dev/null
+++ b/net-mgmt/netustad/pkg-message
@@ -0,0 +1,7 @@
+*************************************************
+* You must run this program as root *
+* Program path : %%PREFIX%%/sbin/netustad *
+* Your AdminUser : admin *
+* Your AdminPassword : admin *
+* Don't forget to change your password! *
+*************************************************
diff --git a/net-mgmt/netustad/pkg-plist b/net-mgmt/netustad/pkg-plist
new file mode 100644
index 000000000000..dc2be8a91653
--- /dev/null
+++ b/net-mgmt/netustad/pkg-plist
@@ -0,0 +1,39 @@
+sbin/netustad
+sbin/netustadctl
+sbin/netustadpasswd
+etc/rc.d/netustad.sh.sample
+@unexec if [ -f %D/etc/rc.d/netustad.sh ]; then rm -f %D/etc/rc.d/netustad.sh; fi
+@unexec if cmp -s %D/etc/netustad.conf %D/etc/netustad.conf-dist; then rm -f %D/etc/netustad.conf; fi
+etc/netustad.conf-dist
+@exec [ -f %B/netustad.conf ] || cp %B/%f %B/netustad.conf
+%%DATADIR%%/script/English
+%%DATADIR%%/script/Turkce
+%%DATADIR%%/script/action1.inc
+%%DATADIR%%/script/action2.inc
+%%DATADIR%%/script/addform
+%%DATADIR%%/script/addrule.inc
+%%DATADIR%%/script/authform
+%%DATADIR%%/script/bg.png
+%%DATADIR%%/script/delete.jpg
+%%DATADIR%%/script/edit-parse
+%%DATADIR%%/script/editform
+%%DATADIR%%/script/editrule.inc
+%%DATADIR%%/script/intf-parse
+%%DATADIR%%/script/loginform.inc
+%%DATADIR%%/script/maketable
+%%DATADIR%%/script/netustad.css
+%%DATADIR%%/script/proto.inc
+%%DATADIR%%/script/ruleoption1.inc
+%%DATADIR%%/script/ruleoption2.inc
+%%DATADIR%%/script/showrule
+%%DATADIR%%/script/static-parse
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/GPL-License
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+@dirrm %%DATADIR%%/script
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%