aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nsca-ng
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-11-01 15:24:14 +0000
committerSteve Wills <swills@FreeBSD.org>2018-11-01 15:24:14 +0000
commit7d797442cb25b1c193b890cf13388ba77a8d6cc8 (patch)
tree51d40925a2c1c748bb62bdbc68c93a65e828eece /net-mgmt/nsca-ng
parent59035efd19ecaecb882453d4bd975203bc2ada3b (diff)
downloadports-7d797442cb25b1c193b890cf13388ba77a8d6cc8.tar.gz
ports-7d797442cb25b1c193b890cf13388ba77a8d6cc8.zip
net-mgmt/nsca-ng: Fix OpenSSL
PR: 231931 Submitted by: Nathan <ndowens@yahoo.com> Approved by: maintainer timeout (alexander@sulfrian.net, >2 weeks)
Notes
Notes: svn path=/head/; revision=483678
Diffstat (limited to 'net-mgmt/nsca-ng')
-rw-r--r--net-mgmt/nsca-ng/Makefile1
-rw-r--r--net-mgmt/nsca-ng/files/patch-src_common_tls.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/net-mgmt/nsca-ng/Makefile b/net-mgmt/nsca-ng/Makefile
index 6b7342aa9733..6d3624981909 100644
--- a/net-mgmt/nsca-ng/Makefile
+++ b/net-mgmt/nsca-ng/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nsca-ng
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nsca-ng.org/download/ http://www.nsca-ng.org/download/
diff --git a/net-mgmt/nsca-ng/files/patch-src_common_tls.c b/net-mgmt/nsca-ng/files/patch-src_common_tls.c
new file mode 100644
index 000000000000..250dd9ffbc0e
--- /dev/null
+++ b/net-mgmt/nsca-ng/files/patch-src_common_tls.c
@@ -0,0 +1,20 @@
+--- src/common/tls.c.orig 2018-10-10 00:47:13 UTC
++++ src/common/tls.c
+@@ -102,6 +102,7 @@
+ #include <ev.h>
+ #include <openssl/conf.h>
+ #include <openssl/err.h>
++#include <openssl/opensslv.h>
+ #include <openssl/ssl.h>
+
+ #include "log.h"
+@@ -419,7 +420,9 @@ initialize_openssl(const SSL_METHOD *method, const cha
+
+ (void)SSL_library_init();
+ SSL_load_error_strings();
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+ (void)atexit(ERR_free_strings);
++#endif
+
+ /*
+ * In earlier versions, we called