aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nsca
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-13 22:47:09 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-13 22:47:09 +0000
commitfcc0151de777da90e8fab26923b5349262183738 (patch)
treeb7109dec51b575db37bf6e5e19ebb7ab20af4d56 /net-mgmt/nsca
parent537ac8e57e4c3c8ebe095ab0372bc9f35747ad54 (diff)
Notes
Diffstat (limited to 'net-mgmt/nsca')
-rw-r--r--net-mgmt/nsca/Makefile40
-rw-r--r--net-mgmt/nsca/distinfo1
-rw-r--r--net-mgmt/nsca/pkg-descr7
-rw-r--r--net-mgmt/nsca/pkg-plist12
4 files changed, 60 insertions, 0 deletions
diff --git a/net-mgmt/nsca/Makefile b/net-mgmt/nsca/Makefile
new file mode 100644
index 000000000000..76d7988fa36d
--- /dev/null
+++ b/net-mgmt/nsca/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: nsca
+# Date created: 2003-11-18
+# Whom: Paul Dlug <paul@nerdlabs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nsca
+PORTVERSION= 2.4
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= nagios
+
+MAINTAINER= paul@nerdlabs.com
+COMMENT= Nagios Service Check Acceptor
+
+BUILD_DEPENDS= ${NAGIOS_DIR}:${PORTSDIR}/net/nagios
+RUN_DEPENDS= ${NAGIOS_DIR}:${PORTSDIR}/net/nagios
+LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/spool/nagios
+
+NAGIOS_DIR= ${LOCALBASE}/libexec/nagios
+CONF_DIR= ${LOCALBASE}/etc/nagios
+
+DOCS= Changelog LEGAL README SECURITY
+
+# NOTE: this port installs into ${LOCALBASE} instead of ${PREFIX}
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/nsca ${NAGIOS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/send_nsca ${NAGIOS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/nsca.cfg ${CONF_DIR}/nsca.cfg.sample
+ ${INSTALL_DATA} ${WRKSRC}/send_nsca.cfg ${CONF_DIR}/send_nsca.cfg.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nsca/distinfo b/net-mgmt/nsca/distinfo
new file mode 100644
index 000000000000..cbc77145878f
--- /dev/null
+++ b/net-mgmt/nsca/distinfo
@@ -0,0 +1 @@
+MD5 (nsca-2.4.tar.gz) = ab58553a87940f574ec54189a43a70bc
diff --git a/net-mgmt/nsca/pkg-descr b/net-mgmt/nsca/pkg-descr
new file mode 100644
index 000000000000..bb5b01afa3a4
--- /dev/null
+++ b/net-mgmt/nsca/pkg-descr
@@ -0,0 +1,7 @@
+The Nagios Service Check Acceptor (NSCA) is used to send service check
+results to a central Nagios server. This consists of the "nsca" daemon
+which runs on the main Nagios server and accepts results and the
+"check_nsca" plugin which is used to send results to the server.
+
+Author: Ethan Galstad
+WWW: http://www.nagios.org/
diff --git a/net-mgmt/nsca/pkg-plist b/net-mgmt/nsca/pkg-plist
new file mode 100644
index 000000000000..a74df080477d
--- /dev/null
+++ b/net-mgmt/nsca/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/LEGAL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/SECURITY
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@comment This port installs into LOCALBASE as opposed to PREFIX
+@cwd %%LOCALBASE%%
+etc/nagios/nsca.cfg.sample
+etc/nagios/send_nsca.cfg.sample
+libexec/nagios/nsca
+libexec/nagios/send_nsca