aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ocsinventory-agent/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-24 14:55:36 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-24 14:55:36 +0000
commit03d5cb4b2b188449c73c9208b7c29b6f4191ddaf (patch)
tree1fbabd6cfc2fc55d10c0b7f323a240ae002ac7e3 /net-mgmt/ocsinventory-agent/Makefile
parent27333072519b646c9b8871dffba523f342b8c605 (diff)
downloadports-03d5cb4b2b188449c73c9208b7c29b6f4191ddaf.tar.gz
ports-03d5cb4b2b188449c73c9208b7c29b6f4191ddaf.zip
Notes
Diffstat (limited to 'net-mgmt/ocsinventory-agent/Makefile')
-rw-r--r--net-mgmt/ocsinventory-agent/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mgmt/ocsinventory-agent/Makefile b/net-mgmt/ocsinventory-agent/Makefile
new file mode 100644
index 000000000000..779d69a7c920
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ocs-unix-agent
+# Date created: 14 August 2007
+# Whom: Dennis Cabooter
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ocsinventory
+PORTVERSION= 0.0.6
+CATEGORIES= net-mgmt
+MASTER_SITES= http://nana.rulezlan.org/~goneri/ocsinventory-agent/
+PKGNAMESUFFIX= -Agent
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= freebsd@rootxs.org
+COMMENT= Keep track of the computers configuration and software
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
+ ${SITE_PERL}/Proc/Daemon.pm:${PORTSDIR}/devel/p5-Proc-Daemon \
+ dmidecode:${PORTSDIR}/sysutils/dmidecode \
+ lspci:${PORTSDIR}/sysutils/pciutils
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>