aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/openlldp
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-06-27 13:54:23 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-06-27 13:54:23 +0000
commite639fcadfa8bb8152a72cb22ef15208bec70eb0c (patch)
treee811c3bb10ffb0857f22b82941248a35e6eb64a1 /net-mgmt/openlldp
parent0ad56eab051c267bb27ccf0749485807d23ab6f0 (diff)
downloadports-e639fcadfa8bb8152a72cb22ef15208bec70eb0c.tar.gz
ports-e639fcadfa8bb8152a72cb22ef15208bec70eb0c.zip
The OpenLLDP project aims to provide a comprehensive implementation of the
IEEE standard 802.1AB Link Layer Discovery Protocol. LLDP is an industry standard protocol designed to supplant proprietary Link-Layer protocols such as Extreme's EDP (Extreme Discovery Protocol) and CDP (Cisco Discovery Protocol). WWW: http://sourceforge.net/projects/openlldp/ PR: ports/113063 Submitted by: Roar Pettersen <roar at uib.no> Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=194336
Diffstat (limited to 'net-mgmt/openlldp')
-rw-r--r--net-mgmt/openlldp/Makefile31
-rw-r--r--net-mgmt/openlldp/distinfo3
-rw-r--r--net-mgmt/openlldp/files/lldpd.862
-rw-r--r--net-mgmt/openlldp/files/lldpd.in33
-rw-r--r--net-mgmt/openlldp/pkg-descr7
5 files changed, 136 insertions, 0 deletions
diff --git a/net-mgmt/openlldp/Makefile b/net-mgmt/openlldp/Makefile
new file mode 100644
index 000000000000..7a2728fa5fe1
--- /dev/null
+++ b/net-mgmt/openlldp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: openlldp
+# Date created: 27 May 2007
+# Whom: Roar Pettersen <roar@uib.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openlldp
+DISTVERSION= 0.3alpha
+CATEGORIES= net-mgmt
+MASTER_SITES= SF
+
+MAINTAINER= roar.pettersen@it.uib.no
+COMMENT= Link Layer Discovery Protocol daemon
+
+GNU_CONFIGURE= yes
+
+USE_RC_SUBR= lldpd
+PLIST_FILES= sbin/lldpd
+
+MAN8= lldpd.8
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^CFLAGS =/CFLAGS +=/g' \
+ ${WRKSRC}/src/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/lldpd ${PREFIX}/sbin
+ ${INSTALL_MAN} ${FILESDIR}/lldpd.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/openlldp/distinfo b/net-mgmt/openlldp/distinfo
new file mode 100644
index 000000000000..e085afc1083c
--- /dev/null
+++ b/net-mgmt/openlldp/distinfo
@@ -0,0 +1,3 @@
+MD5 (openlldp-0.3alpha.tar.gz) = 131abc8c2563d33c4537d1c6dcb5c121
+SHA256 (openlldp-0.3alpha.tar.gz) = 2ecc1967be52078c5357540763e2b3c5ff8554161fe8dcac8952b60a0cd016f1
+SIZE (openlldp-0.3alpha.tar.gz) = 103523
diff --git a/net-mgmt/openlldp/files/lldpd.8 b/net-mgmt/openlldp/files/lldpd.8
new file mode 100644
index 000000000000..db12445127ee
--- /dev/null
+++ b/net-mgmt/openlldp/files/lldpd.8
@@ -0,0 +1,62 @@
+.Dd May 27, 2007
+.Dt lldpd 8
+.Sh NAME
+.Nm lldpd
+.Nd Send Link Layer Discovery Protocol packets over ethernet.
+.Sh SYNOPSIS
+.Nm lldpd
+.Op Fl c
+.Op Fl i Ar interface
+.Op Fl d
+.Op Fl f
+.Op Fl s
+.Sh DESCRIPTION
+The
+.Nm
+utiliy used to generate Link Layer Discovery Protocol packets and
+send them over ethernet.
+.Pp
+The options are as follows:
+.Bl -tag -width Ds
+.It Fl c
+Use the config file <path> instead of the default.
+.It Fl i Ar interface
+set interface, over that packets will be sent
+.It Fl d
+Set debug verbosity
+
+<debug_level> can be any of :
+ A : Enable ALL debug flags.
+ c : Enable CONFIG debug flag.
+ s : Enable STATE debug flag.
+ t : Enable TLV debug flag.
+ i : Enable INT debug flag.
+ n : Enable SNMP debug flag.
+ x : Enable EXCESSIVE debug flag.
+.It Fl f
+Run in forground mode
+.It Fl s
+Remove the existing control socket if found (Should only be used in system init scripts!)
+.El
+.Sh DIAGNOSTICS
+When everything is ok,
+and
+.Nm
+program is started with (default) daemon mode, it justs
+daemonises with return code 0.
+In case of errors they are printed to stderr and program exists
+with non-zero status. Most errors caused by the fact that
+the
+.Nm
+needs access to /dev/bpf*, so it must be started by root, and
+Berkeley Packet Filter must be enabled in kernel (by adding
+.Sy pseudo-device bpf
+into kernel configuration).
+.Sh SEE ALSO
+.Sy http://www.lldp.org/
+for information about Link Layer Discovery Protocol.
+.Sy http://www.tcpdump.org/
+- tcpdump home page.
+.Sh AUTHOR
+OpenLLDP
+http://openlldp.sourceforge.net/
diff --git a/net-mgmt/openlldp/files/lldpd.in b/net-mgmt/openlldp/files/lldpd.in
new file mode 100644
index 000000000000..3c003a699300
--- /dev/null
+++ b/net-mgmt/openlldp/files/lldpd.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: lldpd
+# REQUIRE: NETWORKING
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable lldpd:
+#
+# lldpd_enable="YES"
+#
+# You can define flags for lldpd running. See lldpd(8) for details.
+#
+# Example:
+# lldpd_flags="-i em0"
+
+. %%RC_SUBR%%
+
+name=lldpd
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/$name
+command_args=">/dev/null 2>/dev/null &"
+
+# set defaults
+
+lldpd_enable=${lldpd_enable:-"NO"}
+lldpd_flags=${lldpd_flags:-""}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net-mgmt/openlldp/pkg-descr b/net-mgmt/openlldp/pkg-descr
new file mode 100644
index 000000000000..56bd279b140f
--- /dev/null
+++ b/net-mgmt/openlldp/pkg-descr
@@ -0,0 +1,7 @@
+The OpenLLDP project aims to provide a comprehensive implementation of the
+IEEE standard 802.1AB Link Layer Discovery Protocol. LLDP is an industry
+standard protocol designed to supplant proprietary Link-Layer protocols
+such as Extreme's EDP (Extreme Discovery Protocol) and CDP (Cisco Discovery
+Protocol).
+
+WWW: http://sourceforge.net/projects/openlldp/