aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-GRNOC-TL1
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-28 10:31:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-28 10:31:31 +0000
commitdeaef7983fe8800151aec6d3ccb86d4ef313694c (patch)
treed67a2ee8ff4fa770927361c80ef7babddebb24eb /net-mgmt/p5-GRNOC-TL1
parentf92d19663ba8aa342dc51f3b8ffbcf15d1d54e0e (diff)
downloadports-deaef7983fe8800151aec6d3ccb86d4ef313694c.tar.gz
ports-deaef7983fe8800151aec6d3ccb86d4ef313694c.zip
Notes
Diffstat (limited to 'net-mgmt/p5-GRNOC-TL1')
-rw-r--r--net-mgmt/p5-GRNOC-TL1/Makefile23
-rw-r--r--net-mgmt/p5-GRNOC-TL1/distinfo2
-rw-r--r--net-mgmt/p5-GRNOC-TL1/pkg-descr22
-rw-r--r--net-mgmt/p5-GRNOC-TL1/pkg-plist21
4 files changed, 68 insertions, 0 deletions
diff --git a/net-mgmt/p5-GRNOC-TL1/Makefile b/net-mgmt/p5-GRNOC-TL1/Makefile
new file mode 100644
index 000000000000..e423b2080175
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-TL1/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-GRNOC-TL1
+# Date created: 03 12 2011
+# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GRNOC-TL1
+PORTVERSION= 1.2.2
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= SF/routerproxy/${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Module supports retrieval of data from different models of TL1 devices
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS+= ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-GRNOC-TL1/distinfo b/net-mgmt/p5-GRNOC-TL1/distinfo
new file mode 100644
index 000000000000..6feb0a60d681
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-TL1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (GRNOC-TL1-1.2.2.tar.gz) = bf5bbc98fff95b6f27cd01b64ae3b579f282a4d612e552dae2db499b008aeaa2
+SIZE (GRNOC-TL1-1.2.2.tar.gz) = 15758
diff --git a/net-mgmt/p5-GRNOC-TL1/pkg-descr b/net-mgmt/p5-GRNOC-TL1/pkg-descr
new file mode 100644
index 000000000000..4b96335e5285
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-TL1/pkg-descr
@@ -0,0 +1,22 @@
+This module supports the ability to retrieve data from several
+different models of TL1 devices. Explictly supported devices
+include the following:
+
+* Cisco ONS15327
+* Cisco ONS15454
+* Cisco ONS15808
+* Nortel OME 6500
+* Nortel HDXc
+* Ciena CoreDirector
+* Infinera DTC
+* Fujitsu FLASHWAVE 7500
+
+Each specifically supported device has its own
+GRNOC::TL1::Device module, which sets the default port and
+prompt used for that device. They also may each export their
+own unique commands on top of what is already provided in
+GRNOC::TL1::Device. Raw commands and output can be sent and
+received, or output can be parsed via the parse function, or
+by calling a function for that device.
+
+WWW: http://www.sourceforge.net/projects/routerproxy
diff --git a/net-mgmt/p5-GRNOC-TL1/pkg-plist b/net-mgmt/p5-GRNOC-TL1/pkg-plist
new file mode 100644
index 000000000000..37941878823d
--- /dev/null
+++ b/net-mgmt/p5-GRNOC-TL1/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/GRNOC/TL1.pm
+%%SITE_PERL%%/GRNOC/TL1/Device.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Ciena/CoreDirector.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Cisco/ONS15454.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Cisco/ONS15808.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Fujitsu/FLASHWAVE7500.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Infinera/DTC.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Nortel/HDXc.pm
+%%SITE_PERL%%/GRNOC/TL1/Device/Nortel/OME6500.pm
+%%SITE_PERL%%/GRNOC/TL1/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC/TL1/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC/TL1
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GRNOC
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device/Nortel
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device/Infinera
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device/Fujitsu
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device/Cisco
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device/Ciena
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1/Device
+@dirrmtry %%SITE_PERL%%/GRNOC/TL1
+@dirrmtry %%SITE_PERL%%/GRNOC