aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Mon
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2000-10-31 18:37:15 +0000
committerJim Mock <jim@FreeBSD.org>2000-10-31 18:37:15 +0000
commit52e53bcaef0661bd833a162bfd69000cf4cd6c3e (patch)
tree06d20cccf2fa8ec2e11aa31247807d9948e62fbc /net-mgmt/p5-Mon
parenta3314295b200574d958911dfe3cc4a590f5e0e81 (diff)
downloadports-52e53bcaef0661bd833a162bfd69000cf4cd6c3e.tar.gz
ports-52e53bcaef0661bd833a162bfd69000cf4cd6c3e.zip
Import of p5-Mon.
This is a perl5 module for interfacing with the Mon system monitoring package. Submitted by: Nick Esborn <nick@netdot.net>
Notes
Notes: svn path=/head/; revision=34505
Diffstat (limited to 'net-mgmt/p5-Mon')
-rw-r--r--net-mgmt/p5-Mon/Makefile29
-rw-r--r--net-mgmt/p5-Mon/distinfo1
-rw-r--r--net-mgmt/p5-Mon/pkg-comment1
-rw-r--r--net-mgmt/p5-Mon/pkg-descr7
-rw-r--r--net-mgmt/p5-Mon/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/p5-Mon/Makefile b/net-mgmt/p5-Mon/Makefile
new file mode 100644
index 000000000000..2c7d5e121b58
--- /dev/null
+++ b/net-mgmt/p5-Mon/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Mon
+# Date created: October 30th, 2000
+# Whom: Nicholas Esborn <nick@netdot.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mon
+PORTVERSION= 0.9
+CATEGORIES= net sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mon
+PKGNAMEPREFIX= p5-
+DISTNAME= Mon-${PORTVERSION}
+
+MAINTAINER= nick@netdot.net
+
+USE_PERL5= YES
+
+MAN3= Mon::SNMP.3 \
+ Mon::Client.3 \
+ Mon::Protocol.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Mon/distinfo b/net-mgmt/p5-Mon/distinfo
new file mode 100644
index 000000000000..6f3ec6c8ae16
--- /dev/null
+++ b/net-mgmt/p5-Mon/distinfo
@@ -0,0 +1 @@
+MD5 (Mon-0.9.tar.gz) = 7c8cc3469023a4be52d2552bbd550da1
diff --git a/net-mgmt/p5-Mon/pkg-comment b/net-mgmt/p5-Mon/pkg-comment
new file mode 100644
index 000000000000..bda04ec13b06
--- /dev/null
+++ b/net-mgmt/p5-Mon/pkg-comment
@@ -0,0 +1 @@
+A perl module that supports mon, a network and system monitoring daemon
diff --git a/net-mgmt/p5-Mon/pkg-descr b/net-mgmt/p5-Mon/pkg-descr
new file mode 100644
index 000000000000..5d6b8678a322
--- /dev/null
+++ b/net-mgmt/p5-Mon/pkg-descr
@@ -0,0 +1,7 @@
+This is the Perl5 module for interfacing with the Mon system monitoring
+package. Currently only the client interface is implemented, but more
+things like special logging routines and persistent monitors are being
+considered.
+
+"mon" is a tool for monitoring the availability of services.
+More information can be found at http://www.kernel.org/software/mon/.
diff --git a/net-mgmt/p5-Mon/pkg-plist b/net-mgmt/p5-Mon/pkg-plist
new file mode 100644
index 000000000000..2ecd0782ab22
--- /dev/null
+++ b/net-mgmt/p5-Mon/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mon/SNMP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mon/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/Mon/Protocol.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mon/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mon
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Mon