aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Monitoring-Livestatus
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2019-01-15 16:44:30 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2019-01-15 16:44:30 +0000
commit884fcefcfb3a89c52f3f15583cb057cb50b45014 (patch)
tree4694c491775da192adebfeec9b28258f9842abc7 /net-mgmt/p5-Monitoring-Livestatus
parent806a278701cd1db7a92726978a503f60ca2d385a (diff)
downloadports-884fcefcfb3a89c52f3f15583cb057cb50b45014.tar.gz
ports-884fcefcfb3a89c52f3f15583cb057cb50b45014.zip
[NEW] net-mgmt/p5-Monitoring-Livestatus: Perl API for check_mk livestatus
Perl API for check_mk livestatus to access runtime data from Nagios WWW: https://metacpan.org/release/Monitoring-Livestatus Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D18637
Notes
Notes: svn path=/head/; revision=490387
Diffstat (limited to 'net-mgmt/p5-Monitoring-Livestatus')
-rw-r--r--net-mgmt/p5-Monitoring-Livestatus/Makefile51
-rw-r--r--net-mgmt/p5-Monitoring-Livestatus/distinfo3
-rw-r--r--net-mgmt/p5-Monitoring-Livestatus/pkg-descr7
3 files changed, 61 insertions, 0 deletions
diff --git a/net-mgmt/p5-Monitoring-Livestatus/Makefile b/net-mgmt/p5-Monitoring-Livestatus/Makefile
new file mode 100644
index 000000000000..2845e0663b5f
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Livestatus/Makefile
@@ -0,0 +1,51 @@
+# $FreeBSD$
+
+PORTNAME= Monitoring-Livestatus
+PORTVERSION= 0.80
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:NIERLEIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Perl API for check_mk livestatus
+
+LICENSE= GPLv1+
+LICENSE_FILE= ${WRKSRC}/README
+
+RUN_DEPENDS= p5-Carp>=0:devel/p5-Carp \
+ p5-Cpanel-JSON-XS>=0:converters/p5-Cpanel-JSON-XS \
+ p5-Data-Dumper>=0:devel/p5-Data-Dumper \
+ p5-Digest-MD5>=0:security/p5-Digest-MD5 \
+ p5-Encode>=0:converters/p5-Encode \
+ p5-IO-Socket-IP>=0:net/p5-IO-Socket-IP \
+ p5-Socket>=0:net/p5-Socket \
+ p5-Storable>=0:devel/p5-Storable
+TEST_DEPENDS= p5-Test-More-UTF8>=0:devel/p5-Test-More-UTF8 \
+ p5-Test-Simple>=0:devel/p5-Test-Simple
+
+USES= perl5
+USE_PERL5= configure
+
+PORTDOCS= Changes README
+PORTEXAMPLES= dump.pl test.pl
+
+PLIST_FILES= ${SITE_PERL}/Monitoring/Livestatus.pm \
+ ${SITE_PERL}/Monitoring/Livestatus/INET.pm \
+ ${SITE_PERL}/Monitoring/Livestatus/UNIX.pm \
+ ${SITE_PERL}/man/man3/Monitoring::Livestatus.3.gz \
+ ${SITE_PERL}/man/man3/Monitoring::Livestatus::INET.3.gz \
+ ${SITE_PERL}/man/man3/Monitoring::Livestatus::UNIX.3.gz
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Monitoring-Livestatus/distinfo b/net-mgmt/p5-Monitoring-Livestatus/distinfo
new file mode 100644
index 000000000000..5ef56de75b9d
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Livestatus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545493950
+SHA256 (Monitoring-Livestatus-0.80.tar.gz) = 6dca4affe9004327e6fdc44da3da07766bab17f2d1e329f12e62764609a532a5
+SIZE (Monitoring-Livestatus-0.80.tar.gz) = 53670
diff --git a/net-mgmt/p5-Monitoring-Livestatus/pkg-descr b/net-mgmt/p5-Monitoring-Livestatus/pkg-descr
new file mode 100644
index 000000000000..6c31fd513129
--- /dev/null
+++ b/net-mgmt/p5-Monitoring-Livestatus/pkg-descr
@@ -0,0 +1,7 @@
+Perl API for check_mk livestatus to access runtime data from Nagios and Icinga
+
+This module connects via socket/tcp to the livestatus addon for Naemon, Nagios,
+Icinga and Shinken. You first have to install and activate the livestatus
+addon in your monitoring installation.
+
+WWW: https://metacpan.org/release/Monitoring-Livestatus