aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Nagios-Plugins-Memcached
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:32:26 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-02-17 12:32:26 +0000
commit56a276bcb592def6d3ac8b2f16125ad9785cf703 (patch)
tree6e8ca08efd8d80b0d4916b338ca901095277d97b /net-mgmt/p5-Nagios-Plugins-Memcached
parent159ab3967ccc82309b1bd90d4fe010ad373979a0 (diff)
downloadports-56a276bcb592def6d3ac8b2f16125ad9785cf703.tar.gz
ports-56a276bcb592def6d3ac8b2f16125ad9785cf703.zip
Notes
Diffstat (limited to 'net-mgmt/p5-Nagios-Plugins-Memcached')
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/Makefile37
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/distinfo3
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/files/patch-Makefile.PL11
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/pkg-descr3
-rw-r--r--net-mgmt/p5-Nagios-Plugins-Memcached/pkg-plist9
5 files changed, 63 insertions, 0 deletions
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile b/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
new file mode 100644
index 000000000000..4352dfac79fd
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Nagios-Plugins-Memcached
+# Date created: 18 Dec 2007
+# Whom: Philp M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nagios-Plugins-Memcached
+PORTVERSION= 0.02
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/Z/ZI/ZIGOROU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@p6m7g8.com
+COMMENT= Module to check memcached via nagios
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS+= ${SITE_PERL}/Nagios/Plugin.pm:${PORTSDIR}/net-mgmt/p5-Nagios-Plugin \
+ ${SITE_PERL}/Cache/Memcached.pm:${PORTSDIR}/databases/p5-Cache-Memcached \
+ ${SITE_PERL}/Carp/Clan.pm:${PORTSDIR}/devel/p5-Carp-Clan
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Nagios::Plugins::Memcached.3
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${LOCALBASE}/libexec/nagios
+ ${INSTALL} ${WRKSRC}/bin/check_memcached ${LOCALBASE}/libexec/nagios/check_memcached
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/distinfo b/net-mgmt/p5-Nagios-Plugins-Memcached/distinfo
new file mode 100644
index 000000000000..9d64c1d990c3
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/distinfo
@@ -0,0 +1,3 @@
+MD5 (Nagios-Plugins-Memcached-0.02.tar.gz) = 99154aa60b099a2563f8773f95fd0646
+SHA256 (Nagios-Plugins-Memcached-0.02.tar.gz) = e0dc12870d1336686c509e2a5aff7437b741e1e294f51d06de0ad7d21bad091c
+SIZE (Nagios-Plugins-Memcached-0.02.tar.gz) = 42390
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/files/patch-Makefile.PL b/net-mgmt/p5-Nagios-Plugins-Memcached/files/patch-Makefile.PL
new file mode 100644
index 000000000000..87a4aada5728
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- ./Makefile.PL.orig 2007-12-20 21:29:34.000000000 +0000
++++ ./Makefile.PL 2007-12-20 21:29:46.000000000 +0000
+@@ -12,8 +12,6 @@
+ requires('Nagios::Plugin');
+ requires('Time::HiRes');
+
+-install_script "bin/check_memcached";
+-
+ use_test_base;
+
+ auto_include;
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-descr b/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-descr
new file mode 100644
index 000000000000..70912d03c6d7
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-descr
@@ -0,0 +1,3 @@
+Nagios::Plugins::Memcached - Nagios plugin to observe memcached.
+
+WWW: http://search.cpan.org/dist/Nagios-Plugins-Memcached/
diff --git a/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-plist b/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-plist
new file mode 100644
index 000000000000..bfc01a336df4
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugins-Memcached/pkg-plist
@@ -0,0 +1,9 @@
+libexec/nagios/check_memcached
+%%SITE_PERL%%/Nagios/Plugins/Memcached.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios/Plugins/Memcached/.packlist
+@dirrmtry libexec/nagios
+@dirrmtry %%SITE_PERL%%/Nagios/Plugins
+@dirrmtry %%SITE_PERL%%/Nagios
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios/Plugins
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto