aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-SNMP_Session
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-08-12 11:15:04 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-08-12 11:15:04 +0000
commit39cad529588cf2a6c04dfe7938c3716294bcb62a (patch)
tree956e9ef8df7a23699060f3b25aa2441bed9d2516 /net-mgmt/p5-SNMP_Session
parent5a2b17250f844ede73b94626c16b166e0f390e26 (diff)
downloadports-39cad529588cf2a6c04dfe7938c3716294bcb62a.tar.gz
ports-39cad529588cf2a6c04dfe7938c3716294bcb62a.zip
pack_sockaddr_in6 --> Socket6::pack_sockaddr_in6
PR: 181229 Submitted by: Darren Henderson <darren.henderson@gmail.com>
Notes
Notes: svn path=/head/; revision=324621
Diffstat (limited to 'net-mgmt/p5-SNMP_Session')
-rw-r--r--net-mgmt/p5-SNMP_Session/Makefile2
-rw-r--r--net-mgmt/p5-SNMP_Session/files/patch-SNMP_Session.pm10
2 files changed, 7 insertions, 5 deletions
diff --git a/net-mgmt/p5-SNMP_Session/Makefile b/net-mgmt/p5-SNMP_Session/Makefile
index 2b1cea51df62..4aa224eda8c3 100644
--- a/net-mgmt/p5-SNMP_Session/Makefile
+++ b/net-mgmt/p5-SNMP_Session/Makefile
@@ -3,7 +3,7 @@
PORTNAME= SNMP_Session
PORTVERSION= 1.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt perl5
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= snmp-session
diff --git a/net-mgmt/p5-SNMP_Session/files/patch-SNMP_Session.pm b/net-mgmt/p5-SNMP_Session/files/patch-SNMP_Session.pm
index 1405beccfe19..11534f9e4c18 100644
--- a/net-mgmt/p5-SNMP_Session/files/patch-SNMP_Session.pm
+++ b/net-mgmt/p5-SNMP_Session/files/patch-SNMP_Session.pm
@@ -1,14 +1,16 @@
---- lib/SNMP_Session.pm.orig 2011-01-31 14:10:12.000000000 +0600
-+++ lib/SNMP_Session.pm 2011-01-31 14:11:20.000000000 +0600
-@@ -146,7 +146,7 @@
+--- lib/SNMP_Session.pm.orig 2008-11-21 08:25:17.000000000 +0300
++++ lib/SNMP_Session.pm 2013-08-12 15:13:26.000000000 +0400
+@@ -146,8 +146,8 @@
if (eval {local $SIG{__DIE__};require Socket6;} &&
eval {local $SIG{__DIE__};require IO::Socket::INET6; IO::Socket::INET6->VERSION("1.26");}) {
- import Socket6;
+- $ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
+ Socket6->import(qw(inet_pton inet_ntop getaddrinfo));
- $ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
++ $ipv6_addr_len = length(Socket6::pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
$SNMP_Session::ipv6available = 1;
}
+ eval 'local $SIG{__DIE__};local $SIG{__WARN__};$dont_wait_flags = MSG_DONTWAIT();';
@@ -549,7 +549,7 @@
# complaining about AF_INET6 when Socket6 is not available