aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-jmx4perl/Makefile
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2012-12-06 02:50:17 +0000
committerTom Judge <tj@FreeBSD.org>2012-12-06 02:50:17 +0000
commit83e47a6b8d89ebf9de8228188cfe4fc034a21b65 (patch)
tree542b967158efb2aa98f46c8286dbc867e885324b /net-mgmt/p5-jmx4perl/Makefile
parentf6246255ac16a6cd7a04c47e9dc5b6d02800a6f3 (diff)
downloadports-83e47a6b8d89ebf9de8228188cfe4fc034a21b65.tar.gz
ports-83e47a6b8d89ebf9de8228188cfe4fc034a21b65.zip
Notes
Diffstat (limited to 'net-mgmt/p5-jmx4perl/Makefile')
-rw-r--r--net-mgmt/p5-jmx4perl/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/net-mgmt/p5-jmx4perl/Makefile b/net-mgmt/p5-jmx4perl/Makefile
index bc5e6c3cb86c..9df165aa61af 100644
--- a/net-mgmt/p5-jmx4perl/Makefile
+++ b/net-mgmt/p5-jmx4perl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jmx4perl
PORTVERSION= 1.06
+PORTREVISION= 1
CATEGORIES= net-mgmt perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/R/RO/ROLAND
@@ -94,4 +95,23 @@ MAN3= JMX::Jmx4Perl.3 \
JMX::Jmx4Perl::Response.3 \
JMX::Jmx4Perl::Util.3
+ETC_FILES= common.cfg \
+ glassfish.cfg \
+ jboss.cfg \
+ jetty.cfg \
+ memory.cfg \
+ metrics.cfg \
+ threads.cfg \
+ tomcat.cfg \
+ weblogic.cfg
+
+SUB_FILES= pkg-install pkg-deinstall
+SUB_LIST= ETC_FILES="${ETC_FILES}"
+
+post-install:
+ @${MKDIR} ${ETCDIR}
+.for f in ${ETC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/config/${f} ${ETCDIR}/${f}.sample
+.endfor
+
.include <bsd.port.mk>