aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/packit
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-06-02 16:37:25 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-06-02 16:37:25 +0000
commit86e4952c7e0ac2804feca0b5200fced85c983997 (patch)
treec16c26a03648e43e92deb6e931968bc8eef5614b /net-mgmt/packit
parent34c875ce8c009953a211faa540fd31a790971ee8 (diff)
downloadports-86e4952c7e0ac2804feca0b5200fced85c983997.tar.gz
ports-86e4952c7e0ac2804feca0b5200fced85c983997.zip
New port: packit
Packit is a network auditing tool. PR: 52870 Submitted by: Kirill Ponomarew
Notes
Notes: svn path=/head/; revision=82027
Diffstat (limited to 'net-mgmt/packit')
-rw-r--r--net-mgmt/packit/Makefile40
-rw-r--r--net-mgmt/packit/distinfo1
-rw-r--r--net-mgmt/packit/pkg-descr9
-rw-r--r--net-mgmt/packit/pkg-plist1
4 files changed, 51 insertions, 0 deletions
diff --git a/net-mgmt/packit/Makefile b/net-mgmt/packit/Makefile
new file mode 100644
index 000000000000..34625b3a302e
--- /dev/null
+++ b/net-mgmt/packit/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: packit
+# Date created: 02.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= packit
+PORTVERSION= 0.6.0
+CATEGORIES= net
+MASTER_SITES= http://packit.sourceforge.net/
+DISTNAME= ${PORTNAME}-latest
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Packit is a network auditing tool
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN8= packit.8
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib" \
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""#######################################################
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You need ${PORTSDIR}/net/libnet-devel to build this port
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""#######################################################
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/packit/distinfo b/net-mgmt/packit/distinfo
new file mode 100644
index 000000000000..2759c002afaf
--- /dev/null
+++ b/net-mgmt/packit/distinfo
@@ -0,0 +1 @@
+MD5 (packit-latest.tgz) = fd7436accc01e0dcb127df1f20a457d3
diff --git a/net-mgmt/packit/pkg-descr b/net-mgmt/packit/pkg-descr
new file mode 100644
index 000000000000..d469900dba3e
--- /dev/null
+++ b/net-mgmt/packit/pkg-descr
@@ -0,0 +1,9 @@
+Packit is a network auditing tool. Its value is derived from
+its ability to customize, inject, monitor, and manipulate IP
+traffic. By allowing you to define (spoof) nearly all TCP, UDP,
+ICMP, IP, ARP, RARP, and Ethernet header options, Packit can be
+useful in testing firewalls, intrusion detection systems, port
+scanning, simulating network traffic, and general TCP/IP
+auditing. Packit is also an excellent tool for learning TCP/IP.
+
+WWW: http://packit.sourceforge.net/
diff --git a/net-mgmt/packit/pkg-plist b/net-mgmt/packit/pkg-plist
new file mode 100644
index 000000000000..19ccbf81d682
--- /dev/null
+++ b/net-mgmt/packit/pkg-plist
@@ -0,0 +1 @@
+sbin/packit