aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pftabled
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 11:28:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 11:28:32 +0000
commit5c1bfd69f6048624bf2287c995d3d119ed4d788c (patch)
treedaa919326ccb7f189fd0a15b939e805db0b91dae /net-mgmt/pftabled
parent194a5e08be6942491300a7084db50ad4ae2b8d16 (diff)
downloadports-5c1bfd69f6048624bf2287c995d3d119ed4d788c.tar.gz
ports-5c1bfd69f6048624bf2287c995d3d119ed4d788c.zip
Convert to new options framework
While here do some build with clang fixes PR: ports/178445, ports/178446, ports/178444, ports/178443, ports/178425, ports/178423 Submitted by: "Ilya A. Arkhipov" <rum1cro@yandex.ru>
Notes
Notes: svn path=/head/; revision=317790
Diffstat (limited to 'net-mgmt/pftabled')
-rw-r--r--net-mgmt/pftabled/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-mgmt/pftabled/Makefile b/net-mgmt/pftabled/Makefile
index 727733bf9e5d..3d44c7720f3c 100644
--- a/net-mgmt/pftabled/Makefile
+++ b/net-mgmt/pftabled/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pftabled
-# Date created: 2006-11-21
-# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
-#
+# Created by: Bartlomiej Rutkowski <r@robakdesign.com>
# $FreeBSD$
-#
PORTNAME= pftabled
PORTVERSION= 1.09
@@ -21,19 +17,21 @@ PLIST_FILES= bin/pftabled-client sbin/pftabled
GNU_CONFIGURE= yes
USE_GMAKE= yes
-OPTIONS= PERLC "A Sample Perl Client" on \
- PYTHONC "A Sample Python Client" on
+OPTIONS_DEFINE= PERLC PYTHONC
+OPTIONS_DEFAULT= PERLC PYTHONC
+PERLC_DESC= A Sample Perl Client
+PYTHONC_DESC= A Sample Python Client
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_PERLC)
+.if ${PORT_OPTIONS:MPERLC}
. if ${PERL_LEVEL} < 500703
RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
. endif
PLIST_FILES+= bin/pftabled-client.pl
.endif
-.if !defined(WITHOUT_PYTHONC)
+.if ${PORT_OPTIONS:MPYTHONC}
PLIST_FILES+= bin/pftabled-client.py
.endif
@@ -41,10 +39,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|cat1/pftabled.0|man1/pftabled.0|' ${WRKSRC}/Makefile.in
post-install:
-.if !defined(WITHOUT_PERLC)
+.if ${PORT_OPTIONS:MPERLC}
${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.pl ${PREFIX}/bin/
.endif
-.if !defined(WITHOUT_PYTHONC)
+.if ${PORT_OPTIONS:MPYTHONC}
${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.py ${PREFIX}/bin/
.endif