aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pftabled
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-23 12:02:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-23 12:02:29 +0000
commitaec6dd3dc755b4e09b578ac9f0dbed1c8953e89c (patch)
treecd8bffd0e2155d80013c30c16fe8ce9db8155a3c /net-mgmt/pftabled
parent6e65d26f6e82e2ac8035942b62135525bcf1aed7 (diff)
downloadports-aec6dd3dc755b4e09b578ac9f0dbed1c8953e89c.tar.gz
ports-aec6dd3dc755b4e09b578ac9f0dbed1c8953e89c.zip
Notes
Diffstat (limited to 'net-mgmt/pftabled')
-rw-r--r--net-mgmt/pftabled/Makefile31
-rw-r--r--net-mgmt/pftabled/distinfo3
-rw-r--r--net-mgmt/pftabled/files/patch-Makefile.in11
-rw-r--r--net-mgmt/pftabled/files/pftabled.in29
-rw-r--r--net-mgmt/pftabled/pkg-descr7
5 files changed, 81 insertions, 0 deletions
diff --git a/net-mgmt/pftabled/Makefile b/net-mgmt/pftabled/Makefile
new file mode 100644
index 000000000000..4b8e84bb8c8e
--- /dev/null
+++ b/net-mgmt/pftabled/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pftabled
+# Date created: 2006-11-21
+# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pftabled
+PORTVERSION= 1.06
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.wolfermann.org/
+
+MAINTAINER= r@robakdesign.com
+COMMENT= The pftabled is a tool to manage your pf tables remotely
+
+USE_RC_SUBR= pftabled
+
+MAN1= pftabled.0
+
+PLIST_FILES= bin/pftabled-client sbin/pftabled
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/pftabled/distinfo b/net-mgmt/pftabled/distinfo
new file mode 100644
index 000000000000..2502c0d1a426
--- /dev/null
+++ b/net-mgmt/pftabled/distinfo
@@ -0,0 +1,3 @@
+MD5 (pftabled-1.06.tar.gz) = 27946f75ae8c5f93b8c0c9232215a21c
+SHA256 (pftabled-1.06.tar.gz) = 46a82e70433fca3513600c1f70f7d9e488b8b756a3cfe124f32b103b79becc7b
+SIZE (pftabled-1.06.tar.gz) = 45174
diff --git a/net-mgmt/pftabled/files/patch-Makefile.in b/net-mgmt/pftabled/files/patch-Makefile.in
new file mode 100644
index 000000000000..48e2f08e1887
--- /dev/null
+++ b/net-mgmt/pftabled/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue Nov 21 14:31:41 2006
++++ Makefile.in Tue Nov 21 14:33:13 2006
+@@ -35,7 +35,7 @@
+
+ server-install: pftabled pftabled.cat1
+ ${INSTALL} -s -m 555 pftabled ${sbindir}
+- ${INSTALL} -m 444 pftabled.cat1 ${mandir}/cat1/pftabled.0
++ ${INSTALL} -m 444 pftabled.cat1 ${mandir}/man1/pftabled.0
+
+ client-install: pftabled-client
+ ${INSTALL} -s -m 555 pftabled-client ${bindir}
diff --git a/net-mgmt/pftabled/files/pftabled.in b/net-mgmt/pftabled/files/pftabled.in
new file mode 100644
index 000000000000..1e8110aaf3f7
--- /dev/null
+++ b/net-mgmt/pftabled/files/pftabled.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: pftabled
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable pftabled:
+# pftabled_enable (bool): Set it to "YES" to enable pftabled.
+# Default is "NO".
+# pftabled_flags (flags): Set flags to alter default behaviour of pftabled.
+# Consult with the man page for more info.
+#
+
+. %%RC_SUBR%%
+
+name="pftabled"
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${pftabled_enable="NO"}
+: ${pftabled_flags=""}
+
+command="%%PREFIX%%/sbin/${name}"
+
+run_rc_command "$1"
diff --git a/net-mgmt/pftabled/pkg-descr b/net-mgmt/pftabled/pkg-descr
new file mode 100644
index 000000000000..f917c613c333
--- /dev/null
+++ b/net-mgmt/pftabled/pkg-descr
@@ -0,0 +1,7 @@
+The pftabled daemon is a small helper to make your pf
+tables reachable from other hosts. You can add/delete/flush
+IP addresses to/from a remote table with a single UDP
+datagram. A simple client program is included to do this
+from the command line.
+
+WWW: http://wolfermann.org/pftabled.html