aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-junos-eznc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:14:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:14:35 +0000
commit7e3fbd3fd1ada17b3e1c37106c74ce4028e5dc7f (patch)
treee039b12f6b69c633bd4d616d1798c6320fac67bf /net-mgmt/py-junos-eznc
parent353ae8d0b2878ccb827ac031b2133a77588e2b6e (diff)
downloadports-7e3fbd3fd1ada17b3e1c37106c74ce4028e5dc7f.tar.gz
ports-7e3fbd3fd1ada17b3e1c37106c74ce4028e5dc7f.zip
New port: net-mgmt/py-junos-eznc: Junos easy automation for non-programmers
PR: 224343 Submitted by: Sergey Akhmatov <sergey@akhmatov.ru>
Notes
Notes: svn path=/head/; revision=466528
Diffstat (limited to 'net-mgmt/py-junos-eznc')
-rw-r--r--net-mgmt/py-junos-eznc/Makefile28
-rw-r--r--net-mgmt/py-junos-eznc/distinfo3
-rw-r--r--net-mgmt/py-junos-eznc/pkg-descr15
3 files changed, 46 insertions, 0 deletions
diff --git a/net-mgmt/py-junos-eznc/Makefile b/net-mgmt/py-junos-eznc/Makefile
new file mode 100644
index 000000000000..36699b5829e9
--- /dev/null
+++ b/net-mgmt/py-junos-eznc/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= junos-eznc
+DISTVERSION= 2.1.7
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sergey@akhmatov.ru
+COMMENT= Junos easy automation for non-programmers
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.7.1:devel/py-Jinja2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.2.4:devel/py-lxml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ncclient>=0.5.3:net-mgmt/py-ncclient@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=1.15.2:security/py-paramiko@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scp>=0.7.0:security/py-scp@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.10:devel/py-yaml@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-junos-eznc/distinfo b/net-mgmt/py-junos-eznc/distinfo
new file mode 100644
index 000000000000..539290711efb
--- /dev/null
+++ b/net-mgmt/py-junos-eznc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513269828
+SHA256 (junos-eznc-2.1.7.tar.gz) = 95a037cdd05618a189517357e46a06886909a18c7923b628c6ac43d5f54b2912
+SIZE (junos-eznc-2.1.7.tar.gz) = 107811
diff --git a/net-mgmt/py-junos-eznc/pkg-descr b/net-mgmt/py-junos-eznc/pkg-descr
new file mode 100644
index 000000000000..c3ddb410a8ab
--- /dev/null
+++ b/net-mgmt/py-junos-eznc/pkg-descr
@@ -0,0 +1,15 @@
+Junos PyEZ is a Python library to remotely manage/automate Junos
+devices.
+
+Junos PyEZ is designed to provide the same capabilities as a user
+would have on the Junos CLI, but in an environment built for
+automation tasks. These capabilities include, but are not limited to:
+- Remote connectivity and management of Junos devices via NETCONF
+- Provide "facts" about the device such as software-version, serial-number, etc
+- Retrieve "operational" or "run-state" information as Tables/Views
+- Retrieve configuration information as Tables/Views
+- Make configuration changes in unstructured and structured ways
+- Provide common utilities for tasks such as secure copy of files and software
+ updates
+
+WWW: https://github.com/Juniper/py-junos-eznc